libdevil-devel-1.7.8-16.mga4.i586.rpm


Advertisement

Description

libdevil-devel - Development headers and libraries for writing programs using DevIL

Property Value
Distribution Mageia 4.1
Repository Mageia Core i586
Package name libdevil-devel
Package version 1.7.8
Package release 16.mga4
Package architecture i586
Package type rpm
Installed size 81.07 KB
Download size 38.06 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Development headers and libraries for writing programs using DevIL.

Alternatives

Package Version Architecture Repository
libdevil-devel - - -

Requires

Name Value
devel(libGL) -
devel(libGLU) -
devel(libHalf) -
devel(libIL) -
devel(libILU) -
devel(libIlmImf-Imf_2_0) -
devel(libSDL-1.2) -
devel(libX11) -
devel(libXext) -
devel(liballeg) -
devel(libgcc_s) -
devel(libjasper) -
devel(libjpeg) -
devel(liblcms) -
devel(libm) -
devel(libmng) -
devel(libpng16) -
devel(libstdc++) -
devel(libtiff) -
libdevil1 == 1.7.8-16.mga4
pkgconfig -
pkgconfig(IL) -

Provides

Name Value
devel(libIL) -
devel(libILU) -
devel(libILUT) -
devil-devel == 1.7.8-16.mga4
libdevil-devel == 1.7.8-16.mga4
libdevil-devel(x86-32) == 1.7.8-16.mga4
pkgconfig(IL) == 1.7.8
pkgconfig(ILU) == 1.7.8
pkgconfig(ILUT) == 1.7.8

Obsoletes

Name Value
libdevil-static-devel < 1.7.8-10
libdevil1-devel -

Download

Type URL
Binary Package libdevil-devel-1.7.8-16.mga4.i586.rpm
Source Package devil-1.7.8-16.mga4.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libdevil-devel rpm package:
    # urpmi libdevil-devel

Files

Path
/usr/include/IL/devil_cpp_wrapper.hpp
/usr/include/IL/il.h
/usr/include/IL/ilu.h
/usr/include/IL/ilu_region.h
/usr/include/IL/ilut.h
/usr/lib/libIL.so
/usr/lib/libILU.so
/usr/lib/libILUT.so
/usr/lib/pkgconfig/IL.pc
/usr/lib/pkgconfig/ILU.pc
/usr/lib/pkgconfig/ILUT.pc
/usr/share/info/DevIL_manual.info.xz

Changelog

2013-10-19 - umeabot <umeabot> 1.7.8-16.mga4
+ Revision: 534411
- Mageia 4 Mass Rebuild
2013-09-12 - fwang <fwang> 1.7.8-15.mga4
+ Revision: 477839
- rebuild for new ilmbase
2013-08-27 - tv <tv> 1.7.8-14.mga4
+ Revision: 472376
- rebuild for new libmng
2013-06-02 - fwang <fwang> 1.7.8-13.mga4
+ Revision: 434722
- rebuild for new libpng
2013-04-07 - rtp <rtp> 1.7.8-12.mga3
+ Revision: 408943
- fix configure args
2013-01-11 - umeabot <umeabot> 1.7.8-11.mga3
+ Revision: 348736
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
2012-01-10 - wally <wally> 1.7.8-10.mga3
+ Revision: 194728
- fix CVE-2009-3994 (better late than never)
- disable static build and drop -static-devel pkg
- use an ugly CPPFLAGS workaround to get pkg build (temporary)
+ dmorgan <dmorgan>
- Fix provides in the devel packages
+ fwang <fwang>
- fix linkage
- rebuild for new tiff
2011-10-03 - fwang <fwang> 1.7.8-9.mga2
+ Revision: 151166
- drop .la files
2011-09-10 - fwang <fwang> 1.7.8-8.mga2
+ Revision: 142180
- remove deprecated symbol
- rebuild for new libpng
2011-07-18 - dmorgan <dmorgan> 1.7.8-7.mga2
+ Revision: 125821
- Rebuild against new directfb

See Also

Package Description
libdevil1-1.7.8-16.mga4.i586.rpm Libraries needed for programs using DevIL
libdevmapper-devel-1.02.82-2.mga4.i586.rpm Device mapper development library
libdevmapper-event-devel-1.02.82-2.mga4.i586.rpm Device mapper event development library
libdevmapper-event1.02-1.02.82-2.mga4.i586.rpm Device mapper event library
libdevmapper1.02-1.02.82-2.mga4.i586.rpm Device mapper library
libdfb++-devel-1.2.0-14.mga4.i586.rpm Headers for developing programs that will use DFB++
libdfb++1.2_0-1.2.0-14.mga4.i586.rpm C++ binding for DirectFB providing a much easier usage
libdhash-devel-0.4.3-5.mga4.i586.rpm Development files for libdhash
libdhash1-0.4.3-5.mga4.i586.rpm Dynamic hash table
libdiffie-devel-0.10.49-21.mga4.i586.rpm Static version of the diffie library
libdiffie1-0.10.49-21.mga4.i586.rpm The diffie library, necessary to run mirrordir
libdigidoc-3.7.2-2.mga4.i586.rpm Library for handling digitally signed documents
libdigidoc-devel-3.7.2-2.mga4.i586.rpm Development files for libdigidoc
libdigidoc2-3.7.2-2.mga4.i586.rpm Library for handling digitally signed documents
libdigidocpp-3.7.2-2.mga4.i586.rpm Library for creating and validating BDoc and DDoc containers
Advertisement
Advertisement