libmagic-devel-5.16-1.mga4.i586.rpm


Advertisement

Description

libmagic-devel - Development files to build applications that handle magic files

Property Value
Distribution Mageia 4.1
Repository Mageia Core i586
Package filename libmagic-devel-5.16-1.mga4.i586.rpm
Package name libmagic-devel
Package version 5.16
Package release 1.mga4
Package architecture i586
Package type rpm
Category Development/C
Homepage http://www.darwinsys.com/file/
License BSD
Maintainer -
Download size 16.06 KB
Installed size 23.68 KB
The file command is used to identify a particular file according to the
type of data contained by the file.  File can identify many different
file types, including ELF binaries, system libraries, RPM packages, and
different graphics formats.
Libmagic is a library for handling the so called magic files the 'file'
command is based on.

Alternatives

Package Version Architecture Repository
libmagic-devel-5.16-1.10.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic-devel-5.16-1.9.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic-devel-5.16-1.7.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic-devel-5.16-1.6.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic-devel-5.16-1.5.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic-devel-5.16-1.4.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic-devel-5.16-1.3.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic-devel-5.16-1.2.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic-devel-5.16-1.1.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic-devel - - -

Requires

Name Value
devel(libz) -
libmagic1 == 5.16

Provides

Name Value
devel(libmagic) -
file-devel == 5.16-1.mga4
libmagic-devel == 5.16-1.mga4
libmagic-devel(x86-32) == 5.16-1.mga4
libmagic1-devel == 0:5.16-1.mga4
magic-devel == 5.16-1.mga4

Obsoletes

Name Value
libmagic1-devel <= 0:5.16-1.mga4

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libmagic-devel-5.16-1.mga4.i586.rpm
Source Package file-5.16-1.mga4.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libmagic-devel rpm package:
    # urpmi libmagic-devel

Files

Path
/usr/include/file.h
/usr/include/magic.h
/usr/lib/libmagic.la
/usr/lib/libmagic.so
/usr/share/man/man3/libmagic.3.xz

Changelog

2013-12-05 - luigiwalser <luigiwalser> 5.16-1.mga4
+ Revision: 555409
- 5.16
2013-10-22 - umeabot <umeabot> 5.15-4.mga4
+ Revision: 543108
- Mageia 4 Mass Rebuild
2013-10-15 - danf <danf> 5.15-3.mga4
+ Revision: 498356
- Added a version dependency on the library, since it expects the specific
magic file format version provided in the corresponding main package
2013-10-14 - pterjan <pterjan> 5.15-2.mga4
+ Revision: 497751
- Rebuild to add different pythonegg provides for python 2 and 3
2013-09-25 - luigiwalser <luigiwalser> 5.15-1.mga4
+ Revision: 485759
- 5.15
- rediff patches 8, 9, and 13
- remove upstreamed sticky bit patch
2013-03-22 - luigiwalser <luigiwalser> 5.14-1.mga4
+ Revision: 404478
- 5.14
- 5.13
- remove upstream patches
2013-01-11 - umeabot <umeabot> 5.12-8.mga3
+ Revision: 350297
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
2013-01-11 - blino <blino> 5.12-7.mga3
+ Revision: 344908
- add back ELF detection patch, it got detected as reversed because of a modified RCSID
2013-01-10 - luigiwalser <luigiwalser> 5.12-6.mga3
+ Revision: 344756
- fix misdetection as assembler text (upstream)
2013-01-09 - blino <blino> 5.12-5.mga3
+ Revision: 344311
- drop merged patches
- use updated (!) upstream 5.12 tarball

See Also

Package Description
libmagic-static-devel-5.16-1.mga4.i586.rpm Static library to build applications that handle magic files
libmagic1-5.16-1.mga4.i586.rpm Shared library for handling magic files
libmagick++-6Q16_3-6.8.7.0-2.mga4.i586.rpm ImageMagick libraries
libmagick-6Q16_1-6.8.7.0-2.mga4.i586.rpm ImageMagick libraries
libmagick-devel-6.8.7.0-2.mga4.i586.rpm Static libraries and header files for ImageMagick app development
libmailcommon4-4.11.4-2.mga4.i586.rpm KDEPIM 4 library
libmaildir4-4.11.4-3.mga4.i586.rpm KDEPIM 4 library
libmailimporter4-4.11.4-2.mga4.i586.rpm Mail Importer Library
libmailtransport4-4.11.4-1.mga4.i586.rpm KDE 4 core library
libmaitretarot-devel-0.1.98-14.mga4.i586.rpm Development files from Libmaitretarot
libmaitretarot0-0.1.98-14.mga4.i586.rpm The Maitretarot library
libmal-devel-0.44.1-7.mga4.i586.rpm Development tools for programs which will use the libmal library
libmal-malsync-0.44.1-7.mga4.i586.rpm Utility to update Palms from Avantgo and MobileLink web site
libmal1-0.44.1-7.mga4.i586.rpm MAL library for AvantGo
libmalaga-devel-7.12-10.mga4.i586.rpm Headers and static libraries for Malaga development
Advertisement
Advertisement