libselinux1-2.1.13-2.mga4.i586.rpm


Advertisement

Description

libselinux1 - SELinux library and simple utilities

Property Value
Distribution Mageia 4.1
Repository Mageia Core i586
Package name libselinux1
Package version 2.1.13
Package release 2.mga4
Package architecture i586
Package type rpm
Installed size 133.60 KB
Download size 58.66 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
libselinux provides an API for SELinux applications to get and set
process and file security contexts and to obtain security policy
decisions. Required for any applications that use the SELinux API.

Alternatives

Package Version Architecture Repository
libselinux1 - - -

Requires

Name Value
filesystem >= 2.1.9
ld-linux.so.2 -
ld-linux.so.2(GLIBC_2.3) -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.2) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.2.3) -
libc.so.6(GLIBC_2.2.4) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.2) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.7) -
libc.so.6(GLIBC_2.8) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libpcre.so.1 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.2) -

Provides

Name Value
libselinux == 2.1.13-2.mga4
libselinux.so.1 -
libselinux1 == 2.1.13-2.mga4
libselinux1(x86-32) == 2.1.13-2.mga4
selinux == 2.1.13-2.mga4

Download

Type URL
Binary Package libselinux1-2.1.13-2.mga4.i586.rpm
Source Package libselinux-2.1.13-2.mga4.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libselinux1 rpm package:
    # urpmi libselinux1

Files

Path
/usr/lib/libselinux.so.1

Changelog

2013-10-19 - umeabot <umeabot> 2.1.13-2.mga4
+ Revision: 535968
- Mageia 4 Mass Rebuild
2013-02-26 - spuhler <spuhler> 2.1.13-1.mga4
+ Revision: 400401
- upgrade to 2.1.13
* audit2why: make sure path is nul terminated
*utils: new file context regex compiler
*label_file: use precompiled filecontext when possible
*do not leak mmapfd
*sefcontontext_compile: Add error handling to help debug problems in libsemanage.
*man: make selinux.8 mention service man pages
*audit2why: Fix segfault if finish() called twice
*audit2why: do not leak on multiple init() calls
*mode_to_security_class: interface to translate a mode_t in to a security class
*audit2why: Cleanup audit2why analysys function
*man: Fix program synopsis and function prototypes in man pages
*man: Fix man pages formatting
*man: Fix typo in man page
*man: Add references and man page links to _raw function variants
*Use ENOTSUP instead of EOPNOTSUPP for getfilecon functions
*man: context_new(3): fix the return value description
*selinux_status_open: handle error from sysconf
*selinux_status_open: do not leak statusfd on exec
*Fix errors found by coverity
*Change boooleans.subs to booleans.subs_dist.
*optimize set*con functions
*pkg-config do not specifc ruby version
*unmap file contexts on selabel_close()
*do not leak file contexts with mmap'd backend
*sefcontext_compile: do not leak fd on error
*matchmediacon: do not leak fd
*src/label_android_property: do not leak fd on error
- updated patch from rhat for 2.1.13
2013-01-12 - umeabot <umeabot> 2.1.12-3.mga3
+ Revision: 358137
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
2012-12-02 - spuhler <spuhler> 2.1.12-2.mga3
+ Revision: 324836
- reversed to filesystem >=2.1.9 for the time being
2012-12-02 - spuhler <spuhler> 2.1.12-1.mga3
+ Revision: 324734
- added BuilRequires: pcre-devel
- upgrade to 2.1.12
arranged spec file to make it build
- added selinixdefcon file
- added selinuxconlist file
2012-09-17 - fwang <fwang> 2.1.11-2.mga3
+ Revision: 294805
- update file list
- force regenerate symlink
2012-07-21 - colin <colin> 2.1.11-1.mga3
+ Revision: 273164
- Add BuildRequire for swig
- New version: 2.1.11
- Update for usrmove
+ tv <tv>
- new release
- new release
2011-02-11 - dmorgan <dmorgan> 2.0.78-3.mga1
+ Revision: 50036
- Remove mdv macros
- imported package libselinux
2010-11-12 - Funda Wang <fwang@mandriva.org> 2.0.78-3mdv2011.0
+ Revision: 596436
- fix build

See Also

Package Description
libsemanage-devel-2.1.10-2.mga4.i586.rpm Header files and libraries used to build policy manipulation tools
libsemanage-static-devel-2.1.10-2.mga4.i586.rpm Static libraries used to build policy manipulation tools
libsemanage1-2.1.10-2.mga4.i586.rpm SELinux binary policy manipulation library
libsendlater4-4.11.4-2.mga4.i586.rpm KDEPIM 4 library
libsepol-devel-2.1.9-3.mga4.i586.rpm Header files and libraries used to build policy manipulation tools
libsepol-static-devel-2.1.9-3.mga4.i586.rpm Static libraries used to build policy manipulation tools
libsepol1-2.1.9-3.mga4.i586.rpm SELinux binary policy manipulation library
libserd-devel-0.18.2-3.mga4.i586.rpm Headers for the Lightweight RDF syntax library
libserd0_0-0.18.2-3.mga4.i586.rpm Lightweight RDF syntax library
libserf-devel-1.3.2-2.mga4.i586.rpm Development libraries and headers for serf
libserf1-1.3.2-2.mga4.i586.rpm A high-performance asynchronous HTTP client library
libserializer-1.1.6-7.mga4.noarch.rpm JFreeReport General Serialization Framework
libserializer-javadoc-1.1.6-7.mga4.noarch.rpm Javadoc for libserializer
libsexy-devel-0.1.11-13.mga4.i586.rpm Collection of widgets for GTK+
libsexy2-0.1.11-13.mga4.i586.rpm Collection of widgets for GTK+
Advertisement
Advertisement