ocaml-archive-2.8.4+2-5.mga4.i586.rpm


Advertisement

Description

ocaml-archive - Binding to libarchive

Distribution: Mageia 4.1
Repository: Mageia Core i586
Package name: ocaml-archive
Package version: 2.8.4+2
Package release: 5.mga4
Package architecture: i586
Package type: rpm
Installed size: 109.76 KB
Download size: 37.27 KB
Official Mirror: distrib-coffee.ipsl.jussieu.fr
libarchive is a C library for reading and writing tar, cpio, zip, ISO, and other archive formats. This library is its OCaml bindings. * Reads a variety of formats, including tar, pax, cpio, zip, xar, lha, ar, cab, mtree, and ISO images. * Writes tar, pax, cpio, zip, xar, ar, ISO, mtree, and shar archives. * Full automatic format detection when reading archives, including compressed archives. libarchive website: http://code.google.com/p/libarchive/

Alternatives

Provides

  • dllarchive-ocaml_stubs.so
  • ocaml-archive == 2.8.4+2-5.mga4
  • ocaml-archive(x86-32) == 2.8.4+2-5.mga4

    Install Howto

    1. Enable Mageia Core repository on "Install and Remove Software"
    2. Update packages list:
      # urpmi.update -a
    3. Install ocaml-archive rpm package:
      # urpmi ocaml-archive

    Files

    • /usr/lib/ocaml/archive/Archive.cmi
    • /usr/lib/ocaml/archive/ArchiveLow.cmi
    • /usr/lib/ocaml/archive/ArchiveLwt.cmi
    • /usr/lib/ocaml/archive/META
    • /usr/lib/ocaml/archive/archive-lwt.cma
    • /usr/lib/ocaml/archive/archive-lwt.cmxs
    • /usr/lib/ocaml/archive/archive-ocaml.cma
    • /usr/lib/ocaml/archive/archive-ocaml.cmxs
    • /usr/lib/ocaml/stublibs/dllarchive-ocaml_stubs.so
    • /usr/lib/ocaml/stublibs/dllarchive-ocaml_stubs.so.owner
    • /usr/share/doc/ocaml-archive/AUTHORS.txt
    • /usr/share/doc/ocaml-archive/README.txt

    Changelog

    2013-10-21 - umeabot <umeabot> 2.8.4+2-5.mga4 + Revision: 537837 - Mageia 4 Mass Rebuild

    2013-09-27 - blue_prawn <blue_prawn> 2.8.4+2-4.mga4 + Revision: 487931 - rebuild for ocaml-4.01.0

    2013-06-28 - fwang <fwang> 2.8.4+2-3.mga4 + Revision: 447782 - rebuild for new libarchive

    2013-03-28 - blue_prawn <blue_prawn> 2.8.4+2-2.mga4 + Revision: 406061 - try to fix libarchive dependency - try to fix libarchive dependency

    2013-03-19 - blue_prawn <blue_prawn> 2.8.4+2-1.mga3 + Revision: 404114 - s/curses/ncurses/ - build requires libcurses-devel - build requires libarchive-devel - build requires fileutils and extlib - build requires ounit - build requires lwt - imported package ocaml-archive

    Advertisement
    Advertisement