perl-LWP-Protocol-PSGI-0.60.0-2.mga4.noarch.rpm


Advertisement

Description

perl-LWP-Protocol-PSGI - Override LWP's HTTP/HTTPS backend with your own PSGI applciation

Property Value
Distribution Mageia 4.1
Repository Mageia Core i586
Package name perl-LWP-Protocol-PSGI
Package version 0.60.0
Package release 2.mga4
Package architecture noarch
Package type rpm
Installed size 18.85 KB
Download size 13.14 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
LWP::Protocol::PSGI is a module to hijack *any* code that uses the
LWP::UserAgent manpage underneath such that any HTTP or HTTPS requests can
be routed to your own PSGI application.
Because it works with any code that uses LWP, you can override various
WWW::*, Net::* or WebService::* modules such as the WWW::Mechanize manpage,
without modifying the calling code or its internals.
use WWW::Mechanize;
use LWP::Protocol::PSGI;

Alternatives

Package Version Architecture Repository
perl-LWP-Protocol-PSGI-0.60.0-2.mga4.noarch.rpm 0.60.0 noarch Mageia Core
perl-LWP-Protocol-PSGI - - -

Requires

Name Value
perl(Guard) -
perl(HTTP::Message::PSGI) -
perl(LWP) >= 5.0.0
perl(LWP::Protocol) -
perl(parent) -
perl-base >= 2:5.18.1

Provides

Name Value
perl(LWP::Protocol::PSGI) == 0.60.0
perl-LWP-Protocol-PSGI == 0.60.0-2.mga4

Download

Type URL
Binary Package perl-LWP-Protocol-PSGI-0.60.0-2.mga4.noarch.rpm
Source Package perl-LWP-Protocol-PSGI-0.60.0-2.mga4.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-LWP-Protocol-PSGI rpm package:
    # urpmi perl-LWP-Protocol-PSGI

Files

Path
/usr/lib/perl5/vendor_perl/5.18.1/LWP/
/usr/lib/perl5/vendor_perl/5.18.1/LWP/Protocol/PSGI.pm
/usr/share/doc/perl-LWP-Protocol-PSGI/Changes
/usr/share/doc/perl-LWP-Protocol-PSGI/META.yml
/usr/share/doc/perl-LWP-Protocol-PSGI/MYMETA.yml
/usr/share/doc/perl-LWP-Protocol-PSGI/README
/usr/share/man/man3/LWP::Protocol::PSGI.3pm.xz

Changelog

2013-10-21 - umeabot <umeabot> 0.60.0-2.mga4
+ Revision: 537257
- Mageia 4 Mass Rebuild
2013-09-26 - sander85 <sander85> 0.60.0-1.mga4
+ Revision: 486651
- update to 0.06
2013-01-13 - umeabot <umeabot> 0.40.0-2.mga3
+ Revision: 368918
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
2013-01-08 - jquelin <jquelin> 0.40.0-1.mga3
+ Revision: 342358
- update to 0.04
2012-08-31 - kharec <kharec> 0.30.0-1.mga3
+ Revision: 286216
- update to 0.03
2011-10-07 - jquelin <jquelin> 0.20.0-1.mga2
+ Revision: 152748
- imported package perl-LWP-Protocol-PSGI
2011-10-07 - cpan2dist 0.02-1mga
- initial mageia release, generated with cpan2dist

See Also

Package Description
perl-LWP-Protocol-https-6.40.0-2.mga4.noarch.rpm Provide https support for LWP::UserAgent
perl-LWP-UserAgent-Determined-1.60.0-3.mga4.noarch.rpm A virtual browser that retries errors
perl-LWPx-ParanoidAgent-1.100.0-1.mga4.noarch.rpm Paranoid subclass of LWP::UserAgent
perl-LWPx-TimedHTTP-1.800.0-3.mga4.noarch.rpm time the different stages of an HTTP request
perl-LaTeX-Driver-0.120.0-3.mga4.noarch.rpm Driver to run LaTeX, bibtex and makeindex
perl-LaTeX-Encode-0.80.0-3.mga4.noarch.rpm Encode LaTeX special chars for typesetting
perl-LaTeX-Table-1.0.6-4.mga4.noarch.rpm Automatic generation of LaTeX tables
perl-LaTeX-TikZ-0.20.0-3.mga4.noarch.rpm Type constraint metaclass that autoloads type coercions
perl-Language-Befunge-4.130.0-3.mga4.noarch.rpm A generic funge interpreter
perl-Language-Befunge-Storage-Generic-Vec-XS-0.30.0-7.mga4.i586.rpm Language::Befunge::Storage::Generic::Vec rewritten for speed
perl-Language-Befunge-Vector-XS-1.1.1-7.mga4.i586.rpm Language::Befunge::Vector rewritten for speed
perl-Language-Ook-1.0.2-4.mga4.noarch.rpm An Ook! interpreter
perl-Lchown-1.10.0-5.mga4.i586.rpm Use the lchown(2) system call from Perl
perl-Lemonldap-NG-Cli-0.200.0-3.mga4.noarch.rpm Configure LemonLDAP::NG via the command line
perl-Lexical-Persistence-1.23.0-2.mga4.noarch.rpm Bind lexicals to persistent data
Advertisement
Advertisement