perl-Module-CPANTS-Analyse-0.920.0-2.mga4.noarch.rpm


Advertisement

Description

perl-Module-CPANTS-Analyse - Generate Kwalitee ratings for a distribution

Property Value
Distribution Mageia 4.1
Repository Mageia Core i586
Package name perl-Module-CPANTS-Analyse
Package version 0.920.0
Package release 2.mga4
Package architecture noarch
Package type rpm
Installed size 178.54 KB
Download size 55.96 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Kwalitee is an automatically-measurable gauge of how good your software is.
That's very different from quality, which a computer really can't measure in a
general sense. (If you can, you've solved a hard problem in computer science.)
In the world of the CPAN, the CPANTS project (CPAN Testing Service; also a
funny acronym on its own) measures Kwalitee with several metrics. If you plan
to release a distribution to the CPAN -- or even within your own organization
-- testing its Kwalitee before creating a release can help you improve your
quality as well.
Test::Kwalitee and a short test file will do this for you automatically.

Alternatives

Package Version Architecture Repository
perl-Module-CPANTS-Analyse-0.920.0-2.mga4.noarch.rpm 0.920.0 noarch Mageia Core
perl-Module-CPANTS-Analyse - - -

Requires

Name Value
perl(Archive::Any::Lite) >= 0.60.0
perl(Archive::Tar) >= 1.480.0
perl(Array::Diff) >= 0.40.0
perl(CPAN::DistnameInfo) >= 0.60.0
perl(CPAN::Meta::Validator) >= 2.131.490
perl(CPAN::Meta::YAML) >= 0.8.0
perl(Class::Accessor) >= 0.190.0
perl(Cwd) -
perl(File::Find::Rule::VCS) -
perl(IO::Capture) >= 0.50.0
perl(Module::ExtractUse) >= 0.300.0
perl(Module::Pluggable) >= 2.960.0
perl(Set::Scalar) -
perl(Software::License) >= 0.3.0
perl(Test::Deep) -
perl(Test::More) -
perl(Test::NoWarnings) -
perl(Test::Warn) >= 0.110.0
perl(Text::Balanced) -
perl(YAML::Any) -
perl(version) >= 0.730.0
perl-base >= 2:5.18.1

Provides

Name Value
perl(Module::CPANTS::Analyse) == 0.920.0
perl(Module::CPANTS::Kwalitee) == 0.920.0
perl(Module::CPANTS::Kwalitee::BrokenInstaller) == 0.920.0
perl(Module::CPANTS::Kwalitee::CpantsErrors) == 0.920.0
perl(Module::CPANTS::Kwalitee::Distname) == 0.920.0
perl(Module::CPANTS::Kwalitee::Distros) == 0.920.0
perl(Module::CPANTS::Kwalitee::Files) == 0.920.0
perl(Module::CPANTS::Kwalitee::FindModules) == 0.920.0
perl(Module::CPANTS::Kwalitee::License) == 0.920.0
perl(Module::CPANTS::Kwalitee::Manifest) == 0.920.0
perl(Module::CPANTS::Kwalitee::MetaYML) == 0.920.0
perl(Module::CPANTS::Kwalitee::NeedsCompiler) == 0.920.0
perl(Module::CPANTS::Kwalitee::Pod) == 0.920.0
perl(Module::CPANTS::Kwalitee::Prereq) == 0.920.0
perl(Module::CPANTS::Kwalitee::Repackageable) == 0.920.0
perl(Module::CPANTS::Kwalitee::Signature) == 0.920.0
perl(Module::CPANTS::Kwalitee::Uses) == 0.920.0
perl(Module::CPANTS::Kwalitee::Version) == 0.920.0
perl-Module-CPANTS-Analyse == 0.920.0-2.mga4

Download

Type URL
Binary Package perl-Module-CPANTS-Analyse-0.920.0-2.mga4.noarch.rpm
Source Package perl-Module-CPANTS-Analyse-0.920.0-2.mga4.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Module-CPANTS-Analyse rpm package:
    # urpmi perl-Module-CPANTS-Analyse

Files

Path
/usr/bin/cpants_lint.pl
/usr/lib/perl5/vendor_perl/5.18.1/Module/
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Analyse.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee/BrokenInstaller.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee/CpantsErrors.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee/Distname.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee/Distros.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee/Files.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee/FindModules.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee/License.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee/Manifest.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee/MetaYML.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee/NeedsCompiler.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee/Pod.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee/Prereq.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee/Repackageable.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee/Signature.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee/Uses.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/CPANTS/Kwalitee/Version.pm
/usr/share/doc/perl-Module-CPANTS-Analyse/AUTHORS
/usr/share/doc/perl-Module-CPANTS-Analyse/Changes
/usr/share/doc/perl-Module-CPANTS-Analyse/META.json
/usr/share/doc/perl-Module-CPANTS-Analyse/META.yml
/usr/share/doc/perl-Module-CPANTS-Analyse/MYMETA.yml
/usr/share/doc/perl-Module-CPANTS-Analyse/README
/usr/share/doc/perl-Module-CPANTS-Analyse/TODO
/usr/share/man/man1/cpants_lint.pl.1.xz
/usr/share/man/man3/Module::CPANTS::Analyse.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee::BrokenInstaller.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee::CpantsErrors.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Distname.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Distros.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Files.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee::FindModules.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee::License.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Manifest.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee::MetaYML.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee::NeedsCompiler.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Pod.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Prereq.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Repackageable.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Signature.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Uses.3pm.xz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Version.3pm.xz

Changelog

2013-10-21 - umeabot <umeabot> 0.920.0-2.mga4
+ Revision: 537310
- Mageia 4 Mass Rebuild
2013-09-26 - sander85 <sander85> 0.920.0-1.mga4
+ Revision: 486785
- update to 0.92
2013-09-08 - sander85 <sander85> 0.910.0-1.mga4
+ Revision: 476162
- update to 0.91
2013-08-04 - sander85 <sander85> 0.900.200-1.mga4
+ Revision: 463454
- update to 0.9002
2013-08-02 - sander85 <sander85> 0.890.0-1.mga4
+ Revision: 462692
- update to 0.89
2013-07-29 - sander85 <sander85> 0.870.0-1.mga4
+ Revision: 460387
- Add YAML::Syck to pass tests
+ jquelin <jquelin>
- adding missing buildrequires:
- update to 0.87
+ umeabot <umeabot>
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
2012-07-11 - jquelin <jquelin> 0.860.0-1.mga3
+ Revision: 269523
- force YAML::XS as buildrequires to prevent rt#78311
- adding missing buildrequires:
- update to 0.86
2011-03-11 - jquelin <jquelin> 0.850.0-3.mga1
+ Revision: 68245
- update buildrequires:
- wrong patch name
- patch to use test::cpan::meta::yaml::version
- rebuild
2011-01-24 - jquelin <jquelin> 0.850.0-2.mga1
+ Revision: 37343
- rebuild
- mageia rebuild
- imported package perl-Module-CPANTS-Analyse

See Also

Package Description
perl-Module-Compile-0.230.0-3.mga4.noarch.rpm Perl Module Compilation
perl-Module-CoreList-2.990.0-2.mga4.noarch.rpm Tell what modules shipped with versions of perl
perl-Module-Data-0.6.0-3.mga4.noarch.rpm Introspect context information about modules in
perl-Module-Depends-0.160.0-2.mga4.noarch.rpm Intrusive discovery of distribution dependencies
perl-Module-Extract-0.10.0-4.mga4.noarch.rpm Base class for working with Perl distributions
perl-Module-Extract-Namespaces-1.10.0-2.mga4.noarch.rpm Extract the package declarations from a module
perl-Module-Extract-Use-1.30.0-3.mga4.noarch.rpm Pull out the modules a module uses
perl-Module-Extract-VERSION-1.10.0-3.mga4.noarch.rpm Extract a module version without running code
perl-Module-ExtractUse-0.310.0-2.mga4.noarch.rpm Find out what modules are used
perl-Module-Find-0.110.0-3.mga4.noarch.rpm Find and use installed modules in a (sub)category
perl-Module-Format-0.0.5-2.mga4.noarch.rpm Convert and manipulate stringified versions of Perl modules
perl-Module-Implementation-0.70.0-2.mga4.noarch.rpm Loads one of several alternate underlying implementations for a module
perl-Module-Info-0.350.0-2.mga4.noarch.rpm Information about Perl modules
perl-Module-Inspector-1.50.0-3.mga4.noarch.rpm An integrated API for inspecting Perl distributions
perl-Module-Install-1.60.0-3.mga4.noarch.rpm Standalone, extensible Perl module installer
Advertisement
Advertisement