perl-Module-Install-RequiresList-0.100.0-3.mga4.noarch.rpm


Advertisement

Description

perl-Module-Install-RequiresList - Report prerequisite modules and version numbers

Property Value
Distribution Mageia 4.1
Repository Mageia Core i586
Package name perl-Module-Install-RequiresList
Package version 0.100.0
Package release 3.mga4
Package architecture noarch
Package type rpm
Installed size 24.90 KB
Download size 14.91 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
This module adds a target to your Makefile for listing the modules
required.
The report is broken into sections: Required, Recommended, Build Requires,
and Author Requires.
For each module listed, the report prints 3 versions: the version you are
requesting, your installed version and the CPAN version.

Alternatives

Package Version Architecture Repository
perl-Module-Install-RequiresList-0.100.0-3.mga4.noarch.rpm 0.100.0 noarch Mageia Core
perl-Module-Install-RequiresList - - -

Requires

Name Value
perl(CPAN::Meta::YAML) >= 0.3.0
perl(IO::All) >= 0.410.0
perl-base >= 2:5.18.1

Provides

Name Value
perl(Module::Install::RequiresList) == 0.100.0
perl-Module-Install-RequiresList == 0.100.0-3.mga4

Download

Type URL
Binary Package perl-Module-Install-RequiresList-0.100.0-3.mga4.noarch.rpm
Source Package perl-Module-Install-RequiresList-0.100.0-3.mga4.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Module-Install-RequiresList rpm package:
    # urpmi perl-Module-Install-RequiresList

Files

Path
/usr/lib/perl5/vendor_perl/5.18.1/Module/
/usr/lib/perl5/vendor_perl/5.18.1/Module/Install/RequiresList.pm
/usr/lib/perl5/vendor_perl/5.18.1/Module/Install/RequiresList.pod
/usr/share/doc/perl-Module-Install-RequiresList/Changes
/usr/share/doc/perl-Module-Install-RequiresList/LICENSE
/usr/share/doc/perl-Module-Install-RequiresList/META.yml
/usr/share/doc/perl-Module-Install-RequiresList/README
/usr/share/man/man3/Module::Install::RequiresList.3pm.xz

Changelog

2013-10-18 - umeabot <umeabot> 0.100.0-3.mga4
+ Revision: 512996
- Mageia 4 Mass Rebuild
2013-01-13 - umeabot <umeabot> 0.100.0-2.mga3
+ Revision: 369892
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
2012-01-30 - shlomif <shlomif> 0.100.0-1.mga2
+ Revision: 203504
- imported package perl-Module-Install-RequiresList
2012-01-21 - cpan2dist 0.10-1mga
- initial mageia release, generated with cpan2dist

See Also

Package Description
perl-Module-Install-StandardTests-0.50.0-3.mga4.noarch.rpm Generate standard tests for installation
perl-Module-Install-Template-0.80.0-3.mga4.noarch.rpm Treat module source code as a template
perl-Module-Install-TrustMetaYml-0.3.0-2.mga4.noarch.rpm Trusts META.yml list of dependencies
perl-Module-Install-VersionCheck-0.160.0-3.mga4.noarch.rpm Show Author the Current Versions
perl-Module-List-0.3.0-3.mga4.noarch.rpm Module `directory' listing
perl-Module-List-Pluggable-0.80.0-3.mga4.noarch.rpm Stub that imports methods via Module::List::Pluggable
perl-Module-Load-0.240.0-2.mga4.noarch.rpm Runtime require of both modules and files
perl-Module-Load-Conditional-0.580.0-2.mga4.noarch.rpm Looking up module information / loading at runtime
perl-Module-Loaded-0.80.0-3.mga4.noarch.rpm Mark modules as loaded or unloaded
perl-Module-Locate-1.760.0-2.mga4.noarch.rpm Locate modules in the same fashion as C<require> and C<use>
perl-Module-Manifest-1.80.0-3.mga4.noarch.rpm Parse and examine a Perl distribution MANIFEST file
perl-Module-Manifest-Skip-0.170.0-3.mga4.noarch.rpm MANIFEST.SKIP Manangement for Modules
perl-Module-Math-Depends-0.20.0-3.mga4.noarch.rpm Convenience object for manipulating module dependencies
perl-Module-Metadata-1.0.18-2.mga4.noarch.rpm Gather package and POD information from perl module files
perl-Module-Package-0.300.0-3.mga4.noarch.rpm A Hands on Guide
Advertisement
Advertisement