perl-Perl-PrereqScanner-1.17.0-2.mga4.noarch.rpm


Advertisement

Description

perl-Perl-PrereqScanner - A tool to scan your Perl code for its prerequisites

Property Value
Distribution Mageia 4.1
Repository Mageia Core i586
Package name perl-Perl-PrereqScanner
Package version 1.17.0
Package release 2.mga4
Package architecture noarch
Package type rpm
Installed size 93.41 KB
Download size 32.70 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
The scanner will extract loosely your distribution prerequisites from your
files.
The extraction may not be perfect but tries to do its best. It will
currently find the following prereqs:

Alternatives

Package Version Architecture Repository
perl-Perl-PrereqScanner-1.17.0-2.mga4.noarch.rpm 1.17.0 noarch Mageia Core
perl-Perl-PrereqScanner - - -

Requires

Name Value
perl(CPAN::Meta::Requirements) >= 2.120.630
perl(File::Find) -
perl(File::Spec::Functions) -
perl(FindBin) -
perl(Getopt::Long) -
perl(Getopt::Long::Descriptive) -
perl(List::MoreUtils) -
perl(List::Util) -
perl(Module::Path) -
perl(Moose) -
perl(Moose::Role) -
perl(PPI) >= 1.215.0
perl(Params::Util) -
perl(Scalar::Util) -
perl(String::RewritePrefix) >= 0.5.0
perl(lib) -
perl(namespace::autoclean) -
perl(strict) -
perl(warnings) -
perl-base >= 2:5.18.1

Provides

Name Value
perl(Perl::PrereqScanner) == 1.17.0
perl(Perl::PrereqScanner::Scanner) == 1.17.0
perl(Perl::PrereqScanner::Scanner::Aliased) == 1.17.0
perl(Perl::PrereqScanner::Scanner::Moose) == 1.17.0
perl(Perl::PrereqScanner::Scanner::POE) == 1.17.0
perl(Perl::PrereqScanner::Scanner::Perl5) == 1.17.0
perl(Perl::PrereqScanner::Scanner::Superclass) == 1.17.0
perl(Perl::PrereqScanner::Scanner::TestMore) == 1.17.0
perl-Perl-PrereqScanner == 1.17.0-2.mga4

Download

Type URL
Binary Package perl-Perl-PrereqScanner-1.17.0-2.mga4.noarch.rpm
Source Package perl-Perl-PrereqScanner-1.17.0-2.mga4.src.rpm

Install Howto

  1. Enable Mageia Core repository on "Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Perl-PrereqScanner rpm package:
    # urpmi perl-Perl-PrereqScanner

Files

Path
/usr/bin/scan-perl-prereqs
/usr/bin/scan_prereqs
/usr/lib/perl5/vendor_perl/5.18.1/Perl/PrereqScanner.pm
/usr/lib/perl5/vendor_perl/5.18.1/Perl/PrereqScanner/Scanner.pm
/usr/lib/perl5/vendor_perl/5.18.1/Perl/PrereqScanner/Scanner/Aliased.pm
/usr/lib/perl5/vendor_perl/5.18.1/Perl/PrereqScanner/Scanner/Moose.pm
/usr/lib/perl5/vendor_perl/5.18.1/Perl/PrereqScanner/Scanner/POE.pm
/usr/lib/perl5/vendor_perl/5.18.1/Perl/PrereqScanner/Scanner/Perl5.pm
/usr/lib/perl5/vendor_perl/5.18.1/Perl/PrereqScanner/Scanner/Superclass.pm
/usr/lib/perl5/vendor_perl/5.18.1/Perl/PrereqScanner/Scanner/TestMore.pm
/usr/share/doc/perl-Perl-PrereqScanner/Changes
/usr/share/doc/perl-Perl-PrereqScanner/LICENSE
/usr/share/doc/perl-Perl-PrereqScanner/META.json
/usr/share/doc/perl-Perl-PrereqScanner/META.yml
/usr/share/doc/perl-Perl-PrereqScanner/MYMETA.yml
/usr/share/doc/perl-Perl-PrereqScanner/README
/usr/share/man/man1/scan-perl-prereqs.1.xz
/usr/share/man/man1/scan_prereqs.1.xz
/usr/share/man/man3/Perl::PrereqScanner.3pm.xz
/usr/share/man/man3/Perl::PrereqScanner::Scanner.3pm.xz
/usr/share/man/man3/Perl::PrereqScanner::Scanner::Aliased.3pm.xz
/usr/share/man/man3/Perl::PrereqScanner::Scanner::Moose.3pm.xz
/usr/share/man/man3/Perl::PrereqScanner::Scanner::POE.3pm.xz
/usr/share/man/man3/Perl::PrereqScanner::Scanner::Perl5.3pm.xz
/usr/share/man/man3/Perl::PrereqScanner::Scanner::Superclass.3pm.xz
/usr/share/man/man3/Perl::PrereqScanner::Scanner::TestMore.3pm.xz

Changelog

2013-10-21 - umeabot <umeabot> 1.17.0-2.mga4
+ Revision: 539934
- Mageia 4 Mass Rebuild
2013-10-08 - sander85 <sander85> 1.17.0-1.mga4
+ Revision: 493107
- update to 1.017
2013-08-09 - sander85 <sander85> 1.16.0-1.mga4
+ Revision: 464913
- update to 1.016
2013-01-13 - umeabot <umeabot> 1.15.0-2.mga3
+ Revision: 371705
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
2013-01-08 - jquelin <jquelin> 1.15.0-1.mga3
+ Revision: 342528
- update to 1.015
2012-08-31 - kharec <kharec> 1.14.0-1.mga3
+ Revision: 286404
- update to 1.014
2012-07-04 - jquelin <jquelin> 1.13.0-1.mga3
+ Revision: 267452
- update to 1.013
2012-03-07 - jquelin <jquelin> 1.11.0-1.mga2
+ Revision: 220936
- update to 1.011
2012-02-23 - jquelin <jquelin> 1.10.0-1.mga2
+ Revision: 213161
- update to 1.010
2012-01-05 - jquelin <jquelin> 1.9.0-1.mga2
+ Revision: 191274
- update to 1.009

See Also

Package Description
perl-Perl-Version-1.11.0-3.mga4.noarch.rpm Parse and manipulate Perl version strings
perl-Perl6-Classes-0.220.0-3.mga4.noarch.rpm Perl 6 class syntax for Perl 5
perl-Perl6-Doc-0.470.0-3.mga4.noarch.rpm Perl 6 Documentation Collection
perl-Perl6-Export-0.70.0-3.mga4.noarch.rpm Implements the Perl 6 is export trait
perl-Perl6-Export-Attrs-0.0.3-4.mga4.noarch.rpm The Perl 6 'is export(...)' trait as a Perl 5 attribute
perl-Perl6-Form-0.40.0-3.mga4.noarch.rpm Implements the Perl 6 'form' built-in
perl-Perl6-Junction-1.600.0-1.mga4.noarch.rpm Perl6 style Junction operators in Perl5
perl-Perl6-Perldoc-0.0.11-2.mga4.noarch.rpm Add a to_xhtml() method to Perl6::Perldoc::Parser
perl-Perl6-Perldoc-To-Ansi-0.110.0-3.mga4.noarch.rpm ANSI-colored text renderer for Perl6::Perldoc
perl-Perl6-Refactor-0.10.0-3.mga4.noarch.rpm The great new Perl6::Refactor!
perl-Perl6-Signature-0.30.0-3.mga4.noarch.rpm Parse, query, and pretty-print Perl 6 signatures
perl-Perl6-Slurp-0.51.3-2.mga4.noarch.rpm Implements the Perl 6 'slurp' built-in
perl-PerlIO-Layers-0.10.0-4.mga4.i586.rpm No summary found
perl-PerlIO-Util-0.720.0-5.mga4.i586.rpm A selection of general PerlIO utilities
perl-PerlIO-eol-0.140.0-7.mga4.i586.rpm PerlIO layer for normalizing line endings
Advertisement
Advertisement