polkit-0.112-2.mga4.i586.rpm


Advertisement

Description

polkit - PolicyKit Authorization Framework

Property Value
Distribution Mageia 4.1
Repository Mageia Core i586
Package name polkit
Package version 0.112
Package release 2.mga4
Package architecture i586
Package type rpm
Installed size 219.02 KB
Download size 87.18 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
PolicyKit is a toolkit for defining and handling authorizations.
It is used for allowing unprivileged processes to speak to privileged
processes.

Alternatives

Package Version Architecture Repository
polkit-0.113-1.mga4.i586.rpm 0.113 i586 Mageia Core Updates
polkit-0.113-1.mga4.x86_64.rpm 0.113 x86_64 Mageia Core Updates
polkit-0.112-2.1.mga4.i586.rpm 0.112 i586 Mageia Core Updates
polkit-0.112-2.1.mga4.x86_64.rpm 0.112 x86_64 Mageia Core Updates
polkit-0.112-2.mga4.x86_64.rpm 0.112 x86_64 Mageia Core
polkit - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.2) -
libc.so.6(GLIBC_2.2.4) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.7) -
libexpat.so.1 -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libmozjs185.so.1.0 -
libpam.so.0 -
libpolkit-agent-1.so.0 -
libpolkit-gobject-1.so.0 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.2) -
libsystemd-login.so.0 -
rpm-helper >= 0.24.8-1

Provides

Name Value
polkit == 0.112-2.mga4
polkit(x86-32) == 0.112-2.mga4

Download

Type URL
Binary Package polkit-0.112-2.mga4.i586.rpm
Source Package polkit-0.112-2.mga4.src.rpm

Install Howto

  1. Enable Mageia Core repository on "Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install polkit rpm package:
    # urpmi polkit

Files

Path
/etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf
/etc/pam.d/polkit-1
/etc/polkit-1/
/etc/polkit-1/rules.d/50-default.rules
/usr/bin/pk-example-frobnicate
/usr/bin/pkaction
/usr/bin/pkcheck
/usr/bin/pkexec
/usr/bin/pkttyagent
/usr/lib/polkit-1/polkit-agent-helper-1
/usr/lib/polkit-1/polkitd
/usr/lib/systemd/system/polkit.service
/usr/share/dbus-1/system-services/org.freedesktop.PolicyKit1.service
/usr/share/locale/cs/LC_MESSAGES/polkit-1.mo
/usr/share/locale/da/LC_MESSAGES/polkit-1.mo
/usr/share/man/man1/pkaction.1.xz
/usr/share/man/man1/pkcheck.1.xz
/usr/share/man/man1/pkexec.1.xz
/usr/share/man/man1/pkttyagent.1.xz
/usr/share/man/man8/polkit.8.xz
/usr/share/man/man8/polkitd.8.xz
/usr/share/polkit-1/rules.d
/usr/share/polkit-1/actions/org.freedesktop.policykit.examples.pkexec.policy
/usr/share/polkit-1/actions/org.freedesktop.policykit.policy

Changelog

2013-10-19 - umeabot <umeabot> 0.112-2.mga4
+ Revision: 535851
- Mageia 4 Mass Rebuild
2013-09-21 - luigiwalser <luigiwalser> 0.112-1.mga4
+ Revision: 482687
- 0.112 (fixes CVE-2013-4288)
2013-08-18 - joequant <joequant> 0.111-1.mga4
+ Revision: 467420
- Add enable-systemd-login to allow sandbox compile
- add systemd
- upgrade to 0.111
2013-01-18 - fwang <fwang> 0.107-6.mga3
+ Revision: 389289
- eggdbus is not needed anymore
+ umeabot <umeabot>
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
2013-01-07 - luigiwalser <luigiwalser> 0.107-4.mga3
+ Revision: 340740
- further fix for automake 1.13
- fix for automake 1.13
2012-10-19 - ovitters <ovitters> 0.107-3.mga3
+ Revision: 308217
- drop consolekit dependency
2012-09-26 - mitya <mitya> 0.107-2.mga3
+ Revision: 298329
- Authenticate as root if e.g. the wheel group is empty (RedHat #834494)
2012-09-08 - luigiwalser <luigiwalser> 0.107-1.mga3
+ Revision: 289804
- 0.107
2012-07-08 - colin <colin> 0.106-2.mga3
+ Revision: 268917
- Fix permissions on rules.d dirs
2012-06-27 - colin <colin> 0.106-1.mga3
+ Revision: 264420
- Really fix build requires
- Fix build requires
- Fix build
- Drop wheel group rules (replacements should go in other packages)
- Do not enable the service with systemd - it's dbus only now.
- Ensure polkitd runs as it's own user.
+ ovitters <ovitters>
- update buildrequires
- enable systemd
- drop systemd patch due to new polkit version
- new version 0.106
- update source url

See Also

Package Description
polkit-desktop-policy-0.112-2.mga4.noarch.rpm PolicyKit policy for desktop users
polkit-kde-agent-1-0.99.0-6.mga4.i586.rpm PolicyKit authentication agent for KDE
polkit-kde-kcmodules-1-0.98.1-4.mga4.i586.rpm PolicyKit KDE Configuration
polkit-qt-1-devel-0.103.0-3.mga4.i586.rpm Devel stuff for polkit-Qt
polyglot-1.4.70b-3.mga4.i586.rpm Xboard protocol to UCI protocol adapter
poppassd-ceti-1.8.5-5.mga4.i586.rpm An Eudora and NUPOP change password server
poppler-0.24.3-2.mga4.i586.rpm PDF rendering library
poppler-data-0.4.6-3.mga4.noarch.rpm Encoding files for poppler
poppler-sharp-0.0.3-4.mga4.i586.rpm C sharp Bindings for Poppler
poppler-sharp-devel-0.0.3-4.mga4.i586.rpm Development files for poppler-sharp
popt-data-1.16-5.mga4.noarch.rpm Data files for popt
portals-pom-1.3-4.mga4.noarch.rpm Apache Portals (parent pom)
portlet-2.0-api-1.0-6.mga4.noarch.rpm Java Portlet Specification V2.0
portlet-2.0-api-javadoc-1.0-6.mga4.noarch.rpm Javadoc for portlet-2.0-api
portmidi-217-6.mga4.i586.rpm Real-time MIDI input/output, audio I/O library
Advertisement
Advertisement