libgcc1-4.8.2-3.2.mga4.i586.rpm


Advertisement

Description

libgcc1 - GNU C library

Property Value
Distribution Mageia 4.1
Repository Mageia Core Updates i586
Package filename libgcc1-4.8.2-3.2.mga4.i586.rpm
Package name libgcc1
Package version 4.8.2
Package release 3.2.mga4
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://gcc.gnu.org/
License GPLv3+
Maintainer -
Download size 55.03 KB
Installed size 111.57 KB
The libgcc1 package contains GCC shared libraries for gcc 4.8

Alternatives

Package Version Architecture Repository
libgcc1-4.8.2-3.2.mga4.x86_64.rpm 4.8.2 x86_64 Mageia Core Updates
libgcc1-4.8.2-3.mga4.i586.rpm 4.8.2 i586 Mageia Core
libgcc1-4.8.2-3.mga4.x86_64.rpm 4.8.2 x86_64 Mageia Core
libgcc1 - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.2.4) -

Provides

Name Value
libgcc == 4.8.2-3.2.mga4
libgcc1 == 4.8.2-3.2.mga4
libgcc1(x86-32) == 4.8.2-3.2.mga4
libgcc3.0 == 4.8.2-3.2.mga4
libgcc3.2 == 4.8.2-3.2.mga4
libgcc4.8 == 4.8.2-3.2.mga4
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_3.3) -
libgcc_s.so.1(GCC_3.3.1) -
libgcc_s.so.1(GCC_3.4) -
libgcc_s.so.1(GCC_3.4.2) -
libgcc_s.so.1(GCC_4.0.0) -
libgcc_s.so.1(GCC_4.2.0) -
libgcc_s.so.1(GCC_4.3.0) -
libgcc_s.so.1(GCC_4.4.0) -
libgcc_s.so.1(GCC_4.5.0) -
libgcc_s.so.1(GCC_4.7.0) -
libgcc_s.so.1(GCC_4.8.0) -
libgcc_s.so.1(GLIBC_2.0) -

Obsoletes

Name Value
libgcc3.0 -
libgcc4.8 -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libgcc1-4.8.2-3.2.mga4.i586.rpm
Source Package gcc-4.8.2-3.2.mga4.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libgcc1 rpm package:
    # urpmi libgcc1

Files

Path
/lib/libgcc_s-4.8.2.so.1
/lib/libgcc_s.so.1

Changelog

2014-07-31 - tmb <tmb> 4.8.2-3.2.mga4
+ Revision: 658567
- fix memory overflow in libgfortran (CVE-2014-5044)
- gcc/PR61801: fix sched2 miscompiles syscall sequence
- ship cxxabi.h and cxxabi_tweaks.h in both upstream default path for clang
to work and Mageia specific path to keep backward compatibility (mga#13543)
2013-10-23 - tmb <tmb> 4.8.2-3.mga4
+ Revision: 546668
- fix bug in nth_element (PR libstdc++/58800, mga #11516)
2013-10-22 - umeabot <umeabot> 4.8.2-2.mga4
+ Revision: 545598
- Mageia 4 Mass Rebuild
2013-10-16 - tmb <tmb> 4.8.2-1.mga4
+ Revision: 501462
- update to 4.8.2 final
2013-10-12 - tmb <tmb> 4.8.2-0.20131009.2.mga4
+ Revision: 496063
- rebuild with new binutils & make
2013-10-11 - tmb <tmb> 4.8.2-0.20131009.1.mga4
+ Revision: 495122
- update to 4.8.2 RC
2013-10-04 - tmb <tmb> 4.8.2-0.20131003.1.mga4
+ Revision: 491582
- update filelists
- update to 2013-10-03
2013-09-22 - tmb <tmb> 4.8.2-0.20130919.1.mga4
+ Revision: 483258
- update to 2013-09-19
2013-09-17 - tmb <tmb> 4.8.2-0.20130912.1.mga4
+ Revision: 480784
- update to 2013-09-12
2013-09-10 - tmb <tmb> 4.8.2-0.20130905.1.mga4
+ Revision: 477216
- update to 2013-09-05

See Also

Package Description
libgcj-devel-4.8.2-3.2.mga4.i586.rpm Header files and libraries for Java development
libgcj-static-devel-4.8.2-3.2.mga4.i586.rpm Static libraries for Java development
libgcj14-4.8.2-3.2.mga4.i586.rpm GNU Java runtime libraries
libgcj14-base-4.8.2-3.2.mga4.i586.rpm Java library base classes
libgcj14-src-4.8.2-3.2.mga4.i586.rpm Java library sources
libgcj_bc1-4.8.2-3.2.mga4.i586.rpm GNU Java runtime bytecode wrapper library
libgcrypt-devel-1.5.4-1.1.mga4.i586.rpm Development files for GNU cryptographic library
libgcrypt-devel-1.5.4-1.2.mga4.i586.rpm Development files for GNU cryptographic library
libgcrypt-devel-1.5.4-1.mga4.i586.rpm Development files for GNU cryptographic library
libgcrypt11-1.5.4-1.1.mga4.i586.rpm GNU Cryptographic library
libgcrypt11-1.5.4-1.2.mga4.i586.rpm GNU Cryptographic library
libgcrypt11-1.5.4-1.mga4.i586.rpm GNU Cryptographic library
libgd-devel-2.1.0-3.1.mga4.i586.rpm The development libraries and header files for gd
libgd-devel-2.1.0-3.2.mga4.i586.rpm The development libraries and header files for gd
libgd-static-devel-2.1.0-3.1.mga4.i586.rpm Static GD library
Advertisement
Advertisement