libmagic1-5.16-1.9.mga4.i586.rpm


Advertisement

Description

libmagic1 - Shared library for handling magic files

Property Value
Distribution Mageia 4.1
Repository Mageia Core Updates i586
Package filename libmagic1-5.16-1.9.mga4.i586.rpm
Package name libmagic1
Package version 5.16
Package release 1.9.mga4
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://www.darwinsys.com/file/
License BSD
Maintainer -
Download size 57.95 KB
Installed size 120.91 KB
The file command is used to identify a particular file according to the
type of data contained by the file.  File can identify many different
file types, including ELF binaries, system libraries, RPM packages, and
different graphics formats.
Libmagic is a library for handling the so called magic files the 'file'
command is based on.

Alternatives

Package Version Architecture Repository
libmagic1-5.16-1.10.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic1-5.16-1.7.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic1-5.16-1.6.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic1-5.16-1.5.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic1-5.16-1.4.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic1-5.16-1.3.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic1-5.16-1.2.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic1-5.16-1.1.mga4.i586.rpm 5.16 i586 Mageia Core Updates
libmagic1-5.16-1.mga4.i586.rpm 5.16 i586 Mageia Core
libmagic1 - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.15) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.7) -
libc.so.6(GLIBC_2.8) -
libz.so.1 -

Provides

Name Value
libmagic.so.1 -
libmagic1 == 5.16-1.9.mga4
libmagic1(x86-32) == 5.16-1.9.mga4

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libmagic1-5.16-1.9.mga4.i586.rpm
Source Package file-5.16-1.9.mga4.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libmagic1 rpm package:
    # urpmi libmagic1

Files

Path
/usr/lib/libmagic.so.1
/usr/lib/libmagic.so.1.0.0

Changelog

2014-12-16 - luigiwalser <luigiwalser> 5.16-1.9.mga4
+ Revision: 803606
- add upstream patch to fix out-of-bounds read with pascal strings
- rediff upstream patches to fix CVE-2014-8116 and CVE-2014-8117
- add upstream patch to fix CVE-2014-3710
- add patch from fedora to fix CVE-2014-3587
- rediff upstream patches to fix more buffer issues with CDF parsing
(CVE-2014-3479, CVE-2014-3480, CVE-2014-3487)
- add upstream patch to correctly compute truncated pascal string size
(CVE-2014-3478)
- add upstream changes to CDF parser to fix CVE-2014-023[78] and other issues
- rediff upstream patch to fix a memory leak
- rediff upstream patches to fix CVE-2014-2270
- rediff upstream patches to fix CVE-2014-1943
+ oden <oden>
- P23: security fix for CVE-2014-3538 (ubuntu)
2013-12-05 - luigiwalser <luigiwalser> 5.16-1.mga4
+ Revision: 555409
- 5.16
2013-10-22 - umeabot <umeabot> 5.15-4.mga4
+ Revision: 543108
- Mageia 4 Mass Rebuild
2013-10-15 - danf <danf> 5.15-3.mga4
+ Revision: 498356
- Added a version dependency on the library, since it expects the specific
magic file format version provided in the corresponding main package
2013-10-14 - pterjan <pterjan> 5.15-2.mga4
+ Revision: 497751
- Rebuild to add different pythonegg provides for python 2 and 3
2013-09-25 - luigiwalser <luigiwalser> 5.15-1.mga4
+ Revision: 485759
- 5.15
- rediff patches 8, 9, and 13
- remove upstreamed sticky bit patch
2013-03-22 - luigiwalser <luigiwalser> 5.14-1.mga4
+ Revision: 404478
- 5.14
- 5.13
- remove upstream patches
2013-01-11 - umeabot <umeabot> 5.12-8.mga3
+ Revision: 350297
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
2013-01-11 - blino <blino> 5.12-7.mga3
+ Revision: 344908
- add back ELF detection patch, it got detected as reversed because of a modified RCSID
2013-01-10 - luigiwalser <luigiwalser> 5.12-6.mga3
+ Revision: 344756
- fix misdetection as assembler text (upstream)

See Also

Package Description
libmagick++-6Q16_3-6.8.7.0-2.1.mga4.i586.rpm ImageMagick libraries
libmagick++-6Q16_3-6.8.7.0-2.3.mga4.i586.rpm ImageMagick libraries
libmagick-6Q16_1-6.8.7.0-2.1.mga4.i586.rpm ImageMagick libraries
libmagick-6Q16_1-6.8.7.0-2.3.mga4.i586.rpm ImageMagick libraries
libmagick-devel-6.8.7.0-2.1.mga4.i586.rpm Static libraries and header files for ImageMagick app development
libmagick-devel-6.8.7.0-2.3.mga4.i586.rpm Static libraries and header files for ImageMagick app development
libmailcommon4-4.12.5-1.1.mga4.i586.rpm KDEPIM 4 library
libmailcommon4-4.12.5-1.mga4.i586.rpm KDEPIM 4 library
libmaildir4-4.12.5-1.mga4.i586.rpm KDEPIM 4 library
libmailimporter4-4.12.5-1.1.mga4.i586.rpm Mail Importer Library
libmailimporter4-4.12.5-1.mga4.i586.rpm Mail Importer Library
libmailtransport4-4.12.5-1.mga4.i586.rpm KDE 4 core library
libmarblewidget17-4.12.5-1.1.mga4.i586.rpm Runtime library for marble
libmarblewidget17-4.12.5-1.mga4.i586.rpm Runtime library for marble
libmariadb-devel-5.5.36-1.mga4.i586.rpm Development header files and libraries
Advertisement
Advertisement