libqt5base5-devel-5.2.0-2.5.mga4.i586.rpm


Advertisement

Description

libqt5base5-devel - Development files for the Qt5 GUI toolkit

Property Value
Distribution Mageia 4.1
Repository Mageia Core Updates i586
Package name libqt5base5-devel
Package version 5.2.0
Package release 2.5.mga4
Package architecture i586
Package type rpm
Installed size unknown
Download size 8.49 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
The qtbase5-devel package contains the files necessary to develop
applications using the Qt GUI toolkit: the header files, the Qt
meta object compiler, and the static libraries.  See the address
http://qt-project.org/ for more information about Qt5.

Alternatives

Package Version Architecture Repository
libqt5base5-devel-5.2.0-2.4.mga4.i586.rpm 5.2.0 i586 Mageia Core Updates
libqt5base5-devel-5.2.0-2.3.mga4.i586.rpm 5.2.0 i586 Mageia Core Updates
libqt5base5-devel-5.2.0-2.mga4.i586.rpm 5.2.0 i586 Mageia Core
libqt5base5-devel - - -

Requires

Name Value
libqt5bootstrap-devel == 5.2.0-2.5.mga4
libqt5concurrent-devel == 5.2.0-2.5.mga4
libqt5core-devel == 5.2.0-2.5.mga4
libqt5dbus-devel == 5.2.0-2.5.mga4
libqt5gui-devel == 5.2.0-2.5.mga4
libqt5network-devel == 5.2.0-2.5.mga4
libqt5opengl-devel == 5.2.0-2.5.mga4
libqt5printsupport-devel == 5.2.0-2.5.mga4
libqt5sql-devel == 5.2.0-2.5.mga4
libqt5test-devel == 5.2.0-2.5.mga4
libqt5widgets-devel == 5.2.0-2.5.mga4
libqt5xml-devel == 5.2.0-2.5.mga4
qtbase5-common == 5.2.0
qtbase5-common-devel == 5.2.0-2.5.mga4

Provides

Name Value
libqt5-devel == 5.2.0-2.5.mga4
libqt5base5-devel == 5.2.0-2.5.mga4
libqt5base5-devel(x86-32) == 5.2.0-2.5.mga4
libqtbase5-devel == 5.2.0-2.5.mga4
qt5-devel == 5.2.0-2.5.mga4
qtbase5-devel == 5.2.0-2.5.mga4

Download

Type URL
Binary Package libqt5base5-devel-5.2.0-2.5.mga4.i586.rpm
Source Package qtbase5-5.2.0-2.5.mga4.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on "Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install libqt5base5-devel rpm package:
    # urpmi libqt5base5-devel

Changelog

2015-04-22 - luigiwalser <luigiwalser> 5.2.0-2.5.mga4
+ Revision: 820559
- add patches from fedora to fix CVE-2015-1858, CVE-2015-1859, and CVE-2015-1860
- add patch from upstream via fedora to fix CVE-2014-0190
+ lmenut <lmenut>
- add upstream patch to fix DoS vulnerability in the BMP image handler
(CVE-2015-0295) mga#15383
+ neoclust <neoclust>
- Fix previous commit by moving requires in the good package
- Fix Requires in qtsql5-devel
2013-12-14 - fwang <fwang> 5.2.0-2.mga4
+ Revision: 556694
- 5.2.0 final
2013-12-01 - fwang <fwang> 5.2.0-1.rc1.1.mga4
+ Revision: 554396
- 5.2.0 rc1
2013-10-26 - fwang <fwang> 5.2.0-1.beta1.2.mga4
+ Revision: 547083
- use xkbcommon instead
- br xcb-xkb
2013-10-26 - fwang <fwang> 5.2.0-1.beta1.1.mga4
+ Revision: 547072
- 5.2.0 beta1
2013-10-21 - umeabot <umeabot> 5.2.0-1.alpha.2.mga4
+ Revision: 538802
- Mageia 4 Mass Rebuild
2013-10-02 - neoclust <neoclust> 5.2.0-1.alpha.1.mga4
+ Revision: 490404
- New version 5.2.0 alpha
2013-09-26 - fwang <fwang> 5.2.0-0.0.20130523.9.mga4
+ Revision: 486794
- rebuild for icu 52
2013-08-10 - wally <wally> 5.2.0-0.0.20130523.8.mga4
+ Revision: 465090
- add more cmake fixes (rediff patch)
2013-08-10 - neoclust <neoclust> 5.2.0-0.0.20130523.7.mga4
+ Revision: 465081
- Add fedora patch to fix cmake path search

See Also

Package Description
libqt5bootstrap-devel-5.2.0-2.3.mga4.i586.rpm Devel files needed to build apps based on QtBootstrap
libqt5bootstrap-devel-5.2.0-2.4.mga4.i586.rpm Devel files needed to build apps based on QtBootstrap
libqt5bootstrap-devel-5.2.0-2.5.mga4.i586.rpm Devel files needed to build apps based on QtBootstrap
libqt5concurrent-devel-5.2.0-2.3.mga4.i586.rpm Devel files needed to build apps based on QtConcurrent
libqt5concurrent-devel-5.2.0-2.4.mga4.i586.rpm Devel files needed to build apps based on QtConcurrent
libqt5concurrent-devel-5.2.0-2.5.mga4.i586.rpm Devel files needed to build apps based on QtConcurrent
libqt5concurrent5-5.2.0-2.3.mga4.i586.rpm Qt5 3D Lib
libqt5concurrent5-5.2.0-2.4.mga4.i586.rpm Qt5 3D Lib
libqt5concurrent5-5.2.0-2.5.mga4.i586.rpm Qt5 3D Lib
libqt5core-devel-5.2.0-2.3.mga4.i586.rpm Devel files needed to build apps based on QtCore
libqt5core-devel-5.2.0-2.4.mga4.i586.rpm Devel files needed to build apps based on QtCore
libqt5core-devel-5.2.0-2.5.mga4.i586.rpm Devel files needed to build apps based on QtCore
libqt5core-private-devel-5.2.0-2.3.mga4.i586.rpm Devel files needed to build apps based on QtCore
libqt5core-private-devel-5.2.0-2.4.mga4.i586.rpm Devel files needed to build apps based on QtCore
libqt5core-private-devel-5.2.0-2.5.mga4.i586.rpm Devel files needed to build apps based on QtCore
Advertisement
Advertisement