libqt5opengl-devel-5.2.0-2.4.mga4.i586.rpm


Advertisement

Description

libqt5opengl-devel - Devel files needed to build apps based on QtContacts

Property Value
Distribution Mageia 4.1
Repository Mageia Core Updates i586
Package name libqt5opengl-devel
Package version 5.2.0
Package release 2.4.mga4
Package architecture i586
Package type rpm
Installed size 4.14 MB
Download size 547.76 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Devel files needed to build apps based on QtContacts.

Alternatives

Package Version Architecture Repository
libqt5opengl-devel-5.2.0-2.5.mga4.i586.rpm 5.2.0 i586 Mageia Core Updates
libqt5opengl-devel-5.2.0-2.3.mga4.i586.rpm 5.2.0 i586 Mageia Core Updates
libqt5opengl-devel-5.2.0-2.mga4.i586.rpm 5.2.0 i586 Mageia Core
libqt5opengl-devel - - -

Requires

Name Value
devel(libGL) -
devel(libQt5Core) -
devel(libQt5Gui) -
devel(libQt5Widgets) -
devel(libm) -
devel(libstdc++) -
libqt5opengl5 == 5.2.0
pkgconfig -
pkgconfig(Qt5Core) -
pkgconfig(Qt5Gui) -
pkgconfig(Qt5Widgets) -
qtbase5-common == 5.2.0
qtbase5-common-devel == 5.2.0-2.4.mga4

Provides

Name Value
devel(libQt5OpenGL) -
libqt5opengl-devel == 5.2.0
libqt5opengl-devel == 5.2.0-2.4.mga4
libqt5opengl-devel(x86-32) == 5.2.0-2.4.mga4
libqtopengl5-devel == 5.2.0
pkgconfig(Qt5OpenGL) == 5.2.0
pkgconfig(Qt5OpenGLExtensions) == 5.2.0
qt5opengl-devel == 5.2.0
qtopengl5-devel == 5.2.0

Download

Type URL
Binary Package libqt5opengl-devel-5.2.0-2.4.mga4.i586.rpm
Source Package qtbase5-5.2.0-2.4.mga4.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libqt5opengl-devel rpm package:
    # urpmi libqt5opengl-devel

Files

Path
/usr/lib/libQt5OpenGL.prl
/usr/lib/libQt5OpenGL.so
/usr/lib/libQt5OpenGLExtensions.a
/usr/lib/libQt5OpenGLExtensions.prl
/usr/lib/cmake/Qt5OpenGL/Qt5OpenGLConfig.cmake
/usr/lib/cmake/Qt5OpenGL/Qt5OpenGLConfigVersion.cmake
/usr/lib/cmake/Qt5OpenGLExtensions/Qt5OpenGLExtensionsConfig.cmake
/usr/lib/cmake/Qt5OpenGLExtensions/Qt5OpenGLExtensionsConfigVersion.cmake
/usr/lib/pkgconfig/Qt5OpenGL.pc
/usr/lib/pkgconfig/Qt5OpenGLExtensions.pc
/usr/lib/qt5/include/QtOpenGL/QGLBuffer
/usr/lib/qt5/include/QtOpenGL/QGLColormap
/usr/lib/qt5/include/QtOpenGL/QGLContext
/usr/lib/qt5/include/QtOpenGL/QGLFormat
/usr/lib/qt5/include/QtOpenGL/QGLFramebufferObject
/usr/lib/qt5/include/QtOpenGL/QGLFramebufferObjectFormat
/usr/lib/qt5/include/QtOpenGL/QGLFunctions
/usr/lib/qt5/include/QtOpenGL/QGLFunctionsPrivate
/usr/lib/qt5/include/QtOpenGL/QGLPixelBuffer
/usr/lib/qt5/include/QtOpenGL/QGLShader
/usr/lib/qt5/include/QtOpenGL/QGLShaderProgram
/usr/lib/qt5/include/QtOpenGL/QGLWidget
/usr/lib/qt5/include/QtOpenGL/QtOpenGL
/usr/lib/qt5/include/QtOpenGL/QtOpenGLDepends
/usr/lib/qt5/include/QtOpenGL/QtOpenGLVersion
/usr/lib/qt5/include/QtOpenGL/qgl.h
/usr/lib/qt5/include/QtOpenGL/qglbuffer.h
/usr/lib/qt5/include/QtOpenGL/qglcolormap.h
/usr/lib/qt5/include/QtOpenGL/qglframebufferobject.h
/usr/lib/qt5/include/QtOpenGL/qglfunctions.h
/usr/lib/qt5/include/QtOpenGL/qglpixelbuffer.h
/usr/lib/qt5/include/QtOpenGL/qglshaderprogram.h
/usr/lib/qt5/include/QtOpenGL/qtopenglglobal.h
/usr/lib/qt5/include/QtOpenGL/qtopenglversion.h
/usr/lib/qt5/include/QtOpenGLExtensions/QOpenGLExtensions
/usr/lib/qt5/include/QtOpenGLExtensions/QtOpenGLExtensions
/usr/lib/qt5/include/QtOpenGLExtensions/QtOpenGLExtensionsDepends
/usr/lib/qt5/include/QtOpenGLExtensions/QtOpenGLExtensionsVersion
/usr/lib/qt5/include/QtOpenGLExtensions/qopenglextensions.h
/usr/lib/qt5/include/QtOpenGLExtensions/qtopenglextensionsversion.h

Changelog

2015-02-28 - lmenut <lmenut> 5.2.0-2.4.mga4
+ Revision: 817206
- add upstream patch to fix DoS vulnerability in the BMP image handler
(CVE-2015-0295) mga#15383
+ luigiwalser <luigiwalser>
- add patch from upstream via fedora to fix CVE-2014-0190
+ neoclust <neoclust>
- Fix previous commit by moving requires in the good package
- Fix Requires in qtsql5-devel
2013-12-14 - fwang <fwang> 5.2.0-2.mga4
+ Revision: 556694
- 5.2.0 final
2013-12-01 - fwang <fwang> 5.2.0-1.rc1.1.mga4
+ Revision: 554396
- 5.2.0 rc1
2013-10-26 - fwang <fwang> 5.2.0-1.beta1.2.mga4
+ Revision: 547083
- use xkbcommon instead
- br xcb-xkb
2013-10-26 - fwang <fwang> 5.2.0-1.beta1.1.mga4
+ Revision: 547072
- 5.2.0 beta1
2013-10-21 - umeabot <umeabot> 5.2.0-1.alpha.2.mga4
+ Revision: 538802
- Mageia 4 Mass Rebuild
2013-10-02 - neoclust <neoclust> 5.2.0-1.alpha.1.mga4
+ Revision: 490404
- New version 5.2.0 alpha
2013-09-26 - fwang <fwang> 5.2.0-0.0.20130523.9.mga4
+ Revision: 486794
- rebuild for icu 52
2013-08-10 - wally <wally> 5.2.0-0.0.20130523.8.mga4
+ Revision: 465090
- add more cmake fixes (rediff patch)
2013-08-10 - neoclust <neoclust> 5.2.0-0.0.20130523.7.mga4
+ Revision: 465081
- Add fedora patch to fix cmake path search

See Also

Package Description
libqt5opengl-private-devel-5.2.0-2.3.mga4.i586.rpm Devel files needed to build apps based on QtContacts
libqt5opengl-private-devel-5.2.0-2.4.mga4.i586.rpm Devel files needed to build apps based on QtContacts
libqt5opengl-private-devel-5.2.0-2.5.mga4.i586.rpm Devel files needed to build apps based on QtContacts
libqt5opengl5-5.2.0-2.3.mga4.i586.rpm Qt5 Component Library
libqt5opengl5-5.2.0-2.4.mga4.i586.rpm Qt5 Component Library
libqt5opengl5-5.2.0-2.5.mga4.i586.rpm Qt5 Component Library
libqt5platformsupport-devel-5.2.0-2.3.mga4.i586.rpm Devel files needed to build apps based on QtPlatformSupport
libqt5platformsupport-devel-5.2.0-2.4.mga4.i586.rpm Devel files needed to build apps based on QtPlatformSupport
libqt5platformsupport-devel-5.2.0-2.5.mga4.i586.rpm Devel files needed to build apps based on QtPlatformSupport
libqt5platformsupport-private-devel-5.2.0-2.3.mga4.i586.rpm Devel files needed to build apps based on QtPlatformSupport
libqt5platformsupport-private-devel-5.2.0-2.4.mga4.i586.rpm Devel files needed to build apps based on QtPlatformSupport
libqt5platformsupport-private-devel-5.2.0-2.5.mga4.i586.rpm Devel files needed to build apps based on QtPlatformSupport
libqt5printsupport-devel-5.2.0-2.3.mga4.i586.rpm Devel files needed to build apps based on QtPrintSupport
libqt5printsupport-devel-5.2.0-2.4.mga4.i586.rpm Devel files needed to build apps based on QtPrintSupport
libqt5printsupport-devel-5.2.0-2.5.mga4.i586.rpm Devel files needed to build apps based on QtPrintSupport
Advertisement
Advertisement