libqt5printsupport-devel-5.2.0-2.5.mga4.i586.rpm


Advertisement

Description

libqt5printsupport-devel - Devel files needed to build apps based on QtPrintSupport

Property Value
Distribution Mageia 4.1
Repository Mageia Core Updates i586
Package name libqt5printsupport-devel
Package version 5.2.0
Package release 2.5.mga4
Package architecture i586
Package type rpm
Installed size 41.78 KB
Download size 18.10 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Devel files needed to build apps based on QtPrintSupport.

Alternatives

Package Version Architecture Repository
libqt5printsupport-devel-5.2.0-2.4.mga4.i586.rpm 5.2.0 i586 Mageia Core Updates
libqt5printsupport-devel-5.2.0-2.3.mga4.i586.rpm 5.2.0 i586 Mageia Core Updates
libqt5printsupport-devel-5.2.0-2.mga4.i586.rpm 5.2.0 i586 Mageia Core
libqt5printsupport-devel - - -

Requires

Name Value
devel(libQt5Core) -
devel(libQt5Gui) -
devel(libQt5Widgets) -
devel(libm) -
devel(libstdc++) -
libqt5printsupport5 == 5.2.0
pkgconfig -
pkgconfig(Qt5Core) -
pkgconfig(Qt5Gui) -
pkgconfig(Qt5Widgets) -
qtbase5-common == 5.2.0
qtbase5-common-devel == 5.2.0-2.5.mga4

Provides

Name Value
devel(libQt5PrintSupport) -
libqt5printsupport-devel == 5.2.0-2.5.mga4
libqt5printsupport-devel == 5.2.0
libqt5printsupport-devel(x86-32) == 5.2.0-2.5.mga4
libqtprintsupport5-devel == 5.2.0
pkgconfig(Qt5PrintSupport) == 5.2.0
qt5printsupport-devel == 5.2.0
qtprintsupport5-devel == 5.2.0

Download

Type URL
Binary Package libqt5printsupport-devel-5.2.0-2.5.mga4.i586.rpm
Source Package qtbase5-5.2.0-2.5.mga4.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on "Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install libqt5printsupport-devel rpm package:
    # urpmi libqt5printsupport-devel

Files

Path
/usr/lib/libQt5PrintSupport.prl
/usr/lib/libQt5PrintSupport.so
/usr/lib/cmake/Qt5PrintSupport/Qt5PrintSupportConfig.cmake
/usr/lib/cmake/Qt5PrintSupport/Qt5PrintSupportConfigVersion.cmake
/usr/lib/pkgconfig/Qt5PrintSupport.pc
/usr/lib/qt5/include/QtPrintSupport/QAbstractPrintDialog
/usr/lib/qt5/include/QtPrintSupport/QPageSetupDialog
/usr/lib/qt5/include/QtPrintSupport/QPrintDialog
/usr/lib/qt5/include/QtPrintSupport/QPrintEngine
/usr/lib/qt5/include/QtPrintSupport/QPrintPreviewDialog
/usr/lib/qt5/include/QtPrintSupport/QPrintPreviewWidget
/usr/lib/qt5/include/QtPrintSupport/QPrinter
/usr/lib/qt5/include/QtPrintSupport/QPrinterInfo
/usr/lib/qt5/include/QtPrintSupport/QtPrintSupport
/usr/lib/qt5/include/QtPrintSupport/QtPrintSupportDepends
/usr/lib/qt5/include/QtPrintSupport/QtPrintSupportVersion
/usr/lib/qt5/include/QtPrintSupport/qabstractprintdialog.h
/usr/lib/qt5/include/QtPrintSupport/qpagesetupdialog.h
/usr/lib/qt5/include/QtPrintSupport/qprintdialog.h
/usr/lib/qt5/include/QtPrintSupport/qprintengine.h
/usr/lib/qt5/include/QtPrintSupport/qprinter.h
/usr/lib/qt5/include/QtPrintSupport/qprinterinfo.h
/usr/lib/qt5/include/QtPrintSupport/qprintpreviewdialog.h
/usr/lib/qt5/include/QtPrintSupport/qprintpreviewwidget.h
/usr/lib/qt5/include/QtPrintSupport/qtprintsupportglobal.h
/usr/lib/qt5/include/QtPrintSupport/qtprintsupportversion.h

Changelog

2015-04-22 - luigiwalser <luigiwalser> 5.2.0-2.5.mga4
+ Revision: 820559
- add patches from fedora to fix CVE-2015-1858, CVE-2015-1859, and CVE-2015-1860
- add patch from upstream via fedora to fix CVE-2014-0190
+ lmenut <lmenut>
- add upstream patch to fix DoS vulnerability in the BMP image handler
(CVE-2015-0295) mga#15383
+ neoclust <neoclust>
- Fix previous commit by moving requires in the good package
- Fix Requires in qtsql5-devel
2013-12-14 - fwang <fwang> 5.2.0-2.mga4
+ Revision: 556694
- 5.2.0 final
2013-12-01 - fwang <fwang> 5.2.0-1.rc1.1.mga4
+ Revision: 554396
- 5.2.0 rc1
2013-10-26 - fwang <fwang> 5.2.0-1.beta1.2.mga4
+ Revision: 547083
- use xkbcommon instead
- br xcb-xkb
2013-10-26 - fwang <fwang> 5.2.0-1.beta1.1.mga4
+ Revision: 547072
- 5.2.0 beta1
2013-10-21 - umeabot <umeabot> 5.2.0-1.alpha.2.mga4
+ Revision: 538802
- Mageia 4 Mass Rebuild
2013-10-02 - neoclust <neoclust> 5.2.0-1.alpha.1.mga4
+ Revision: 490404
- New version 5.2.0 alpha
2013-09-26 - fwang <fwang> 5.2.0-0.0.20130523.9.mga4
+ Revision: 486794
- rebuild for icu 52
2013-08-10 - wally <wally> 5.2.0-0.0.20130523.8.mga4
+ Revision: 465090
- add more cmake fixes (rediff patch)
2013-08-10 - neoclust <neoclust> 5.2.0-0.0.20130523.7.mga4
+ Revision: 465081
- Add fedora patch to fix cmake path search

See Also

Package Description
libqt5printsupport-private-devel-5.2.0-2.3.mga4.i586.rpm Devel files needed to build apps based on QtPrintSupport
libqt5printsupport-private-devel-5.2.0-2.4.mga4.i586.rpm Devel files needed to build apps based on QtPrintSupport
libqt5printsupport-private-devel-5.2.0-2.5.mga4.i586.rpm Devel files needed to build apps based on QtPrintSupport
libqt5printsupport5-5.2.0-2.3.mga4.i586.rpm Qt5 Lib
libqt5printsupport5-5.2.0-2.4.mga4.i586.rpm Qt5 Lib
libqt5printsupport5-5.2.0-2.5.mga4.i586.rpm Qt5 Lib
libqt5sql-devel-5.2.0-2.3.mga4.i586.rpm Devel files needed to build apps based on QtSql
libqt5sql-devel-5.2.0-2.4.mga4.i586.rpm Devel files needed to build apps based on QtSql
libqt5sql-devel-5.2.0-2.5.mga4.i586.rpm Devel files needed to build apps based on QtSql
libqt5sql-private-devel-5.2.0-2.3.mga4.i586.rpm Devel files needed to build apps based on QtSql
libqt5sql-private-devel-5.2.0-2.4.mga4.i586.rpm Devel files needed to build apps based on QtSql
libqt5sql-private-devel-5.2.0-2.5.mga4.i586.rpm Devel files needed to build apps based on QtSql
libqt5sql5-5.2.0-2.3.mga4.i586.rpm Qt5 Component Library
libqt5sql5-5.2.0-2.4.mga4.i586.rpm Qt5 Component Library
libqt5sql5-5.2.0-2.5.mga4.i586.rpm Qt5 Component Library
Advertisement
Advertisement