libqtwebkit2.2-devel-2.3.3-3.1.mga4.i586.rpm


Advertisement

Description

libqtwebkit2.2-devel - Qt Webkit 2.3 Development Files

Property Value
Distribution Mageia 4.1
Repository Mageia Core Updates i586
Package name libqtwebkit2.2-devel
Package version 2.3.3
Package release 3.1.mga4
Package architecture i586
Package type rpm
Installed size 72.90 KB
Download size 23.10 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Development files to build applications against Qt Webkit 2.3.x

Alternatives

Package Version Architecture Repository
libqtwebkit2.2-devel-2.3.3-3.mga4.i586.rpm 2.3.3 i586 Mageia Core
libqtwebkit2.2-devel - - -

Requires

Name Value
devel(libGL) -
devel(libQtCore) -
devel(libQtGui) -
devel(libQtLocation) -
devel(libQtNetwork) -
devel(libQtOpenGL) -
devel(libQtSensors) -
devel(libX11) -
devel(libXext) -
devel(libXrender) -
devel(libdl) -
devel(libfontconfig) -
devel(libfreetype) -
devel(libgcc_s) -
devel(libgio-2.0) -
devel(libglib-2.0) -
devel(libgmodule-2.0) -
devel(libgobject-2.0) -
devel(libgstapp-0.10) -
devel(libgstbase-0.10) -
devel(libgstinterfaces-0.10) -
devel(libgstpbutils-0.10) -
devel(libgstreamer-0.10) -
devel(libgstvideo-0.10) -
devel(libgthread-2.0) -
devel(libjpeg) -
devel(libm) -
devel(libpng16) -
devel(libsqlite3) -
devel(libstdc++) -
devel(libudev) -
devel(libwebp) -
devel(libxml2) -
devel(libxslt) -
devel(libz) -
libqtwebkit2.2_4 == 2.3.3-3.1.mga4
pkgconfig -
pkgconfig(QtCore) -
pkgconfig(QtGui) -
pkgconfig(QtNetwork) -
qt-mobility-devel -
qt4-devel -

Provides

Name Value
devel(libQtWebKit) -
libqtwebkit2.2-devel == 2.3.3-3.1.mga4
libqtwebkit2.2-devel(x86-32) == 2.3.3-3.1.mga4
pkgconfig(QtWebKit) == 4.10.3
qtwebkit-devel == 2.3.3-3.1.mga4

Conflicts

Name Value
libqt4-devel < 4:4.7.4-6

Download

Type URL
Binary Package libqtwebkit2.2-devel-2.3.3-3.1.mga4.i586.rpm
Source Package qtwebkit-2.3.3-3.1.mga4.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libqtwebkit2.2-devel rpm package:
    # urpmi libqtwebkit2.2-devel

Files

Path
/usr/include/QtWebKit/QGraphicsWebView
/usr/include/QtWebKit/QWebDatabase
/usr/include/QtWebKit/QWebElement
/usr/include/QtWebKit/QWebElementCollection
/usr/include/QtWebKit/QWebFrame
/usr/include/QtWebKit/QWebFullScreenVideoHandler
/usr/include/QtWebKit/QWebHapticFeedbackPlayer
/usr/include/QtWebKit/QWebHistory
/usr/include/QtWebKit/QWebHistoryInterface
/usr/include/QtWebKit/QWebHistoryItem
/usr/include/QtWebKit/QWebHitTestResult
/usr/include/QtWebKit/QWebInspector
/usr/include/QtWebKit/QWebKitPlatformPlugin
/usr/include/QtWebKit/QWebNotificationData
/usr/include/QtWebKit/QWebNotificationPresenter
/usr/include/QtWebKit/QWebPage
/usr/include/QtWebKit/QWebPluginFactory
/usr/include/QtWebKit/QWebScriptWorld
/usr/include/QtWebKit/QWebSecurityOrigin
/usr/include/QtWebKit/QWebSelectData
/usr/include/QtWebKit/QWebSelectMethod
/usr/include/QtWebKit/QWebSettings
/usr/include/QtWebKit/QWebSpellChecker
/usr/include/QtWebKit/QWebTouchModifier
/usr/include/QtWebKit/QWebView
/usr/include/QtWebKit/QtWebKit
/usr/include/QtWebKit/qgraphicswebview.h
/usr/include/QtWebKit/qwebdatabase.h
/usr/include/QtWebKit/qwebelement.h
/usr/include/QtWebKit/qwebframe.h
/usr/include/QtWebKit/qwebhistory.h
/usr/include/QtWebKit/qwebhistoryinterface.h
/usr/include/QtWebKit/qwebinspector.h
/usr/include/QtWebKit/qwebkitglobal.h
/usr/include/QtWebKit/qwebkitplatformplugin.h
/usr/include/QtWebKit/qwebkitversion.h
/usr/include/QtWebKit/qwebpage.h
/usr/include/QtWebKit/qwebpluginfactory.h
/usr/include/QtWebKit/qwebscriptworld.h
/usr/include/QtWebKit/qwebsecurityorigin.h
/usr/include/QtWebKit/qwebsettings.h
/usr/include/QtWebKit/qwebview.h
/usr/lib/libQtWebKit.prl
/usr/lib/libQtWebKit.so
/usr/lib/pkgconfig/QtWebKit.pc
/usr/lib/qt4/mkspecs/modules/qt_webkit.pri

Changelog

2015-04-22 - luigiwalser <luigiwalser> 2.3.3-3.1.mga4
+ Revision: 820555
- add patch from fedora to fix security issue (mga#15749, rhbz#1204795)
2013-12-23 - neoclust <neoclust> 2.3.3-3.mga4
+ Revision: 560260
- Add a provide for qtwebkit, needed by Google Music s music manager ( mga #7943)
2013-10-22 - umeabot <umeabot> 2.3.3-2.mga4
+ Revision: 545235
- Mageia 4 Mass Rebuild
2013-10-15 - luigiwalser <luigiwalser> 2.3.3-1.mga4
+ Revision: 500923
- 2.3.3
- partial sync with fedora
- update some incorrect references to qtwebkit 2.2 to say 2.3
2013-08-04 - lmenut <lmenut> 2.3.2-2.mga4
+ Revision: 463341
- bump release to be higher than in mga3 update
2013-07-13 - mikala <mikala> 2.3.2-1.mga4
+ Revision: 453888
- Update tarball to 2.3.2
2013-06-02 - fwang <fwang> 2.3.0-3.mga4
+ Revision: 434677
- rebuild for new libpng
2013-05-27 - neoclust <neoclust> 2.3.0-2.mga4
+ Revision: 428732
- Do not add qt5 buildrequires
Fix crashes on non sse2 machines
2013-05-27 - blino <blino> 2.3.0-1.mga4
+ Revision: 428722
- buildrequire qt5widgets-private-devel for private/qaccessiblewidget_p.h
2013-03-25 - neoclust <neoclust> 2.3.0-1.mga3
+ Revision: 405217
- New version 2.3.0

See Also

Package Description
libqtwebkit2.2_4-2.3.3-3.1.mga4.i586.rpm Qt Webkit 2.3 Library
libqtxml4-4.8.6-1.1.mga4.i586.rpm Qt4 Component Library
libqtxml4-4.8.6-1.2.mga4.i586.rpm Qt4 Component Library
libqtxml4-4.8.6-1.3.mga4.i586.rpm Qt4 Component Library
libqtxml4-4.8.6-1.mga4.i586.rpm Qt4 Component Library
libqtxmlpatterns4-4.8.6-1.1.mga4.i586.rpm Qt4 Component Library
libqtxmlpatterns4-4.8.6-1.2.mga4.i586.rpm Qt4 Component Library
libqtxmlpatterns4-4.8.6-1.3.mga4.i586.rpm Qt4 Component Library
libqtxmlpatterns4-4.8.6-1.mga4.i586.rpm Qt4 Component Library
libquadmath-devel-4.8.2-3.2.mga4.i586.rpm GCC __float128 support
libquadmath0-4.8.2-3.2.mga4.i586.rpm GCC __float128 shared support library
libqyoto2-4.12.5-1.mga4.i586.rpm Runtime library for Qt NET/Mono bindings
libraw-devel-0.15.4-2.1.mga4.i586.rpm LibRaw development libraries
libraw-tools-0.15.4-2.1.mga4.i586.rpm Tools available in libraw
libraw9-0.15.4-2.1.mga4.i586.rpm Raw image decoder library (non-thread-safe)
Advertisement
Advertisement