librpm-devel-4.11.1-9.mga4.i586.rpm


Advertisement

Description

librpm-devel - Development files for applications which will manipulate RPM packages

Property Value
Distribution Mageia 4.1
Repository Mageia Core Updates i586
Package name librpm-devel
Package version 4.11.1
Package release 9.mga4
Package architecture i586
Package type rpm
Installed size 238.80 KB
Download size 65.81 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
This package contains the RPM C library and header files.  These
development files will simplify the process of writing programs
which manipulate RPM packages and databases and are intended to make
it easier to create graphical package managers or any other tools
that need an intimate knowledge of RPM packages in order to function.
This package should be installed if you want to develop programs that
will manipulate RPM packages and databases.

Alternatives

Package Version Architecture Repository
librpm-devel-4.11.1-9.1.mga4.i586.rpm 4.11.1 i586 Mageia Core Updates
librpm-devel-4.11.1-8.mga4.i586.rpm 4.11.1 i586 Mageia Core
librpm-devel - - -

Requires

Name Value
devel(libbz2) -
devel(libcap) -
devel(libdb-5.3) -
devel(libdl) -
devel(libelf) -
devel(liblua) -
devel(liblzma) -
devel(libmagic) -
devel(libnss3) -
devel(libpopt) -
devel(librpm) -
devel(librpmio) -
devel(libz) -
librpm3 == 1:4.11.1-9.mga4
librpmbuild3 == 1:4.11.1-9.mga4
librpmsign3 == 1:4.11.1-9.mga4
pkgconfig -
rpm == 1:4.11.1-9.mga4

Provides

Name Value
devel(librpm) -
devel(librpmbuild) -
devel(librpmio) -
devel(librpmsign) -
librpm-devel == 1:4.11.1-9.mga4
librpm-devel == 4.11.1-9.mga4
librpm-devel(x86-32) == 1:4.11.1-9.mga4
pkgconfig(rpm) == 4.11.1
rpm-devel == 4.11.1-9.mga4

Download

Type URL
Binary Package librpm-devel-4.11.1-9.mga4.i586.rpm
Source Package rpm-4.11.1-9.mga4.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install librpm-devel rpm package:
    # urpmi librpm-devel

Files

Path
/usr/include/rpm/argv.h
/usr/include/rpm/header.h
/usr/include/rpm/rpmbase64.h
/usr/include/rpm/rpmbuild.h
/usr/include/rpm/rpmcallback.h
/usr/include/rpm/rpmcli.h
/usr/include/rpm/rpmdb.h
/usr/include/rpm/rpmds.h
/usr/include/rpm/rpmfc.h
/usr/include/rpm/rpmfi.h
/usr/include/rpm/rpmfileutil.h
/usr/include/rpm/rpmio.h
/usr/include/rpm/rpmkeyring.h
/usr/include/rpm/rpmlegacy.h
/usr/include/rpm/rpmlib.h
/usr/include/rpm/rpmlog.h
/usr/include/rpm/rpmmacro.h
/usr/include/rpm/rpmpgp.h
/usr/include/rpm/rpmpol.h
/usr/include/rpm/rpmprob.h
/usr/include/rpm/rpmps.h
/usr/include/rpm/rpmsign.h
/usr/include/rpm/rpmspec.h
/usr/include/rpm/rpmsq.h
/usr/include/rpm/rpmstring.h
/usr/include/rpm/rpmstrpool.h
/usr/include/rpm/rpmsw.h
/usr/include/rpm/rpmtag.h
/usr/include/rpm/rpmtd.h
/usr/include/rpm/rpmte.h
/usr/include/rpm/rpmts.h
/usr/include/rpm/rpmtypes.h
/usr/include/rpm/rpmurl.h
/usr/include/rpm/rpmutil.h
/usr/include/rpm/rpmvf.h
/usr/lib/librpm.so
/usr/lib/librpmbuild.so
/usr/lib/librpmio.so
/usr/lib/librpmsign.so
/usr/lib/pkgconfig/rpm.pc

Changelog

See rpm-4.11.1-9.mga4.i586.rpm changelog.

See Also

Package Description
librpm3-4.11.1-9.1.mga4.i586.rpm Library used by rpm
librpm3-4.11.1-9.mga4.i586.rpm Library used by rpm
librpmbuild3-4.11.1-9.1.mga4.i586.rpm Libraries for building and signing RPM packages
librpmbuild3-4.11.1-9.mga4.i586.rpm Libraries for building and signing RPM packages
librpmsign3-4.11.1-9.1.mga4.i586.rpm Libraries for building and signing RPM packages
librpmsign3-4.11.1-9.mga4.i586.rpm Libraries for building and signing RPM packages
librsvg-2.39.0-1.2.mga4.i586.rpm Raph's SVG library
librsvg-gir2.0-2.39.0-1.2.mga4.i586.rpm GObject Introspection interface description for librsvg
librsvg2-devel-2.39.0-1.2.mga4.i586.rpm Libraries and include files for developing with librsvg
librsvg2_2-2.39.0-1.2.mga4.i586.rpm Raph's SVG library
librsync-devel-1.0.0-2.2.mga4.i586.rpm Headers for librsync
librsync2-1.0.0-2.2.mga4.i586.rpm Rsync libraries
librtfreader12-2.7.5-1.1.mga4.i586.rpm Calligra core library
librtm4-4.12.5-1.1.mga4.i586.rpm KDE/Qt library for online Remember The Milk service
libruby2.0-2.0.0.p594-1.mga4.i586.rpm Libraries necessary to run Ruby
Advertisement
Advertisement