libstdc++6-4.8.2-3.2.mga4.i586.rpm


Advertisement

Description

libstdc++6 - GNU C++ library

Property Value
Distribution Mageia 4.1
Repository Mageia Core Updates i586
Package filename libstdc++6-4.8.2-3.2.mga4.i586.rpm
Package name libstdc++6
Package version 4.8.2
Package release 3.2.mga4
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://gcc.gnu.org/
License GPLv3+
Maintainer -
Download size 253.71 KB
Installed size 907.76 KB
This package contains the GCC Standard C++ Library v3, an ongoing
project to implement the ISO/IEC 14882:1998 Standard C++ library.

Alternatives

Package Version Architecture Repository
libstdc++6-4.8.2-3.2.mga4.x86_64.rpm 4.8.2 x86_64 Mageia Core Updates
libstdc++6-4.8.2-3.mga4.i586.rpm 4.8.2 i586 Mageia Core
libstdc++6-4.8.2-3.mga4.x86_64.rpm 4.8.2 x86_64 Mageia Core
libstdc++6 - - -

Requires

Name Value
ld-linux.so.2 -
ld-linux.so.2(GLIBC_2.3) -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.2) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_3.3) -
libgcc_s.so.1(GCC_4.2.0) -
libgcc_s.so.1(GLIBC_2.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -

Provides

Name Value
libstdc++ == 4.8.2-3.2.mga4
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.1) -
libstdc++.so.6(CXXABI_1.3.2) -
libstdc++.so.6(CXXABI_1.3.3) -
libstdc++.so.6(CXXABI_1.3.4) -
libstdc++.so.6(CXXABI_1.3.5) -
libstdc++.so.6(CXXABI_1.3.6) -
libstdc++.so.6(CXXABI_1.3.7) -
libstdc++.so.6(CXXABI_TM_1) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.1) -
libstdc++.so.6(GLIBCXX_3.4.10) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.12) -
libstdc++.so.6(GLIBCXX_3.4.13) -
libstdc++.so.6(GLIBCXX_3.4.14) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.16) -
libstdc++.so.6(GLIBCXX_3.4.17) -
libstdc++.so.6(GLIBCXX_3.4.18) -
libstdc++.so.6(GLIBCXX_3.4.19) -
libstdc++.so.6(GLIBCXX_3.4.2) -
libstdc++.so.6(GLIBCXX_3.4.3) -
libstdc++.so.6(GLIBCXX_3.4.4) -
libstdc++.so.6(GLIBCXX_3.4.5) -
libstdc++.so.6(GLIBCXX_3.4.6) -
libstdc++.so.6(GLIBCXX_3.4.7) -
libstdc++.so.6(GLIBCXX_3.4.8) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libstdc++4.8 == 4.8.2-3.2.mga4
libstdc++6 == 4.8.2-3.2.mga4
libstdc++6(x86-32) == 4.8.2-3.2.mga4

Obsoletes

Name Value
libstdc++4.8 -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libstdc++6-4.8.2-3.2.mga4.i586.rpm
Source Package gcc-4.8.2-3.2.mga4.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libstdc++6 rpm package:
    # urpmi libstdc++6

Files

Path
/usr/lib/libstdc++.so.6
/usr/lib/libstdc++.so.6.0.18

Changelog

2014-07-31 - tmb <tmb> 4.8.2-3.2.mga4
+ Revision: 658567
- fix memory overflow in libgfortran (CVE-2014-5044)
- gcc/PR61801: fix sched2 miscompiles syscall sequence
- ship cxxabi.h and cxxabi_tweaks.h in both upstream default path for clang
to work and Mageia specific path to keep backward compatibility (mga#13543)
2013-10-23 - tmb <tmb> 4.8.2-3.mga4
+ Revision: 546668
- fix bug in nth_element (PR libstdc++/58800, mga #11516)
2013-10-22 - umeabot <umeabot> 4.8.2-2.mga4
+ Revision: 545598
- Mageia 4 Mass Rebuild
2013-10-16 - tmb <tmb> 4.8.2-1.mga4
+ Revision: 501462
- update to 4.8.2 final
2013-10-12 - tmb <tmb> 4.8.2-0.20131009.2.mga4
+ Revision: 496063
- rebuild with new binutils & make
2013-10-11 - tmb <tmb> 4.8.2-0.20131009.1.mga4
+ Revision: 495122
- update to 4.8.2 RC
2013-10-04 - tmb <tmb> 4.8.2-0.20131003.1.mga4
+ Revision: 491582
- update filelists
- update to 2013-10-03
2013-09-22 - tmb <tmb> 4.8.2-0.20130919.1.mga4
+ Revision: 483258
- update to 2013-09-19
2013-09-17 - tmb <tmb> 4.8.2-0.20130912.1.mga4
+ Revision: 480784
- update to 2013-09-12
2013-09-10 - tmb <tmb> 4.8.2-0.20130905.1.mga4
+ Revision: 477216
- update to 2013-09-05

See Also

Package Description
libsuperkaramba4-4.12.5-1.mga4.i586.rpm Runtime library for superkaramba
libsvn-gnome-keyring0-1.8.10-1.mga4.i586.rpm gnome-keyring support for svn
libsvn-gnome-keyring0-1.8.11-1.mga4.i586.rpm gnome-keyring support for svn
libsvn-gnome-keyring0-1.8.13-1.mga4.i586.rpm gnome-keyring support for svn
libsvn-gnome-keyring0-1.8.14-1.mga4.i586.rpm gnome-keyring support for svn
libsvn-gnome-keyring0-1.8.8-1.mga4.i586.rpm gnome-keyring support for svn
libsvn-kwallet0-1.8.10-1.mga4.i586.rpm kwallet support for svn
libsvn-kwallet0-1.8.11-1.mga4.i586.rpm kwallet support for svn
libsvn-kwallet0-1.8.13-1.mga4.i586.rpm kwallet support for svn
libsvn-kwallet0-1.8.14-1.mga4.i586.rpm kwallet support for svn
libsvn-kwallet0-1.8.8-1.mga4.i586.rpm kwallet support for svn
libsvn0-1.8.10-1.mga4.i586.rpm Subversion libraries
libsvn0-1.8.11-1.mga4.i586.rpm Subversion libraries
libsvn0-1.8.13-1.mga4.i586.rpm Subversion libraries
libsvn0-1.8.14-1.mga4.i586.rpm Subversion libraries
Advertisement
Advertisement