openldap-2.4.38-1.3.mga4.i586.rpm


Advertisement

Description

openldap - LDAP servers and sample clients

Distribution: Mageia 4.1
Repository: Mageia Core Updates i586
Package name: openldap
Package version: 2.4.38
Package release: 1.3.mga4
Package architecture: i586
Package type: rpm
Installed size: 15.78 KB
Download size: 18.47 KB
Official Mirror: distrib-coffee.ipsl.jussieu.fr
OpenLDAP is an open source suite of LDAP (Lightweight Directory Access Protocol) applications and development tools. The suite includes a stand-alone LDAP server (slapd) which is in the -servers package, libraries for implementing the LDAP protocol (in the lib packages), and utilities, tools, and sample clients (in the -clients package). The openldap binary package includes only configuration files used by the libraries. Install openldap if you need LDAP applications and tools.

Alternatives

Provides

  • openldap == 2.4.38-1.3.mga4
  • openldap(x86-32) == 2.4.38-1.3.mga4

    Download

    Install Howto

    1. Enable Mageia Core Updates repository on "Install and Remove Software"
    2. Update packages list:
      # urpmi.update -a
    3. Install openldap rpm package:
      # urpmi openldap

    Files

    • /etc/openldap/ldap.conf
    • /etc/openldap/ldapserver
    • /usr/share/doc/openldap/README.mdk
    • /usr/share/man/man5/ldap.conf.5.xz
    • /usr/share/man/man5/ldif.5.xz

    Changelog

    2015-04-08 - luigiwalser <luigiwalser> 2.4.38-1.3.mga4 + Revision: 819890 - fix script name typo in openldap-servers pre scriplet - add upstream patch to fix CVE-2015-1545 - add patch from redhat to fix CVE-2013-4449

    2014-01-01 - buchan <buchan> 2.4.38-1.mga4 + Revision: 563729 - Fix build on i586 - New version 2.4.38 - Update some patches for 2.4.35 and later - Fix installation of nssov - Include post-2.4.38 patches for ITSs: 7749, 7750, 7756, 7757 - In order to allow removal of back_bdb in future without breaking configs: - Build back_bdb and back_hdb as modules and ship in openldap-back_bdb package - Add triggerpostun in openldap-back_bdb on openldap-servers to modify the configuration (either slapd.conf or slapd.d) to ensure the modules are loaded. - Until after mga4 release, openldap-servers will require openldap-back_bdb since many users will require them - Split back_sql out as well to reduce dependencies - Ship mdb backend in a separate package, with mdb utils - Add systemd support (but still provide init script for legacy systems) - Rename service from 'ldap' to 'slapd'

    2013-08-31 - wally <wally> 2.4.33-10.mga4 + Revision: 473694 - fix sasl libname again

    2013-08-29 - fwang <fwang> 2.4.33-9.mga4 + Revision: 472766 - fix sasl libname

    2013-08-27 - luigiwalser <luigiwalser> 2.4.33-8.mga4 + Revision: 472082 - rebuild for cyrus-sasl

    2013-05-11 - guillomovitch <guillomovitch> 2.4.33-7.mga3 + Revision: 413001 - use systemctl in logrotate, instead of sysinit script

    2013-05-08 - luigiwalser <luigiwalser> 2.4.33-6.mga3 + Revision: 412661 - fix upgrade issue during installer when /var/lock/subsys does not exist

    2013-03-27 - mitya <mitya> 2.4.33-5.mga3 + Revision: 405431 - Build with SLAPI support

    2013-03-24 - colin <colin> 2.4.33-4.mga3 + Revision: 404859 - Add systemd requires and general post/pre fixes (mga#9302) - Ensure tmpfiles support is optional for better portability

    2013-01-17 - colin <colin> 2.4.33-2.mga3 + Revision: 389011 - Switch to tmpfiles for /run dir creation

    Advertisement
    Advertisement