php-mysqli-5.5.24-1.mga4.i586.rpm


Advertisement

Description

php-mysqli - MySQL database module for PHP

Distribution: Mageia 4.1
Repository: Mageia Core Updates i586
Package name: php-mysqli
Package version: 5.5.24
Package release: 1.mga4
Package architecture: i586
Package type: rpm
Installed size: 139.04 KB
Download size: 47.24 KB
Official Mirror: distrib-coffee.ipsl.jussieu.fr
This is a dynamic shared object (DSO) for PHP that will add MySQL database support. The mysqli extension allows you to access the functionality provided by MySQL 4.1 and above. It is an improved version of the older PHP MySQL driver, offering various benefits. The developers of the PHP programming language recommend using MySQLi when dealing with MySQL server versions 4.1.3 and newer (takes advantage of new functionality) More information about the MySQL Database server can be found at http://www.mysql.com/ Documentation for MySQL can be found at http://dev.mysql.com/doc/. Documentation for MySQLi can be found at http://www.php.net/manual/en/mysqli.overview.php.

Alternatives

Provides

  • mysqli.so
  • php-mysqli == 3:5.5.24-1.mga4
  • php-mysqli(x86-32) == 3:5.5.24-1.mga4

    Download

    Install Howto

    1. Enable Mageia Core Updates repository on "Install and Remove Software"
    2. Update packages list:
      # urpmi.update -a
    3. Install php-mysqli rpm package:
      # urpmi php-mysqli

    Files

    • /etc/php.d/37_mysqli.ini
    • /usr/lib/php/extensions/mysqli.so

    Changelog

    2015-04-17 - luigiwalser <luigiwalser> 3:5.5.24-1.mga4 + Revision: 820364 - 5.5.24 - remove upstreamed CVE-2015-135[12] patches - 5.5.23 - remove upstream patch for php#68942 - remove CVE-2015-2305 patch (fixed upstream) - add patch from dragonflybsd via debian to fix CVE-2015-2305 - add upstream patch to fix secondary issue in php#68942 - 5.5.22 - rediff patch 25 - rediff upstream patches to fix CVE-2015-1351 and CVE-2015-1352 - 5.5.21 - 5.5.20 - rediff patches 3 and 20 - 5.5.19 - remove CVE-2014-3710 patch (fixed upstream in 5.5.19) - add upstream patch to fix CVE-2014-3710 - 5.5.16 - remove upstreamed CVE-2014-3538 patch - 5.5.14 - 5.5.13 - 5.5.11 + oden <oden> - jsonc-1.3.7 (http://pecl.php.net/package-changelog.php?package=jsonc&release=1.3.7) - fix #13820 (PHP zip makes httpd crash when adding file to an archive.) - 5.5.18 (fixes CVE-2014-3669, CVE-2014-3670, CVE-2014-3668) - P230: security fix for CVE-2014-3538 (upstream) - 5.5.15 - jsonc-1.3.6 - 5.5.12 - jsonc-1.3.5 - P23: rediff - also sync spec file changes with cauldron - sync patches with cauldron - 5.5.10 - jsonc-1.3.4

    2014-01-14 - luigiwalser <luigiwalser> 3:5.5.8-2.mga4 + Revision: 566586 - do not reload httpd when it is not running in filetriggers

    2014-01-14 - oden <oden> 3:5.5.8-1.mga4 + Revision: 566544 - 5.5.8 - rediff the external libzip patch - jsonc-1.3.3

    2013-12-13 - luigiwalser <luigiwalser> 3:5.5.7-1.mga4 + Revision: 556537 - 5.5.7

    2013-11-22 - oden <oden> 3:5.5.6-1.mga4 + Revision: 552282 - rediff some patches - 5.5.6

    2013-10-22 - oden <oden> 3:5.5.5-1.mga4 + Revision: 545808 - 5.5.5 (http://www.php.net/ChangeLog-5.php#5.5.5)

    2013-10-21 - umeabot <umeabot> 3:5.5.4-3.mga4 + Revision: 537673 - Mageia 4 Mass Rebuild

    2013-09-27 - fwang <fwang> 3:5.5.4-2.mga4 + Revision: 487500 - rebuild for icu 52

    2013-09-20 - fwang <fwang> 3:5.5.4-1.mga4 + Revision: 481811 - 5.5.4 final

    2013-09-10 - fwang <fwang> 3:5.5.4-0.0.RC1.3.mga4 + Revision: 477030 - rebuild for new postgresql

    Advertisement
    Advertisement