libffi6-3.1-4.mga5.i586.rpm


Advertisement

Description

libffi6 - A portable foreign function interface library

Property Value
Distribution Mageia 5.1
Repository Mageia Core i586
Package name libffi6
Package version 3.1
Package release 4.mga5
Package architecture i586
Package type rpm
Installed size 43.07 KB
Download size 29.48 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Compilers for high level languages generate code that follow certain
conventions.  These conventions are necessary, in part, for separate
compilation to work.  One such convention is the "calling convention".
The calling convention is a set of assumptions made by the compiler
about where function arguments will be found on entry to a function.
A calling convention also specifies where the return value for a function
is found.
Some programs may not know at the time of compilation what arguments
are to be passed to a function.  For instance, an interpreter may be
told at run-time about the number and types of arguments used to call
a given function.  `Libffi' can be used in such programs to provide
a bridge from the interpreter program to compiled code.
The `libffi' library provides a portable, high level programming
interface to various calling conventions.  This allows a programmer to
call any function specified by a call interface description at run time.
FFI stands for Foreign Function Interface.  A foreign function
interface is the popular name for the interface that allows code
written in one language to call code written in another language.
The `libffi' library really only provides the lowest, machine dependent
layer of a fully featured foreign function interface.  A layer must
exist above `libffi' that handles type conversions for values passed
between the two languages.

Alternatives

Package Version Architecture Repository
libffi6-3.1-4.1.mga5.i586.rpm 3.1 i586 Mageia Core Updates
libffi6 - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.4) -

Provides

Name Value
libffi == 3.1-4.mga5
libffi.so.6 -
libffi6 == 3.1-4.mga5
libffi6(x86-32) == 3.1-4.mga5

Download

Type URL
Binary Package libffi6-3.1-4.mga5.i586.rpm
Source Package libffi-3.1-4.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libffi6 rpm package:
    # urpmi libffi6

Files

Path
/usr/lib/libffi.so.6
/usr/lib/libffi.so.6.0.2
/usr/share/doc/libffi6/LICENSE
/usr/share/doc/libffi6/README

Changelog

2014-10-15 - umeabot <umeabot> 3.1-4.mga5
+ Revision: 745917
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 3.1-3.mga5
+ Revision: 681456
- Mageia 5 Mass Rebuild
2014-08-10 - akien <akien> 3.1-2.mga5
+ Revision: 661520
- Fix pkg-config file (upstream patch)
2014-06-04 - sander85 <sander85> 3.1-1.mga5
+ Revision: 632883
- New version: 3.1
2013-10-19 - umeabot <umeabot> 3.0.13-2.mga4
+ Revision: 523735
- Mageia 4 Mass Rebuild
2013-05-24 - tv <tv> 3.0.13-1.mga4
+ Revision: 426596
- new release
2013-05-09 - colin <colin> 3.0.11-3.mga3
+ Revision: 412789
- Rename -devel package to fit library policy (gcj no longer conflicts)
2013-01-12 - umeabot <umeabot> 3.0.11-2.mga3
+ Revision: 357102
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
2012-08-06 - luigiwalser <luigiwalser> 3.0.11-1.mga3
+ Revision: 278977
- 3.0.11 (updates major to 6)

See Also

Package Description
libffmpeg-devel-2.4.9-1.mga5.i586.rpm Header files for the ffmpeg codec library
libffmpeg-static-devel-2.4.9-1.mga5.i586.rpm Static library for the ffmpeg codec library
libffmpegthumbnailer-devel-2.0.8-10.mga5.i586.rpm Development files for ffmpegthumbnailer
libffmpegthumbnailer4-2.0.8-10.mga5.i586.rpm Main library for ffmpegthumbnailer
libffms2-devel-2.20-4.mga5.i586.rpm Development package for ffms2
libffms2_3-2.20-4.mga5.i586.rpm Library for ffms2
libfftw-devel-3.3.4-3.mga5.i586.rpm Headers, libraries, & docs for the FFTW fast Fourier transform library
libfftw-static-devel-3.3.4-3.mga5.i586.rpm Static development files for the FFTW fast Fourier transform library
libfftw3-3.3.4-3.mga5.i586.rpm Fast Fourier transform library
libfftwmpi3-3.3.4-3.mga5.i586.rpm MPI-parallel fast Fourier transform library
libfftwomp3-3.3.4-3.mga5.i586.rpm OpenMP-parallel fast Fourier transform library
libfife-devel-0.4.0-0.20141115.1.mga5.i586.rpm Development package for fife
libfife0-0.4.0-0.20141115.1.mga5.i586.rpm Shared libs for fife
libfifechan-devel-0.1.2-1.mga5.i586.rpm Headers for developing programs that will use fifechan
libfifechan0.1.2-0.1.2-1.mga5.i586.rpm Shared library for fifechan
Advertisement
Advertisement