libgcrypt11-1.5.4-5.mga5.i586.rpm


Advertisement

Description

libgcrypt11 - GNU Cryptographic library

Property Value
Distribution Mageia 5.1
Repository Mageia Core i586
Package filename libgcrypt11-1.5.4-5.mga5.i586.rpm
Package name libgcrypt11
Package version 1.5.4
Package release 5.mga5
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://www.gnupg.org/
License LGPLv2+
Maintainer -
Download size 273.39 KB
Installed size 668.39 KB
Libgcrypt is a general purpose cryptographic library
based on the code from GNU Privacy Guard.  It provides functions for all
cryptograhic building blocks: symmetric ciphers
(AES,DES,Blowfish,CAST5,Twofish,Arcfour), hash algorithms (MD5,
RIPE-MD160, SHA-1, TIGER-192), MACs (HMAC for all hash algorithms),
public key algorithms (RSA, ElGamal, DSA), large integer functions,
random numbers and a lot of supporting functions.

Alternatives

Package Version Architecture Repository
libgcrypt11-1.5.4-5.5.mga5.i586.rpm 1.5.4 i586 Mageia Core Updates
libgcrypt11-1.5.4-5.4.mga5.i586.rpm 1.5.4 i586 Mageia Core Updates
libgcrypt11-1.5.4-5.3.mga5.i586.rpm 1.5.4 i586 Mageia Core Updates
libgcrypt11-1.5.4-5.2.mga5.i586.rpm 1.5.4 i586 Mageia Core Updates
libgcrypt11 - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.15) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libgcrypt.so.11 -
libgcrypt.so.11(GCRYPT_1.2) -
libgpg-error.so.0 -
libpth.so.20 -
multiarch-utils -

Provides

Name Value
libgcrypt == 1.5.4-5.mga5
libgcrypt.so.11 -
libgcrypt.so.11(GCRYPT_1.2) -
libgcrypt11 == 1.5.4-5.mga5
libgcrypt11(x86-32) == 1.5.4-5.mga5

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package libgcrypt11-1.5.4-5.mga5.i586.rpm
Source Package libgcrypt-1.5.4-5.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libgcrypt11 rpm package:
    # urpmi libgcrypt11

Files

Path
/usr/bin/multiarch-i386-linux/gcryptrnd
/usr/lib/libgcrypt.so.11
/usr/lib/libgcrypt.so.11.8.3
/usr/share/doc/libgcrypt11/AUTHORS
/usr/share/doc/libgcrypt11/NEWS
/usr/share/doc/libgcrypt11/README
/usr/share/doc/libgcrypt11/THANKS
/usr/share/doc/libgcrypt11/TODO

Changelog

2015-04-01 - luigiwalser <luigiwalser> 1.5.4-5.mga5
+ Revision: 819552
- add patch from ubuntu to fix CVE-2015-0837
2015-03-06 - luigiwalser <luigiwalser> 1.5.4-4.mga5
+ Revision: 817945
- add upstream patch to fix CVE-2014-3591
2014-10-15 - umeabot <umeabot> 1.5.4-3.mga5
+ Revision: 744285
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 1.5.4-2.mga5
+ Revision: 681474
- Mageia 5 Mass Rebuild
2014-08-11 - luigiwalser <luigiwalser> 1.5.4-1.mga5
+ Revision: 661714
- 1.5.4 (fixes elgamal side-channel attack)
2013-10-19 - umeabot <umeabot> 1.5.3-2.mga4
+ Revision: 530654
- Mageia 4 Mass Rebuild
2013-07-27 - boklm <boklm> 1.5.3-1.mga4
+ Revision: 458790
- Version 1.5.3 (CVE-2013-4242)
2013-06-13 - fwang <fwang> 1.5.2-1.mga4
+ Revision: 442314
- new version 1.5.2
2013-01-12 - umeabot <umeabot> 1.5.0-3.mga3
+ Revision: 357154
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild

See Also

Package Description
libgcrystal0.14_0-0.14.8-6.mga5.i586.rpm Libraries for gchempaint
libgcu0.14_0-0.14.8-6.mga5.i586.rpm Main libraries for gnome-chemistry-utils
libgd-devel-2.1.1-1.mga5.i586.rpm The development libraries and header files for gd
libgd-static-devel-2.1.1-1.mga5.i586.rpm Static GD library
libgd3-2.1.1-1.mga5.i586.rpm A library used to create PNG, JPEG, or WBMP images
libgda-gir5.0-5.2.2-6.mga5.i586.rpm GObject Introspection interface description for Gda
libgda-xslt3.0_0-3.1.5-18.mga5.i586.rpm GNU Data Access Development
libgda3.0-devel-3.1.5-18.mga5.i586.rpm GNU Data Access Development
libgda3.0_2-3.1.5-18.mga5.i586.rpm GNU Data Access Development
libgda5.0-5.2.2-6.mga5.i586.rpm GNU Data Access
libgda5.0-bdb-5.2.2-6.mga5.i586.rpm GDA Berkeley Database Provider
libgda5.0-devel-5.2.2-6.mga5.i586.rpm GNU Data Access Development
libgda5.0-mysql-5.2.2-6.mga5.i586.rpm GDA MySQL Provider
libgda5.0-postgres-5.2.2-6.mga5.i586.rpm GDA PostgreSQL Provider
libgda5.0-sqlite-5.2.2-6.mga5.i586.rpm GDA sqlite Provider
Advertisement
Advertisement