libqscintilla2_11-2.8.1-1.mga5.i586.rpm


Advertisement

Description

libqscintilla2_11 - Port to Qt of Neil Hodgson's Scintilla C++ editor class

Property Value
Distribution Mageia 5.1
Repository Mageia Core i586
Package name libqscintilla2_11
Package version 2.8.1
Package release 1.mga5
Package architecture i586
Package type rpm
Installed size 21.46 MB
Download size 4.32 MB
Official Mirror distrib-coffee.ipsl.jussieu.fr
As well as features found in standard text editing components,
QScintilla includes features especially useful when editing and
debugging source code. These include support for syntax styling, error
indicators, code completion and call tips. The selection margin can
contain markers like those used in debuggers to indicate breakpoints
and the current line. Styling choices are more open than with many
editors, allowing the use of proportional fonts, bold and italics,
multiple foreground and background colours and multiple fonts.

Alternatives

Package Version Architecture Repository
libqscintilla2_11 - - -

Requires

Name Value
libQtCore.so.4 -
libQtGui.so.4 -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libstdc++.so.6 -
libstdc++.so.6(GLIBCXX_3.4) -
qscintilla-i18n -

Provides

Name Value
libqscintilla2.so.11 -
libqscintilla2_11 == 2.8.1-1.mga5
libqscintilla2_11(x86-32) == 2.8.1-1.mga5

Download

Type URL
Binary Package libqscintilla2_11-2.8.1-1.mga5.i586.rpm
Source Package qscintilla-2.8.1-1.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libqscintilla2_11 rpm package:
    # urpmi libqscintilla2_11

Files

Path
/usr/lib/libqscintilla2.so.11
/usr/lib/libqscintilla2.so.11.0
/usr/lib/libqscintilla2.so.11.0.1

Changelog

2014-03-17 - fwang <fwang> 2.8.1-1.mga5
+ Revision: 604319
- update file list
- fix linkage
- 2.8.1
2014-02-04 - fwang <fwang> 2.8-1.mga5
+ Revision: 581702
- update lib major
- new version 2.8
2013-10-19 - umeabot <umeabot> 2.7.2-4.mga4
+ Revision: 528936
- Mageia 4 Mass Rebuild
+ fwang <fwang>
- qscintilla does not support build python2 and python3 flavour at the same time
- build py3 sip
- build python3 flavour
2013-06-29 - fwang <fwang> 2.7.2-2.mga4
+ Revision: 448375
- move translations out of lib package
2013-06-18 - fwang <fwang> 2.7.2-1.mga4
+ Revision: 444336
- update file list
- update file list
- update install prefix
- update dir
- fix ver
- new version 2.7.2
2013-01-13 - umeabot <umeabot> 2.7-5.mga3
+ Revision: 379912
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
2012-12-16 - fwang <fwang> 2.7-4.mga3
+ Revision: 331414
- fix obsoletes and conflicts tag
2012-12-11 - matteo <matteo> 2.7-3.mga3
+ Revision: 329742
- obsoleting lib qscintilla2_8
2012-12-11 - matteo <matteo> 2.7-2.mga3
+ Revision: 329693
- added missing conflict definition
2012-12-11 - matteo <matteo> 2.7-1.mga3
+ Revision: 329646
- new version

See Also

Package Description
libqt-gstreamer-devel-1.2.0-2.mga5.i586.rpm Development files for QtGstreamer
libqt-mobility-devel-1.2.0-13.mga5.i586.rpm Qt Mobility Framework development files
libqt3-3.3.8b-40.mga5.i586.rpm Qt3 - Shared libraries
libqt3-mysql-3.3.8b-40.mga5.i586.rpm MySQL plugin for Qt
libqt3-odbc-3.3.8b-40.mga5.i586.rpm ODBC plugin for Qt
libqt3-psql-3.3.8b-40.mga5.i586.rpm PostgresSQL plugin for Qt
libqt3-sqlite-3.3.8b-40.mga5.i586.rpm Sqlite 2 plugin for Qt
libqt3support4-4.8.6-9.mga5.i586.rpm Qt4 Component Library
libqt4-devel-4.8.6-9.mga5.i586.rpm Development files for the Qt4 GUI toolkit
libqt5-gstreamer-devel-1.2.0-2.mga5.i586.rpm Development files for Qt5Gstreamer
libqt5base5-devel-5.4.0-7.mga5.i586.rpm Development files for the Qt5 GUI toolkit
libqt5bluetooth-devel-5.4.0-1.mga5.i586.rpm Devel files needed to build apps based on QtBluetooth
libqt5bluetooth-private-devel-5.4.0-1.mga5.i586.rpm Devel files needed to build apps based on QtBluetooth
libqt5bluetooth5-5.4.0-1.mga5.i586.rpm Qt5 Component Library
libqt5bootstrap-devel-5.4.0-7.mga5.i586.rpm Devel files needed to build apps based on QtBootstrap
Advertisement
Advertisement