libtorrent18-0.13.4-3.mga5.i586.rpm


Advertisement

Description

libtorrent18 - BitTorrent library written in C++ for *nix

Property Value
Distribution Mageia 5.1
Repository Mageia Core i586
Package name libtorrent18
Package version 0.13.4
Package release 3.mga5
Package architecture i586
Package type rpm
Installed size 1.14 MB
Download size 414.16 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
LibTorrent is a BitTorrent library written in C++ for *nix. It is designed to
avoid redundant copying and storing of data that other clients and libraries
suffer from. Licensed under the GPL.
Basic features have been implemented and a ncurses client is included. Sloppy
and biased test runs have shown that transferring a 200 MB file with libTorrent
uses 1/4 of the CPU time that the official BitTorrent client requires.
The library and client are under heavy development. They are stable enough to
handle any torrents I throw at them these days.

Alternatives

Package Version Architecture Repository
libtorrent18 - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.11) -
libc.so.6(GLIBC_2.15) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3.2) -
libc.so.6(GLIBC_2.3.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libcrypto.so.1.0.0 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_3.4) -
libgcc_s.so.1(GLIBC_2.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.12) -
libpthread.so.0(GLIBC_2.2) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.10) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libz.so.1 -
libz.so.1(ZLIB_1.2.3.3) -

Provides

Name Value
libtorrent == 0.13.4-3.mga5
libtorrent.so.18 -
libtorrent18 == 0.13.4-3.mga5
libtorrent18(x86-32) == 0.13.4-3.mga5

Download

Type URL
Binary Package libtorrent18-0.13.4-3.mga5.i586.rpm
Source Package libtorrent-0.13.4-3.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libtorrent18 rpm package:
    # urpmi libtorrent18

Files

Path
/usr/lib/libtorrent.so.18
/usr/lib/libtorrent.so.18.0.0

Changelog

2014-10-15 - umeabot <umeabot> 0.13.4-3.mga5
+ Revision: 747022
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 0.13.4-2.mga5
+ Revision: 681818
- Mageia 5 Mass Rebuild
+ wally <wally>
- fix URL
2014-06-21 - wally <wally> 0.13.4-1.mga5
+ Revision: 638267
- new version 0.13.4
- new libmajor 18
- rediff linking patch
2013-10-19 - umeabot <umeabot> 0.13.3-2.mga4
+ Revision: 523899
- Mageia 4 Mass Rebuild
2013-05-26 - wally <wally> 0.13.3-1.mga4
+ Revision: 427875
- new version 0.13.3
- rediff linking patch
- update major
2013-01-12 - umeabot <umeabot> 0.13.2-2.mga3
+ Revision: 358268
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
2012-06-04 - wally <wally> 0.13.2-1.mga3
+ Revision: 254382
- new version 0.13.2
- add P0 to fix linking
- clean .spec a bit
2012-03-07 - stormi <stormi> 0.12.9-3.mga2
+ Revision: 221371
- rebuild to fix changelog
2012-03-07 - remmy <remmy> 0.12.9-2.mga2
+ Revision: 221289
- Revert to last stable upstream release
2012-02-23 - kharec <kharec> 0.13.0-1.mga2
+ Revision: 213496
- new version 0.13.0

See Also

Package Description
libtotem-devel-3.14.2-1.mga5.i586.rpm Devel files for totem
libtotem-gir1.0-3.14.2-1.mga5.i586.rpm GObject Introspection interface description for totem
libtotem-plparser-devel-3.10.4-1.mga5.i586.rpm Static libraries, include files for totem playlist parser
libtotem-plparser-gir1.0-3.10.4-1.mga5.i586.rpm GObject Introspection interface description for totem-pl-parser
libtotem-plparser-mini18-3.10.4-1.mga5.i586.rpm Playlist parser library from the Totem Movie Player
libtotem-plparser18-3.10.4-1.mga5.i586.rpm Playlist parser library from the Totem Movie Player
libtotem0-3.14.2-1.mga5.i586.rpm Shared libraries for totem
libtracker-devel-1.2.5-1.mga5.i586.rpm Development library of Tracker
libtracker-gir1.0-1.2.5-1.mga5.i586.rpm GObject Introspection interface description for tracker
libtracker1.0_0-1.2.5-1.mga5.i586.rpm Shared library of Tracker
libtransitioner2-1.1.8-9.mga5.i586.rpm Library used by the Pacemaker cluster resource manager and its clients
libtre-devel-0.8.0-12.mga5.i586.rpm Header files and libraries for developing apps with tre
libtre5-0.8.0-12.mga5.i586.rpm Lightweight, robust, and efficient POSIX compliant regexp matching library
libtrousers-devel-0.3.13-3.mga5.i586.rpm TrouSerS header files and documentation
libts-devel-1.0-11.mga5.i586.rpm Development library and headers for tslib
Advertisement
Advertisement