ocaml-duppy-0.5.1-4.mga5.i586.rpm


Advertisement

Description

ocaml-duppy - An advanced scheduler for OCaml programmers

Property Value
Distribution Mageia 5.1
Repository Mageia Core i586
Package name ocaml-duppy
Package version 0.5.1
Package release 4.mga5
Package architecture i586
Package type rpm
Installed size 171.08 KB
Download size 57.93 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Duppy is an event scheduler written for OCaml. It allows the user to
execute tasks according to some events on Unix sockets, or a given delay.
Several threaded queues can proceed tasks in parallel. Tasks are processed
according to an abstract notion of priority.

Alternatives

Package Version Architecture Repository
ocaml-duppy-0.5.1-4.mga5.x86_64.rpm 0.5.1 x86_64 Mageia Core
ocaml-duppy - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
ocaml(Arg) == a7ebc43608a0326f6aa67069897d89e7
ocaml(Array) == 8a6bb22925744456eb66180ea42e3344
ocaml(Bigarray) == 968037506db5f9b56ea16d0880b2363f
ocaml(Buffer) == af3ef6fba94cdb4eba31e98b4e341dab
ocaml(Camlp4) == ebd368022fd2bc7b305a42902efa4c90
ocaml(Camlp4_config) == afdd8ec39f52024dae64ef65575881a5
ocaml(Camlp4_import) == 33010d5f2fea03b5bebf94f1b9693ec4
ocaml(Char) == 9554e5449c177414a27e7d7ff5ed8013
ocaml(Complex) == 1858860030310b043b5d7fcb362095a3
ocaml(Condition) == 7e8a9025f5f5369f8af64bb2d24f1bc5
ocaml(Filename) == 28728bb478e079cce0b0c694de7944d6
ocaml(Format) == e0d18776d4bacff3a198b5c23d0e9355
ocaml(Gc) == 292a1cd61d8e068943589882415bdf7d
ocaml(Hashtbl) == 024edc3512403b725052aec8e41ed971
ocaml(Int32) == ad06f04cfca6d404d1de76c3dc67324a
ocaml(Int64) == 3945db6e8df0d5a79bcbc949ee550d52
ocaml(Lexing) == 50598ab7c92b4bdcc624e472342ac8a9
ocaml(List) == d757117653d9319fefb7ddc78a998f41
ocaml(Mutex) == bf9c20efca54afdc260604f8bb20c0e9
ocaml(Nativeint) == 11ff26db80a400d29d2755edd23b5d0f
ocaml(Obj) == b0adfa4175f86e4394859886c1a374bb
ocaml(Parsing) == ce3ca1121d80c4219ee78b6df5ddba03
ocaml(Pcre) == 4f3c8aa08bcea842b2a32cfc7686300d
ocaml(Pervasives) == 36b5bc8227dc9914c6d9fd9bdcfadb45
ocaml(Printexc) == d81cbca604b811d25138fa79499fe071
ocaml(Printf) == d012329cc712e91d0f10a5eef2303d18
ocaml(Queue) == 2dece812a038a26a3231548f436037b6
ocaml(Set) == be044b48f40a48f0eb210225f11e0118
ocaml(Stream) == 932d0bd7bd881dd54cdaabdd1ca8062b
ocaml(String) == db7f34081ef8fcaf499f19523d0736c6
ocaml(Sys) == 5acfec22153eb1403597926ecd15f4f5
ocaml(Unix) == 93736a394d3d85d6d127fe238ddc6092
ocaml(runtime) == 4.01.0
ocaml-pcre -

Provides

Name Value
ocaml(Duppy) == 4b784fa3f98454dbdfc83ebb0aa2f365
ocaml(Pa_duppy) == d4775ad23bd6e2e50e24de6d21ad8dc2
ocaml-duppy == 0.5.1-4.mga5
ocaml-duppy(x86-32) == 0.5.1-4.mga5

Download

Type URL
Binary Package ocaml-duppy-0.5.1-4.mga5.i586.rpm
Source Package ocaml-duppy-0.5.1-4.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install ocaml-duppy rpm package:
    # urpmi ocaml-duppy

Files

Path
/usr/lib/ocaml/duppy/META
/usr/lib/ocaml/duppy/duppy.a
/usr/lib/ocaml/duppy/duppy.cma
/usr/lib/ocaml/duppy/duppy.cmi
/usr/lib/ocaml/duppy/duppy.cmx
/usr/lib/ocaml/duppy/duppy.cmxa
/usr/lib/ocaml/duppy/duppy.mli
/usr/lib/ocaml/duppy/libduppy_stubs.a
/usr/lib/ocaml/duppy/pa_duppy.cmi
/usr/lib/ocaml/duppy/pa_duppy.cmo
/usr/lib/ocaml/duppy/pa_duppy.mli
/usr/lib/ocaml/stublibs/dllduppy_stubs.so
/usr/lib/ocaml/stublibs/dllduppy_stubs.so.owner
/usr/share/doc/ocaml-duppy/CHANGES
/usr/share/doc/ocaml-duppy/COPYING
/usr/share/doc/ocaml-duppy/README

Changelog

2014-10-15 - umeabot <umeabot> 0.5.1-4.mga5
+ Revision: 741320
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 0.5.1-3.mga5
+ Revision: 683021
- Mageia 5 Mass Rebuild
2013-10-19 - umeabot <umeabot> 0.5.1-2.mga4
+ Revision: 528189
- Mageia 4 Mass Rebuild
2013-06-16 - malo <malo> 0.5.1-1.mga4
+ Revision: 443702
- update to 0.5.1
2013-01-12 - umeabot <umeabot> 0.4.2-5.mga3
+ Revision: 361289
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
2012-10-01 - blue_prawn <blue_prawn> 0.4.2-4.mga3
+ Revision: 301655
- new rpm group for ocaml
- new rpm group for ocaml
2012-04-09 - malo <malo> 0.4.2-2.mga2
+ Revision: 229864
- add missing requires to ocaml-pcre
2011-12-03 - malo <malo> 0.4.2-1.mga2
+ Revision: 175730
- simplifying build section
- imported package ocaml-duppy

See Also

Package Description
ocaml-duppy-devel-0.5.1-4.mga5.i586.rpm Development files for ocaml-duppy
ocaml-easy-format-1.0.2-3.mga5.i586.rpm High-level and functional interface to the Format module
ocaml-easy-format-devel-1.0.2-3.mga5.i586.rpm Development files for ocaml-easy-format
ocaml-event-0.6.0-9.mga5.i586.rpm An OCaml wrapper for the libevent API
ocaml-event-devel-0.6.0-9.mga5.i586.rpm Development files for ocaml-event
ocaml-expat-0.9.1-18.mga5.i586.rpm OCaml wrapper for the Expat XML parsing library
ocaml-expat-devel-0.9.1-18.mga5.i586.rpm Development files for ocaml-expat
ocaml-expect-0.0.3-7.mga5.i586.rpm Expect-like framework
ocaml-expect-devel-0.0.3-7.mga5.i586.rpm Development files for ocaml-expect
ocaml-extlib-1.6.1-3.mga5.i586.rpm Extended Standard Library for OCaml
ocaml-extlib-devel-1.6.1-3.mga5.i586.rpm Development files for ocaml-extlib
ocaml-extunix-0.1.1-3.mga5.i586.rpm Extended functions for OCaml Unix module
ocaml-extunix-devel-0.1.1-3.mga5.i586.rpm Development files for ocaml-extunix
ocaml-facile-1.1-8.mga5.i586.rpm OCaml library for constraint programming
ocaml-facile-devel-1.1-8.mga5.i586.rpm Development files for ocaml-facile
Advertisement
Advertisement