perl-Dist-Zilla-Plugin-MetaResourcesFromGit-1.103.620-5.mga5.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-MetaResourcesFromGit - Metadata resource URLs from Git configuration

Property Value
Distribution Mageia 5.1
Repository Mageia Core i586
Package name perl-Dist-Zilla-Plugin-MetaResourcesFromGit
Package version 1.103.620
Package release 5.mga5
Package architecture noarch
Package type rpm
Installed size 34.77 KB
Download size 22.58 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
This plugin is a drop-in replacement for the
Dist::Zilla::Plugin::MetaResources manpage for users of Git. It
_automatically_ provides three resource links to your distribution
metadata, based on the name of the distribution and the remote URL of the
Git repository you are working from.
The default links are equivalent to:
homepage        = https://github.com/%a/%r/wiki
bugtracker.web  = https://rt.cpan.org/Public/Dist/Display.html?Name=%N
repository.url  = git://github.com/%a/%r.git
repository.web  = https://github.com/%a/%r
repository.type = git

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-MetaResourcesFromGit-1.103.620-5.mga5.noarch.rpm 1.103.620 noarch Mageia Core
perl-Dist-Zilla-Plugin-MetaResourcesFromGit - - -

Requires

Name Value
perl(Config::INI::Reader) -
perl(Dist::Zilla::Plugin::MetaResources) -
perl(Moose) -
perl(Path::Class) -
perl(String::Formatter) -
perl-base >= 2:5.20.1

Provides

Name Value
perl(Dist::Zilla::Plugin::MetaResourcesFromGit) == 1.103.620
perl-Dist-Zilla-Plugin-MetaResourcesFromGit == 1.103.620-5.mga5

Download

Type URL
Binary Package perl-Dist-Zilla-Plugin-MetaResourcesFromGit-1.103.620-5.mga5.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-MetaResourcesFromGit-1.103.620-5.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Dist-Zilla-Plugin-MetaResourcesFromGit rpm package:
    # urpmi perl-Dist-Zilla-Plugin-MetaResourcesFromGit

Files

Path
/usr/lib/perl5/vendor_perl/5.20.1/Dist/
/usr/lib/perl5/vendor_perl/5.20.1/Dist/Zilla/
/usr/lib/perl5/vendor_perl/5.20.1/Dist/Zilla/Plugin/MetaResourcesFromGit.pm
/usr/share/doc/perl-Dist-Zilla-Plugin-MetaResourcesFromGit/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-MetaResourcesFromGit/LICENSE
/usr/share/doc/perl-Dist-Zilla-Plugin-MetaResourcesFromGit/META.json
/usr/share/doc/perl-Dist-Zilla-Plugin-MetaResourcesFromGit/META.yml
/usr/share/doc/perl-Dist-Zilla-Plugin-MetaResourcesFromGit/README
/usr/share/man/man3/Dist::Zilla::Plugin::MetaResourcesFromGit.3pm.xz

Changelog

2014-10-15 - umeabot <umeabot> 1.103.620-5.mga5
+ Revision: 742682
- Second Mageia 5 Mass Rebuild
- Mageia 5 Mass Rebuild
2013-10-18 - umeabot <umeabot> 1.103.620-3.mga4
+ Revision: 511008
- Mageia 4 Mass Rebuild
2013-01-13 - umeabot <umeabot> 1.103.620-2.mga3
+ Revision: 366284
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild

See Also

Package Description
perl-Dist-Zilla-Plugin-MinimumPerl-1.3.0-6.mga5.noarch.rpm Detects the minimum version of Perl required for your dist
perl-Dist-Zilla-Plugin-ModuleBuild-XSOrPP-0.40.0-5.mga5.noarch.rpm Add a --pp option to your Build.PL to force an XS-less build
perl-Dist-Zilla-Plugin-ModuleInstall-1.1.0-3.mga5.noarch.rpm Build Module::Install based Distributions with Dist::Zilla
perl-Dist-Zilla-Plugin-MojibakeTests-0.700.0-4.mga5.noarch.rpm Release tests for source encoding
perl-Dist-Zilla-Plugin-NextVersion-Semantic-0.2.0-3.mga5.noarch.rpm Extract previous version from changelog
perl-Dist-Zilla-Plugin-NoAutomatedTesting-0.80.0-3.mga5.noarch.rpm Avoid running under CPAN Testers
perl-Dist-Zilla-Plugin-NoSmartCommentsTests-0.6.0-5.mga5.noarch.rpm Make sure no Smart::Comments escape into the wild
perl-Dist-Zilla-Plugin-OSPrereqs-0.5.0-3.mga5.noarch.rpm List prereqs conditional on operating system
perl-Dist-Zilla-Plugin-OurPkgVersion-0.5.1-3.mga5.noarch.rpm No line insertion and does Package version with our
perl-Dist-Zilla-Plugin-PerlTidy-0.160.0-3.mga5.noarch.rpm Perltidy your dist
perl-Dist-Zilla-Plugin-PodLinkTests-1.6.0-5.mga5.noarch.rpm Dynamically add release tests for POD links
perl-Dist-Zilla-Plugin-PodLoom-5.0.0-3.mga5.noarch.rpm Process module documentation through Pod::Loom
perl-Dist-Zilla-Plugin-PodPurler-0.93.401-4.mga5.noarch.rpm Like PodWeaver, but more erratic and amateurish
perl-Dist-Zilla-Plugin-PodWeaver-4.6.0-3.mga5.noarch.rpm Do horrible things to POD, producing better docs
perl-Dist-Zilla-Plugin-Prepender-1.112.280-5.mga5.noarch.rpm prepend lines at the top of your perl files
Advertisement
Advertisement