perl-ExtUtils-Install-1.680.0-4.mga5.noarch.rpm


Advertisement

Description

perl-ExtUtils-Install - yet another framework for writing test scripts

Property Value
Distribution Mageia 5.1
Repository Mageia Core i586
Package filename perl-ExtUtils-Install-1.680.0-4.mga5.noarch.rpm
Package name perl-ExtUtils-Install
Package version 1.680.0
Package release 4.mga5
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/ExtUtils-Install
License GPL+ or Artistic
Maintainer -
Download size 43.41 KB
Installed size 89.27 KB
*STOP!* If you're just getting started writing tests, have a look at
Test::Simple first. This is a drop in replacement for Test::Simple which
you can switch to once you get the hang of basic testing.
The purpose of this module is to provide a wide range of testing utilities.
Various ways to say "ok" with better diagnostics, facilities to skip tests,
test future features and compare complicated data structures. While you can
do almost anything with a simple 'ok()' function, it doesn't provide good
diagnostic output.
I love it when a plan comes together
Before anything else, you need a testing plan. This basically declares
how many tests your script is going to run to protect against premature
failure.

Alternatives

Package Version Architecture Repository
perl-ExtUtils-Install-1.680.0-4.mga5.noarch.rpm 1.680.0 noarch Mageia Core
perl-ExtUtils-Install - - -

Requires

Name Value
perl >= 0:5.00503
perl(AutoSplit) -
perl(Carp) -
perl(Config) -
perl(Cwd) -
perl(Exporter) -
perl(ExtUtils::MakeMaker) -
perl(ExtUtils::Packlist) -
perl(File::Basename) -
perl(File::Compare) -
perl(File::Copy) -
perl(File::Find) -
perl(File::Path) -
perl(File::Spec) -
perl(strict) -
perl(vars) -
perl-base >= 2:5.20.1

Provides

Name Value
perl(ExtUtils::Install) == 1.680.0
perl(ExtUtils::Install::Warn) -
perl(ExtUtils::Installed) == 1.999.5
perl(ExtUtils::Packlist) == 1.480.0
perl-ExtUtils-Install == 1.680.0-4.mga5

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package perl-ExtUtils-Install-1.680.0-4.mga5.noarch.rpm
Source Package perl-ExtUtils-Install-1.680.0-4.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-ExtUtils-Install rpm package:
    # urpmi perl-ExtUtils-Install

Files

Path
/usr/lib/perl5/vendor_perl/5.20.1/ExtUtils/Install.pm
/usr/lib/perl5/vendor_perl/5.20.1/ExtUtils/Installed.pm
/usr/lib/perl5/vendor_perl/5.20.1/ExtUtils/Packlist.pm
/usr/share/doc/perl-ExtUtils-Install/Changes
/usr/share/doc/perl-ExtUtils-Install/META.json
/usr/share/doc/perl-ExtUtils-Install/META.yml
/usr/share/doc/perl-ExtUtils-Install/MYMETA.yml
/usr/share/doc/perl-ExtUtils-Install/README
/usr/share/man/man3/ExtUtils::Install.3pm.xz
/usr/share/man/man3/ExtUtils::Installed.3pm.xz
/usr/share/man/man3/ExtUtils::Packlist.3pm.xz

Changelog

2014-10-15 - umeabot <umeabot> 1.680.0-4.mga5
+ Revision: 741869
- Second Mageia 5 Mass Rebuild
2014-09-27 - tv <tv> 1.680.0-3.mga5
+ Revision: 725849
- add excludes
2014-09-16 - umeabot <umeabot> 1.680.0-2.mga5
+ Revision: 684681
- Mageia 5 Mass Rebuild
2014-06-06 - sander85 <sander85> 1.680.0-1.mga5
+ Revision: 634233
- update to 1.68
2014-04-25 - jquelin <jquelin> 1.670.0-1.mga5
+ Revision: 617764
- update to 1.67
2014-04-17 - jquelin <jquelin> 1.660.0-1.mga5
+ Revision: 615369
- update to 1.66
2014-04-15 - jquelin <jquelin> 1.650.0-1.mga5
+ Revision: 614572
- update to 1.65
2014-04-01 - jquelin <jquelin> 1.640.0-1.mga5
+ Revision: 611091
- update to 1.64
2014-03-13 - jquelin <jquelin> 1.630.0-1.mga5
+ Revision: 602787
- update to 1.63
2013-10-18 - umeabot <umeabot> 1.540.0-3.mga4
+ Revision: 511430
- Mageia 4 Mass Rebuild

See Also

Package Description
perl-ExtUtils-InstallPaths-0.10.0-3.mga5.noarch.rpm Build.PL install path logic made easy
perl-ExtUtils-LibBuilder-0.60.0-3.mga5.noarch.rpm A tool to build C libraries
perl-ExtUtils-MakeMaker-6.980.0-5.mga5.noarch.rpm Writes Makefiles for extensions
perl-ExtUtils-MakeMaker-CPANfile-0.60.0-3.mga5.noarch.rpm cpanfile support for EUMM
perl-ExtUtils-MakeMaker-Coverage-0.50.0-5.mga5.noarch.rpm Add a Makefile target to determine test coverage using Devel::Cover
perl-ExtUtils-Manifest-1.660.0-3.mga5.noarch.rpm Utilities for managing MANIFEST files
perl-ExtUtils-ParseXS-3.240.0-3.mga5.noarch.rpm Converts Perl XS code into C code
perl-ExtUtils-PerlPP-0.30.0-5.mga5.noarch.rpm ExtUtils-PerlPP module for perl
perl-ExtUtils-PkgConfig-1.150.0-4.mga5.noarch.rpm Perl module for further extending extensions
perl-ExtUtils-Typemap-1.0.0-2.mga5.noarch.rpm A compatibility wrapper for ExtUtils::Typemaps
perl-ExtUtils-Typemaps-Default-1.50.0-3.mga5.noarch.rpm A set of typemaps for STL std::vectors
perl-ExtUtils-XSBuilder-0.280.0-5.mga5.noarch.rpm ExtUtils::XSBuilder - Automatic XS glue code generation
perl-ExtUtils-XSpp-0.180.0-7.mga5.i586.rpm A tiny C++ class example that holds a string and an int
perl-ExtUtils-configPL-1.100.0-5.mga5.noarch.rpm Perl extension to automagiclly configure perl scripts
perl-FBP-0.410.0-5.mga5.noarch.rpm Role for objects which can contain other objects
Advertisement
Advertisement