perl-Module-Depends-0.160.0-4.mga5.noarch.rpm


Advertisement

Description

perl-Module-Depends - Intrusive discovery of distribution dependencies

Property Value
Distribution Mageia 5.1
Repository Mageia Core i586
Package name perl-Module-Depends
Package version 0.160.0
Package release 4.mga5
Package architecture noarch
Package type rpm
Installed size 16.01 KB
Download size 16.57 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Module::Depends extracts module dependencies from an unpacked distribution
tree.
Module::Depends only evaluates the META.yml shipped with a distribution.
This won't be effective until all distributions ship META.yml files, so we
suggest you take your life in your hands and look at
Module::Depends::Intrusive.

Alternatives

Package Version Architecture Repository
perl-Module-Depends-0.160.0-4.mga5.noarch.rpm 0.160.0 noarch Mageia Core
perl-Module-Depends - - -

Requires

Name Value
perl(Class::Accessor::Chained) -
perl(Cwd) -
perl(ExtUtils::MakeMaker) -
perl(File::Spec) -
perl(Module::Depends) -
perl(Parse::CPAN::Meta) -
perl(base) -
perl(strict) -
perl-base >= 2:5.20.1

Provides

Name Value
perl(Module::Depends) == 0.160.0
perl(Module::Depends::Intrusive) -
perl(Module::Depends::Intrusive::Fake::Module::Build) -
perl-Module-Depends == 0.160.0-4.mga5

Download

Type URL
Binary Package perl-Module-Depends-0.160.0-4.mga5.noarch.rpm
Source Package perl-Module-Depends-0.160.0-4.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Module-Depends rpm package:
    # urpmi perl-Module-Depends

Files

Path
/usr/lib/perl5/vendor_perl/5.20.1/Module/Depends.pm
/usr/lib/perl5/vendor_perl/5.20.1/Module/Depends/Intrusive.pm
/usr/share/doc/perl-Module-Depends/Changes
/usr/share/doc/perl-Module-Depends/META.yml
/usr/share/doc/perl-Module-Depends/README
/usr/share/man/man3/Module::Depends.3pm.xz
/usr/share/man/man3/Module::Depends::Intrusive.3pm.xz

Changelog

2014-10-15 - umeabot <umeabot> 0.160.0-4.mga5
+ Revision: 747175
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 0.160.0-3.mga5
+ Revision: 685422
- Mageia 5 Mass Rebuild
2013-10-21 - umeabot <umeabot> 0.160.0-2.mga4
+ Revision: 537315
- Mageia 4 Mass Rebuild
2013-09-26 - sander85 <sander85> 0.160.0-1.mga4
+ Revision: 486796
- update to 0.16
2013-01-13 - umeabot <umeabot> 0.150.0-2.mga3
+ Revision: 369790
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild

See Also

Package Description
perl-Module-Extract-0.10.0-7.mga5.noarch.rpm Base class for working with Perl distributions
perl-Module-Extract-Namespaces-1.20.0-4.mga5.noarch.rpm Extract the package declarations from a module
perl-Module-Extract-Use-1.40.0-4.mga5.noarch.rpm Pull out the modules a module uses
perl-Module-Extract-VERSION-1.10.0-7.mga5.noarch.rpm Extract a module version without running code
perl-Module-ExtractUse-0.330.0-4.mga5.noarch.rpm Find out what modules are used
perl-Module-Find-0.120.0-3.mga5.noarch.rpm Find and use installed modules in a (sub)category
perl-Module-Format-0.0.6-3.mga5.noarch.rpm Convert and manipulate stringified versions of Perl modules
perl-Module-Implementation-0.90.0-3.mga5.noarch.rpm Loads one of several alternate underlying implementations for a module
perl-Module-Info-0.350.0-6.mga5.noarch.rpm Information about Perl modules
perl-Module-Inspector-1.50.0-6.mga5.noarch.rpm An integrated API for inspecting Perl distributions
perl-Module-Install-1.120.0-4.mga5.noarch.rpm Standalone, extensible Perl module installer
perl-Module-Install-AckXXX-0.270.0-4.mga5.noarch.rpm Warn Author About XXX.pm
perl-Module-Install-AuthorRequires-0.20.0-5.mga5.noarch.rpm Declare author-only dependencies
perl-Module-Install-AuthorTests-0.2.0-6.mga5.noarch.rpm Designate tests only run by module authors
perl-Module-Install-AutoLicense-0.80.0-5.mga5.noarch.rpm A Module::Install extension to automagically generate LICENSE files
Advertisement
Advertisement