perl-Perl-Critic-Compatibility-1.1.0-5.mga5.noarch.rpm


Advertisement

Description

perl-Perl-Critic-Compatibility - Don't allow three-argument open unless the code uses a version of perl that supports it

Property Value
Distribution Mageia 5.1
Repository Mageia Core i586
Package name perl-Perl-Critic-Compatibility
Package version 1.1.0
Package release 5.mga5
Package architecture noarch
Package type rpm
Installed size 17.18 KB
Download size 18.41 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
The included policies are:
* the Perl::Critic::Policy::Compatibility::ProhibitColonsInBarewordHashKeys
manpage
Perls after 5.8 don't support having colons in unquoted hash keys.
[Severity: 5]

Alternatives

Package Version Architecture Repository
perl-Perl-Critic-Compatibility-1.1.0-5.mga5.noarch.rpm 1.1.0 noarch Mageia Core
perl-Perl-Critic-Compatibility - - -

Requires

Name Value
perl >= 0:5.006
perl(Perl::Critic) >= 1.83_1
perl(Perl::Critic::Policy) -
perl(Perl::Critic::Utils) -
perl(Readonly) -
perl(base) -
perl(strict) -
perl(version) -
perl(warnings) -
perl-base >= 2:5.20.1

Provides

Name Value
perl(Perl::Critic::Compatibility) == 1.1.0
perl(Perl::Critic::Policy::Compatibility::ProhibitThreeArgumentOpen) == 1.1.0
perl-Perl-Critic-Compatibility == 1.1.0-5.mga5

Download

Type URL
Binary Package perl-Perl-Critic-Compatibility-1.1.0-5.mga5.noarch.rpm
Source Package perl-Perl-Critic-Compatibility-1.1.0-5.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Perl-Critic-Compatibility rpm package:
    # urpmi perl-Perl-Critic-Compatibility

Files

Path
/usr/lib/perl5/vendor_perl/5.20.1/Perl/
/usr/lib/perl5/vendor_perl/5.20.1/Perl/Critic/Compatibility.pm
/usr/lib/perl5/vendor_perl/5.20.1/Perl/Critic/Policy/
/usr/lib/perl5/vendor_perl/5.20.1/Perl/Critic/Policy/Compatibility/ProhibitThreeArgumentOpen.pm
/usr/share/doc/perl-Perl-Critic-Compatibility/Changes
/usr/share/doc/perl-Perl-Critic-Compatibility/META.yml
/usr/share/doc/perl-Perl-Critic-Compatibility/README
/usr/share/man/man3/Perl::Critic::Compatibility.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::Compatibility::ProhibitThreeArgumentOpen.3pm.xz

Changelog

2014-10-15 - umeabot <umeabot> 1.1.0-5.mga5
+ Revision: 748316
- Second Mageia 5 Mass Rebuild
- Mageia 5 Mass Rebuild
2013-10-18 - umeabot <umeabot> 1.1.0-3.mga4
+ Revision: 513981
- Mageia 4 Mass Rebuild
2013-01-13 - umeabot <umeabot> 1.1.0-2.mga3
+ Revision: 371666
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild

See Also

Package Description
perl-Perl-Critic-Deprecated-1.119.0-3.mga5.noarch.rpm Write C<$my_variable = 42> instead of C<$MyVariable = 42>
perl-Perl-Critic-Dynamic-0.50.0-6.mga5.noarch.rpm Base class for dynamic Policies
perl-Perl-Critic-Lax-0.11.0-4.mga5.noarch.rpm Policies that let you slide on common exceptions
perl-Perl-Critic-More-1.3.0-3.mga5.noarch.rpm Stop mixing long strings with code
perl-Perl-Critic-Nits-1.0.0-5.mga5.noarch.rpm Policies of nits I like to pick
perl-Perl-Critic-PetPeeves-JTRAMMELL-0.40.0-4.mga5.noarch.rpm Prohibit superfluous initializations
perl-Perl-Critic-Pulp-85.0.0-3.mga5.noarch.rpm Don't use Foo:: style barewords
perl-Perl-Critic-Storable-0.10.0-5.mga5.noarch.rpm Perl::Critic policy for using Storable
perl-Perl-Critic-StricterSubs-0.30.0-5.mga5.noarch.rpm Perl::Critic plugin for stricter subroutine checks
perl-Perl-Critic-Swift-1.0.3-5.mga5.noarch.rpm Additional policies for Perl::Critic
perl-Perl-Critic-Tics-0.9.0-3.mga5.noarch.rpm (this => is => not => good)
perl-Perl-Destruct-Level-0.20.0-9.mga5.i586.rpm Allow to change perl's destruction level
perl-Perl-Metrics-Simple-0.170.0-5.mga5.noarch.rpm Methods analyzing a single file
perl-Perl-MinimumVersion-1.380.0-4.mga5.noarch.rpm Find a minimum required version of perl for Perl code
perl-Perl-OSType-1.7.0-3.mga5.noarch.rpm Map Perl operating system names to generic types
Advertisement
Advertisement