perl-strictures-1.5.4-3.mga5.noarch.rpm


Advertisement

Description

perl-strictures - No summary found

Property Value
Distribution Mageia 5.1
Repository Mageia Core i586
Package name perl-strictures
Package version 1.5.4
Package release 3.mga5
Package architecture noarch
Package type rpm
Installed size 26.68 KB
Download size 20.85 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
I've been writing the equivalent of this module at the top of my code for
about a year now. I figured it was time to make it shorter.
Things like the importer in 'use Moose' don't help me because they turn
warnings on but don't make them fatal - which from my point of view is
useless because I want an exception to tell me my code isn't warnings
clean.
Any time I see a warning from my code, that indicates a mistake.

Alternatives

Package Version Architecture Repository
perl-strictures-1.5.4-3.mga5.noarch.rpm 1.5.4 noarch Mageia Core
perl-strictures - - -

Requires

Name Value
perl(bareword::filehandles) -
perl(indirect) -
perl(multidimensional) -
perl(strict) -
perl(warnings) -
perl-base >= 2:5.20.1

Provides

Name Value
perl(strictures) -
perl(strictures) == 1.5.4
perl-strictures == 1.5.4-3.mga5

Download

Type URL
Binary Package perl-strictures-1.5.4-3.mga5.noarch.rpm
Source Package perl-strictures-1.5.4-3.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-strictures rpm package:
    # urpmi perl-strictures

Files

Path
/usr/lib/perl5/vendor_perl/5.20.1/strictures.pm
/usr/share/doc/perl-strictures/Changes
/usr/share/doc/perl-strictures/META.json
/usr/share/doc/perl-strictures/META.yml
/usr/share/doc/perl-strictures/MYMETA.yml
/usr/share/doc/perl-strictures/README
/usr/share/man/man3/strictures.3pm.xz

Changelog

2014-10-15 - umeabot <umeabot> 1.5.4-3.mga5
+ Revision: 747745
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 1.5.4-2.mga5
+ Revision: 687060
- Mageia 5 Mass Rebuild
2014-03-14 - jquelin <jquelin> 1.5.4-1.mga5
+ Revision: 603739
- update to 1.005004
2014-02-28 - jquelin <jquelin> 1.5.3-1.mga5
+ Revision: 597908
- update to 1.005003
2013-10-18 - umeabot <umeabot> 1.4.4-3.mga4
+ Revision: 516457
- Mageia 4 Mass Rebuild
2013-01-13 - umeabot <umeabot> 1.4.4-2.mga3
+ Revision: 375558
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
2012-11-14 - jquelin <jquelin> 1.4.4-1.mga3
+ Revision: 317769
- update to 1.004004
2012-09-17 - jquelin <jquelin> 1.4.2-1.mga3
+ Revision: 295072
- update to 1.004002
2012-08-31 - kharec <kharec> 1.4.1-1.mga3
+ Revision: 286606
- update to 1.004001
2012-06-05 - jquelin <jquelin> 1.3.1-1.mga3
+ Revision: 255703
- update to 1.003001

See Also

Package Description
perl-svn-devel-1.8.13-1.mga5.i586.rpm Subversion headers/libraries for development
perl-syntax-0.4.0-6.mga5.noarch.rpm Activate syntax extensions
perl-tag_utils-1.120.0-1.mga5.noarch.rpm Conversion between various formats for Tree Adjoining Grammars
perl-taktuk-3.7.5-3.mga5.i586.rpm Taktuk Perl file
perl-threads-1.960.0-1.mga5.i586.rpm Perl interpreter-based threads
perl-threads-shared-1.460.0-5.mga5.i586.rpm Perl extension for sharing data structures between threads
perl-thrift-0.9.1-4.mga5.noarch.rpm Perl support for thrift
perl-utf8-all-0.7.0-5.mga5.noarch.rpm Turn on Unicode - all of it
perl-xfconf-4.12.0-1.mga5.i586.rpm Perl bindings for xfconf
perl-yui-1.0.4-0.git20140418.10.mga5.i586.rpm Perl bindings for libyui
perl-zapata-1.4.12.1-10.mga5.i586.rpm Zapata Telecom Library perl files
perl-zinnia-0.06-12.mga5.i586.rpm Perl bindings for zinnia
perl_checker-1.2.26-3.mga5.i586.rpm Verify Perl code
perlbrew-0.690.0-3.mga5.noarch.rpm Manage perl installations in your $HOME
perlindex-1.606.0-7.mga5.noarch.rpm English language stemming
Advertisement
Advertisement