perl-yui-1.0.4-0.git20140418.10.mga5.i586.rpm


Advertisement

Description

perl-yui - Perl bindings for libyui

Property Value
Distribution Mageia 5.1
Repository Mageia Core i586
Package name perl-yui
Package version 1.0.4
Package release 0.git20140418.10.mga5
Package architecture i586
Package type rpm
Installed size 2.08 MB
Download size 340.17 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
This package provides Perl language bindings to access functions of
libyui - the YaST User Interface engine that provides the
abstraction from graphical user interfaces (Qt, Gtk) and text based
user interfaces (ncurses).

Alternatives

Package Version Architecture Repository
perl-yui-1.0.4-0.git20140418.10.1.mga5.i586.rpm 1.0.4 i586 Mageia Core Updates
perl-yui-1.0.4-0.git20140418.10.1.mga5.x86_64.rpm 1.0.4 x86_64 Mageia Core Updates
perl-yui-1.0.4-0.git20140418.10.mga5.x86_64.rpm 1.0.4 x86_64 Mageia Core
perl-yui - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libperl.so -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libyui-mga.so.6 -
libyui.so.6 -
perl(DynaLoader) -
perl(Exporter) -
perl(base) -
perl(lib) -
perl(vars) -
perl(yui) -
perl-base >= 2:5.20.1

Provides

Name Value
perl(yui) -
perl(yui::YAlignment) -
perl(yui::YApplication) -
perl(yui::YBarGraph) -
perl(yui::YBarGraphMultiUpdate) -
perl(yui::YBarGraphSegment) -
perl(yui::YBuiltinCaller) -
perl(yui::YBusyIndicator) -
perl(yui::YCBTableItem) -
perl(yui::YCancelEvent) -
perl(yui::YCheckBox) -
perl(yui::YCheckBoxFrame) -
perl(yui::YCodeLocation) -
perl(yui::YColor) -
perl(yui::YComboBox) -
perl(yui::YCommandLine) -
perl(yui::YDateField) -
perl(yui::YDebugEvent) -
perl(yui::YDialog) -
perl(yui::YDownloadProgress) -
perl(yui::YDumbTab) -
perl(yui::YEmpty) -
perl(yui::YEvent) -
perl(yui::YExternalWidgetFactory) -
perl(yui::YExternalWidgets) -
perl(yui::YFrame) -
perl(yui::YImage) -
perl(yui::YInputField) -
perl(yui::YIntField) -
perl(yui::YItem) -
perl(yui::YItemCollection) -
perl(yui::YItemShortcut) -
perl(yui::YKeyEvent) -
perl(yui::YLabel) -
perl(yui::YLayoutBox) -
perl(yui::YLogView) -
perl(yui::YMGAAboutDialog) -
perl(yui::YMGAMessageBox) -
perl(yui::YMGAWidgetFactory) -
perl(yui::YMGA_CBTable) -
perl(yui::YMacro) -
perl(yui::YMacroPlayer) -
perl(yui::YMacroRecorder) -
perl(yui::YMenuButton) -
perl(yui::YMenuEvent) -
perl(yui::YMenuItem) -
perl(yui::YMultiLineEdit) -
perl(yui::YMultiProgressMeter) -
perl(yui::YMultiSelectionBox) -
perl(yui::YOptionalWidgetFactory) -
perl(yui::YPackageSelector) -
perl(yui::YPackageSelectorPlugin) -
perl(yui::YPartitionSplitter) -
perl(yui::YProgressBar) -
perl(yui::YProperty) -
perl(yui::YPropertySet) -
perl(yui::YPropertyValue) -
perl(yui::YPushButton) -
perl(yui::YRadioButton) -
perl(yui::YRadioButtonGroup) -
perl(yui::YReplacePoint) -
perl(yui::YRichText) -
perl(yui::YRpmGroupsTree) -
perl(yui::YSelectionBox) -
perl(yui::YSelectionWidget) -
perl(yui::YSettings) -
perl(yui::YShortcut) -
perl(yui::YShortcutManager) -
perl(yui::YSimpleEventHandler) -
perl(yui::YSimpleInputField) -
perl(yui::YSingleChildContainerWidget) -
perl(yui::YSlider) -
perl(yui::YSpacing) -
perl(yui::YSquash) -
perl(yui::YStringTree) -
perl(yui::YStringWidgetID) -
perl(yui::YTable) -
perl(yui::YTableCell) -
perl(yui::YTableHeader) -
perl(yui::YTableItem) -
perl(yui::YTimeField) -
perl(yui::YTimeoutEvent) -
perl(yui::YTimezoneSelector) -
perl(yui::YTransText) -
perl(yui::YTree) -
perl(yui::YTreeItem) -
perl(yui::YUI) -
perl(yui::YUIBadPropertyArgException) -
perl(yui::YUIButtonRoleMismatchException) -
perl(yui::YUICantLoadAnyUIException) -
perl(yui::YUIDialogStackingOrderException) -
perl(yui::YUIException) -
perl(yui::YUIIndexOutOfRangeException) -
perl(yui::YUIInvalidDimensionException) -
perl(yui::YUIInvalidWidgetException) -
perl(yui::YUILoader) -
perl(yui::YUILog) -
perl(yui::YUINoDialogException) -
perl(yui::YUINullPointerException) -
perl(yui::YUIOutOfMemoryException) -
perl(yui::YUIPlugin) -
perl(yui::YUIPluginException) -
perl(yui::YUIPropertyException) -
perl(yui::YUIPropertyTypeMismatchException) -
perl(yui::YUISetReadOnlyPropertyException) -
perl(yui::YUISyntaxErrorException) -
perl(yui::YUIUnknownPropertyException) -
perl(yui::YUIUnsupportedWidgetException) -
perl(yui::YUIWidgetNotFoundException) -
perl(yui::YWidget) -
perl(yui::YWidgetEvent) -
perl(yui::YWidgetFactory) -
perl(yui::YWidgetID) -
perl(yui::YWizard) -
perl(yuic) -
perl-yui == 1.0.4-0.git20140418.10.mga5
perl-yui(x86-32) == 1.0.4-0.git20140418.10.mga5

Download

Type URL
Binary Package perl-yui-1.0.4-0.git20140418.10.mga5.i586.rpm
Source Package libyui-bindings-1.0.4-0.git20140418.10.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-yui rpm package:
    # urpmi perl-yui

Files

Path
/usr/lib/perl5/vendor_perl/5.20.1/yui.pm
/usr/lib/perl5/vendor_perl/5.20.1/i386-linux-thread-multi/yui.so
/usr/share/doc/perl-yui/aboutDailog.pl
/usr/share/doc/perl-yui/hello_world.pl
/usr/share/doc/perl-yui/loading.pl
/usr/share/doc/perl-yui/myselection_box1.pl
/usr/share/doc/perl-yui/selection_box1.pl
/usr/share/doc/perl-yui/testDateTime.pl
/usr/share/doc/perl-yui/twitter.pl

Changelog

2014-10-15 - umeabot <umeabot> 1.0.4-0.git20140418.10.mga5
+ Revision: 742471
- Second Mageia 5 Mass Rebuild
2014-09-27 - tv <tv> 1.0.4-0.git20140418.9.mga5
+ Revision: 726958
- rebuild for missing pythoneggs deps
2014-09-16 - umeabot <umeabot> 1.0.4-0.git20140418.8.mga5
+ Revision: 681911
- Mageia 5 Mass Rebuild
2014-09-01 - anaselli <anaselli> 1.0.4-0.git20140418.7.mga5
+ Revision: 670515
- rebuilt
2014-06-14 - matteo <matteo> 1.0.4-0.git20140418.6.mga5
+ Revision: 636215
- rebuild needed because of the boot_yui symbol not found issue
2014-05-31 - pterjan <pterjan> 1.0.4-0.git20140418.5.mga5
+ Revision: 629689
- Rebuild for new Python
2014-05-31 - pterjan <pterjan> 1.0.4-0.git20140418.4.mga5
+ Revision: 628317
- Rebuild for new Python
2014-04-22 - anaselli <anaselli> 1.0.4-0.git20140418.3.mga5
+ Revision: 617452
- Back compatibility
2014-04-20 - philippem <philippem> 1.0.4-0.git20140418.2.mga5
+ Revision: 617199
- add Python3
2014-04-18 - anaselli <anaselli> 1.0.4-0.git20140418.1.mga5
+ Revision: 616902
- source packages
- sync with upstream master

See Also

Package Description
perl-zapata-1.4.12.1-10.mga5.i586.rpm Zapata Telecom Library perl files
perl-zinnia-0.06-12.mga5.i586.rpm Perl bindings for zinnia
perl_checker-1.2.26-3.mga5.i586.rpm Verify Perl code
perlbrew-0.690.0-3.mga5.noarch.rpm Manage perl installations in your $HOME
perlindex-1.606.0-7.mga5.noarch.rpm English language stemming
perltidy-20140328.0.0-3.mga5.noarch.rpm Script which indents and reformats Perl script
perroquet-1.1.2-0.20150305.1.mga5.noarch.rpm A listening comprehension tutor
pessulus-2.30.4-7.mga5.noarch.rpm Desktop lockdown editor for GNOME
pfstools-1.8.5-1.mga5.i586.rpm Programs for handling high-dynamic range images
pfstools-exr-1.8.5-1.mga5.i586.rpm EXR file import for PFS tools
pfstools-gdal-1.8.5-1.mga5.i586.rpm PFS Tools using the GDAL library to handle GIS information
pfstools-glview-1.8.5-1.mga5.i586.rpm GL-based viewer for HDR files
pfstools-imgmagick-1.8.5-1.mga5.i586.rpm ImageMagick file import for PFS tools
pfstools-octave-1.8.5-1.mga5.i586.rpm Octave interaction with PFS tools
pfstools-qt-1.8.5-1.mga5.i586.rpm Qt-based viewer for HDR files
Advertisement
Advertisement