ruby-rbx-require-relative-0.0.9-8.mga5.noarch.rpm


Advertisement

Description

ruby-rbx-require-relative - Fast Ruby debugger - core component

Property Value
Distribution Mageia 5.1
Repository Mageia Core i586
Package name ruby-rbx-require-relative
Package version 0.0.9
Package release 8.mga5
Package architecture noarch
Package type rpm
Installed size 5.42 KB
Download size 11.35 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Ruby 1.9's require_relative for Rubinius and MRI 1.8. We also add
abs_path which is like __FILE__ but __FILE__ can be fooled by a sneaky
"chdir" while abs_path can't. If you are running on Ruby 1.9 or greater,
require_relative is the pre-defined version. The benefit we provide in
this situation by this package is the ability to write the same
require_relative sequence in Rubinius 1.8 and Ruby 1.9.

Alternatives

Package Version Architecture Repository
ruby-rbx-require-relative-0.0.9-8.mga5.noarch.rpm 0.0.9 noarch Mageia Core
ruby-rbx-require-relative - - -

Requires

Name Value
ruby(rubygems) -

Provides

Name Value
ruby-rbx-require-relative == 0.0.9-8.mga5
rubygem(rbx-require-relative) == 0.0.9-1

Download

Type URL
Binary Package ruby-rbx-require-relative-0.0.9-8.mga5.noarch.rpm
Source Package ruby-rbx-require-relative-0.0.9-8.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install ruby-rbx-require-relative rpm package:
    # urpmi ruby-rbx-require-relative

Files

Path
/usr/share/ruby/gems/gems/rbx-require-relative-0.0.9/
/usr/share/ruby/gems/gems/rbx-require-relative-0.0.9/lib/require_relative.rb
/usr/share/ruby/gems/gems/rbx-require-relative-0.0.9/lib/version.rb
/usr/share/ruby/gems/gems/rbx-require-relative-0.0.9/test/bar.rb
/usr/share/ruby/gems/gems/rbx-require-relative-0.0.9/test/foo.rb
/usr/share/ruby/gems/gems/rbx-require-relative-0.0.9/test/test-rr.rb
/usr/share/ruby/gems/specifications/rbx-require-relative-0.0.9.gemspec

Changelog

2014-10-15 - umeabot <umeabot> 0.0.9-8.mga5
+ Revision: 739996
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 0.0.9-7.mga5
+ Revision: 688924
- Mageia 5 Mass Rebuild
2013-12-28 - pterjan <pterjan> 0.0.9-6.mga4
+ Revision: 562423
- Fix gem macros
2013-10-21 - umeabot <umeabot> 0.0.9-4.mga4
+ Revision: 538928
- Mageia 4 Mass Rebuild
2013-10-04 - fwang <fwang> 0.0.9-3.mga4
+ Revision: 491114
- update file list
- update file list
- use gem_setup
2013-02-08 - fwang <fwang> 0.0.9-2.mga3
+ Revision: 396892
- rebuild for new rdoc
2013-01-20 - dmorgan <dmorgan> 0.0.9-1.mga3
+ Revision: 390257
- imported package ruby-rbx-require-relative

See Also

Package Description
ruby-rbx-require-relative-doc-0.0.9-8.mga5.noarch.rpm Documentation for ruby-rbx-require-relative
ruby-rchardet-1.3.1-5.mga5.noarch.rpm Character encoding auto-detection in Ruby
ruby-rchardet-doc-1.3.1-5.mga5.noarch.rpm Documentation for ruby-rchardet
ruby-rdiscount-2.1.6-6.mga5.i586.rpm Fast Implementation of Gruber's Markdown in C
ruby-rdiscount-doc-2.1.6-6.mga5.noarch.rpm Documentation for ruby-rdiscount
ruby-rdoc-4.0.1-9.mga5.noarch.rpm RDoc produces HTML and command-line documentation for Ruby projects
ruby-rdoc-doc-4.0.1-9.mga5.noarch.rpm Documentation for ruby-rdoc
ruby-redgreen-1.2.2-8.mga5.noarch.rpm An expanded version of Pat Eyler's RedGreen
ruby-redland-1.0.16.1-2.mga5.i586.rpm Ruby modules for the Redland RDF library
ruby-rexical-1.0.5-8.mga5.noarch.rpm Rexical is a lexical scanner generator
ruby-rexical-doc-1.0.5-8.mga5.noarch.rpm Documentation for ruby-rexical
ruby-riddle-1.5.3-8.mga5.noarch.rpm An API for Sphinx, written in and for Ruby
ruby-riddle-doc-1.5.3-8.mga5.noarch.rpm Documentation for ruby-riddle
ruby-ritex-1.0.1-10.mga5.noarch.rpm WebTeX to MathML conversion library
ruby-ritex-doc-1.0.1-10.mga5.noarch.rpm Documentation for ruby-ritex
Advertisement
Advertisement