ruby-ruby_parser-3.6.1-3.mga5.noarch.rpm


Advertisement

Description

ruby-ruby_parser - A ruby parser written in pure ruby

Property Value
Distribution Mageia 5.1
Repository Mageia Core i586
Package name ruby-ruby_parser
Package version 3.6.1
Package release 3.mga5
Package architecture noarch
Package type rpm
Installed size 1.44 MB
Download size 155.41 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
ruby_parser (RP) is a ruby parser written in pure ruby (utilizing
racc--which does by default use a C extension). RP's output is the same as
ParseTree's output: s-expressions using ruby's arrays and base types.

Alternatives

Package Version Architecture Repository
ruby-ruby_parser-3.6.1-3.mga5.noarch.rpm 3.6.1 noarch Mageia Core
ruby-ruby_parser - - -

Requires

Name Value
ruby(rubygems) -
rubygem(sexp_processor) >= 4.1
rubygem(sexp_processor) < 5

Provides

Name Value
ruby-ruby_parser == 3.6.1-3.mga5
rubygem(ruby_parser) == 3.6.1-1

Download

Type URL
Binary Package ruby-ruby_parser-3.6.1-3.mga5.noarch.rpm
Source Package ruby-ruby_parser-3.6.1-3.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install ruby-ruby_parser rpm package:
    # urpmi ruby-ruby_parser

Files

Path
/usr/bin/ruby_parse
/usr/bin/ruby_parse_extract_error
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/bin/ruby_parse
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/bin/ruby_parse_extract_error
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/lib/.document
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/lib/ruby18_parser.rb
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/lib/ruby18_parser.y
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/lib/ruby19_parser.rb
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/lib/ruby19_parser.y
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/lib/ruby20_parser.rb
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/lib/ruby20_parser.y
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/lib/ruby21_parser.rb
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/lib/ruby21_parser.y
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/lib/ruby_lexer.rb
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/lib/ruby_lexer.rex
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/lib/ruby_lexer.rex.rb
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/lib/ruby_parser.rb
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/lib/ruby_parser_extras.rb
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/test/test_ruby_lexer.rb
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/test/test_ruby_parser.rb
/usr/share/ruby/gems/gems/ruby_parser-3.6.1/test/test_ruby_parser_extras.rb
/usr/share/ruby/gems/specifications/ruby_parser-3.6.1.gemspec

Changelog

2014-10-15 - umeabot <umeabot> 3.6.1-3.mga5
+ Revision: 743515
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 3.6.1-2.mga5
+ Revision: 688948
- Mageia 5 Mass Rebuild
2014-06-08 - pterjan <pterjan> 3.6.1-1.mga5
+ Revision: 634673
- 3.6.1
2013-12-28 - pterjan <pterjan> 2.3.1-8.mga4
+ Revision: 562475
- Fix gem macros
2013-10-21 - umeabot <umeabot> 2.3.1-7.mga4
+ Revision: 539090
- Mageia 4 Mass Rebuild
2013-10-04 - fwang <fwang> 2.3.1-6.mga4
+ Revision: 491368
- update file list
- use gem_setup
2013-03-01 - luigiwalser <luigiwalser> 2.3.1-6.mga3
+ Revision: 400885
- add patch from redhat to fix CVE-2013-0162
2013-02-08 - umeabot <umeabot> 2.3.1-5.mga3
+ Revision: 396423
- Rebuild for CVE-2013-0256
2013-01-14 - umeabot <umeabot> 2.3.1-4.mga3
+ Revision: 381414
- Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
2012-11-04 - fwang <fwang> 2.3.1-3.mga3
+ Revision: 313883
- rebuild for new ruby

See Also

Package Description
ruby-ruby_parser-doc-3.6.1-3.mga5.noarch.rpm Documentation for ruby-ruby_parser
ruby-rubyforge-2.0.4-11.mga5.noarch.rpm A script which automates a limited set of rubyforge operations
ruby-rubyforge-doc-2.0.4-11.mga5.noarch.rpm Documentation for ruby-rubyforge
ruby-rubyntlm-0.1.1-8.mga5.noarch.rpm Ruby/NTLM library
ruby-rubyntlm-doc-0.1.1-8.mga5.noarch.rpm Documentation for ruby-rubyntlm
ruby-rubytree-0.5.2-10.mga5.noarch.rpm Ruby implementation of the Tree data structure
ruby-rubytree-doc-0.5.2-10.mga5.noarch.rpm Documentation for ruby-rubytree
ruby-rubyzip-1.1.4-3.mga5.noarch.rpm A ruby module for reading and writing zip files
ruby-rubyzip-doc-1.1.4-3.mga5.noarch.rpm Documentation for ruby-rubyzip
ruby-rugged-0.19.0-3.mga5.i586.rpm Rugged is a Ruby binding to the libgit2 linkable library
ruby-rugged-doc-0.19.0-3.mga5.noarch.rpm Documentation for ruby-rugged
ruby-rvm-1.11.3.5-8.mga5.noarch.rpm RVM is the Ruby Version Manager (rvm)
ruby-rvm-doc-1.11.3.5-8.mga5.noarch.rpm Documentation for ruby-rvm
ruby-safe_yaml-1.0.3-3.mga5.noarch.rpm SameYAML provides an alternative implementation of YAML.load suitable for accepting user input in Ruby applications
ruby-safe_yaml-doc-1.0.3-3.mga5.noarch.rpm Documentation for ruby-safe_yaml
Advertisement
Advertisement