coreutils-8.23-6.mga5.x86_64.rpm


Advertisement

Description

coreutils - The GNU core utilities: a set of tools commonly used in shell scripts

Property Value
Distribution Mageia 5.1
Repository Mageia Core x86_64
Package name coreutils
Package version 8.23
Package release 6.mga5
Package architecture x86_64
Package type rpm
Installed size 12.83 MB
Download size 2.01 MB
Official Mirror distrib-coffee.ipsl.jussieu.fr
This package is the union of the old GNU fileutils, sh-utils, and
textutils packages.
These tools are the GNU versions of common useful and popular
file & text utilities which are used for:
- file management
- shell scripts
- modifying text file (spliting, joining, comparing, modifying, ...)
Most of these programs have significant advantages over their Unix
counterparts, such as greater speed, additional options, and fewer
arbitrary limits.

Alternatives

Package Version Architecture Repository
coreutils-8.23-6.mga5.i586.rpm 8.23 i586 Mageia Core
coreutils - - -

Requires

Name Value
config(coreutils) == 8.23-6.mga5
filesystem >= 2.1.9-18
libacl.so.1()(64bit) -
libacl.so.1(ACL_1.0)(64bit) -
libattr.so.1()(64bit) -
libattr.so.1(ATTR_1.1)(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libc.so.6(GLIBC_2.17)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.6)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libcap.so.2()(64bit) -
libgmp.so.10()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
librt.so.1()(64bit) -
librt.so.1(GLIBC_2.3.3)(64bit) -
pam >= 0.66-12

Provides

Name Value
/bin/env -
/usr/bin/env -
/usr/bin/ln -
/usr/bin/rm -
/usr/bin/tr -
config(coreutils) == 8.23-6.mga5
coreutils == 8.23-6.mga5
coreutils(x86-64) == 8.23-6.mga5
libstdbuf.so()(64bit) -
mktemp == 8.23
stat == 8.23

Conflicts

Name Value
tetex < 1.0.7-49
util-linux < 2.23.1

Obsoletes

Name Value
base64 -
mktemp < 8.23

Download

Type URL
Binary Package coreutils-8.23-6.mga5.x86_64.rpm
Source Package coreutils-8.23-6.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install coreutils rpm package:
    # urpmi coreutils

Files

Path
/etc/DIR_COLORS
/usr/bin/[
/usr/bin/arch
/usr/bin/base64
/usr/bin/basename
/usr/bin/cat
/usr/bin/chcon
/usr/bin/chgrp
/usr/bin/chmod
/usr/bin/chown
/usr/bin/cksum
/usr/bin/comm
/usr/bin/cp
/usr/bin/csplit
/usr/bin/cut
/usr/bin/date
/usr/bin/dd
/usr/bin/df
/usr/bin/dir
/usr/bin/dircolors
/usr/bin/dirname
/usr/bin/du
/usr/bin/echo
/usr/bin/env
/usr/bin/expand
/usr/bin/expr
/usr/bin/factor
/usr/bin/false
/usr/bin/fmt
/usr/bin/fold
/usr/bin/groups
/usr/bin/head
/usr/bin/hostid
/usr/bin/id
/usr/bin/install
/usr/bin/join
/usr/bin/link
/usr/bin/ln
/usr/bin/logname
/usr/bin/ls
/usr/bin/md5sum
/usr/bin/mkdir
/usr/bin/mkfifo
/usr/bin/mknod
/usr/bin/mktemp
/usr/bin/mv
/usr/bin/nice
/usr/bin/nl
/usr/bin/nohup
/usr/bin/nproc
/usr/bin/numfmt
/usr/bin/od
/usr/bin/paste
/usr/bin/pathchk
/usr/bin/pinky
/usr/bin/pr
/usr/bin/printenv
/usr/bin/printf
/usr/bin/ptx
/usr/bin/pwd
/usr/bin/readlink
/usr/bin/realpath
/usr/bin/rm
/usr/bin/rmdir
/usr/bin/runcon
/usr/bin/seq
/usr/bin/sha1sum
/usr/bin/sha224sum
/usr/bin/sha256sum
/usr/bin/sha384sum
/usr/bin/sha512sum
/usr/bin/shred
/usr/bin/shuf
/usr/bin/sleep
/usr/bin/sort
/usr/bin/split
/usr/bin/stat
/usr/bin/stdbuf
/usr/bin/stty
/usr/bin/sum
/usr/bin/sync
/usr/bin/tac
/usr/bin/tail
/usr/bin/tee
/usr/bin/test
/usr/bin/timeout
/usr/bin/touch
/usr/bin/tr
/usr/bin/true
/usr/bin/truncate
/usr/bin/tsort
/usr/bin/tty
/usr/bin/uname
/usr/bin/unexpand
/usr/bin/uniq
/usr/bin/unlink
/usr/bin/users
/usr/bin/vdir
/usr/bin/wc
/usr/bin/who
/usr/bin/whoami
/usr/bin/yes
/usr/libexec/coreutils/libstdbuf.so
/usr/sbin/chroot
/usr/share/doc/coreutils/README
/usr/share/locale/af/LC_MESSAGES/coreutils.mo
/usr/share/locale/be/LC_MESSAGES/coreutils.mo
/usr/share/locale/bg/LC_MESSAGES/coreutils.mo
/usr/share/locale/ca/LC_MESSAGES/coreutils.mo
/usr/share/locale/cs/LC_MESSAGES/coreutils.mo
/usr/share/locale/da/LC_MESSAGES/coreutils.mo
/usr/share/locale/de/LC_MESSAGES/coreutils.mo
/usr/share/locale/el/LC_MESSAGES/coreutils.mo
/usr/share/locale/eo/LC_MESSAGES/coreutils.mo
/usr/share/locale/es/LC_MESSAGES/coreutils.mo
/usr/share/locale/et/LC_MESSAGES/coreutils.mo
/usr/share/locale/eu/LC_MESSAGES/coreutils.mo
/usr/share/locale/fi/LC_MESSAGES/coreutils.mo
/usr/share/locale/fr/LC_MESSAGES/coreutils.mo
/usr/share/locale/ga/LC_MESSAGES/coreutils.mo
/usr/share/locale/gl/LC_MESSAGES/coreutils.mo
/usr/share/locale/hr/LC_MESSAGES/coreutils.mo
/usr/share/locale/hu/LC_MESSAGES/coreutils.mo
/usr/share/locale/ia/LC_MESSAGES/coreutils.mo
/usr/share/locale/id/LC_MESSAGES/coreutils.mo
/usr/share/locale/it/LC_MESSAGES/coreutils.mo
/usr/share/locale/ja/LC_MESSAGES/coreutils.mo
/usr/share/locale/kk/LC_MESSAGES/coreutils.mo
/usr/share/locale/ko/LC_MESSAGES/coreutils.mo
/usr/share/locale/lg/LC_MESSAGES/coreutils.mo
/usr/share/locale/lt/LC_MESSAGES/coreutils.mo
/usr/share/locale/ms/LC_MESSAGES/coreutils.mo
/usr/share/locale/nb/LC_MESSAGES/coreutils.mo
/usr/share/locale/nl/LC_MESSAGES/coreutils.mo
/usr/share/locale/pl/LC_MESSAGES/coreutils.mo
/usr/share/locale/pt/LC_MESSAGES/coreutils.mo
/usr/share/locale/pt_BR/LC_MESSAGES/coreutils.mo
/usr/share/locale/ro/LC_MESSAGES/coreutils.mo
/usr/share/locale/ru/LC_MESSAGES/coreutils.mo
/usr/share/locale/sk/LC_MESSAGES/coreutils.mo
/usr/share/locale/sl/LC_MESSAGES/coreutils.mo
/usr/share/locale/sv/LC_MESSAGES/coreutils.mo
/usr/share/locale/tr/LC_MESSAGES/coreutils.mo
/usr/share/locale/uk/LC_MESSAGES/coreutils.mo
/usr/share/locale/vi/LC_MESSAGES/coreutils.mo
/usr/share/locale/zh_CN/LC_MESSAGES/coreutils.mo
/usr/share/locale/zh_TW/LC_MESSAGES/coreutils.mo

Changelog

2015-05-15 - luigiwalser <luigiwalser> 8.23-6.mga5
+ Revision: 822099
- update i18n patch from fedora to fix buffer overflow
2014-12-30 - luigiwalser <luigiwalser> 8.23-5.mga5
+ Revision: 807233
- update i18n patch from fedora (fix rhbz#1146185)
2014-10-15 - umeabot <umeabot> 8.23-4.mga5
+ Revision: 740380
- Second Mageia 5 Mass Rebuild
2014-09-18 - umeabot <umeabot> 8.23-3.mga5
+ Revision: 693687
- Rebuild to fix library dependencies
2014-09-16 - umeabot <umeabot> 8.23-2.mga5
+ Revision: 678546
- Mageia 5 Mass Rebuild
2014-07-23 - luigiwalser <luigiwalser> 8.23-1.mga5
+ Revision: 656115
- 8.23
- rediff patch 1155
- rediff df-direct patch (from fedora)
- update i18n patch (from fedora)
2014-02-14 - luigiwalser <luigiwalser> 8.22-1.mga5
+ Revision: 591367
- 8.22
- update i18n patch (from fedora)
- rediff patches 1011, 1014, 2101, 201
- remove upstream patches
2013-12-21 - luigiwalser <luigiwalser> 8.21-6.mga4
+ Revision: 559349
- update i18n patch (from fedora)
- add bugfixes from coreutils 8.22
2013-10-19 - umeabot <umeabot> 8.21-5.mga4
+ Revision: 536374
- Mageia 4 Mass Rebuild
2013-09-23 - blue_prawn <blue_prawn> 8.21-4.mga4
+ Revision: 484185
- fixed substraction with unsigned ints

See Also

Package Description
coreutils-doc-8.23-6.mga5.noarch.rpm Coreutils documentation in info format
corkscrew-2.0-14.mga5.x86_64.rpm Tool for tunneling SSH through HTTP proxies
coro-mock-1.0-7.mga5.noarch.rpm A mock library for compiling JVM coroutine-using code on JVMs without coroutines
coro-mock-javadoc-1.0-7.mga5.noarch.rpm Javadoc for coro-mock
corosync-2.3.4-4.mga5.x86_64.rpm The Corosync Cluster Engine and Application Programming Interfaces
corsixth-0.40-1.mga5.x86_64.rpm Open source clone of Theme Hospital
countdown-0.4.3-4.mga5.noarch.rpm Like sleep, only displays the amount of time remaining
countrycodes-1.0.5-12.mga5.x86_64.rpm Country code finder
courier-authdaemon-0.65.0-12.mga5.x86_64.rpm Courier authentication daemon
courier-authlib-0.65.0-12.mga5.x86_64.rpm Courier authentication library
courier-authlib-devel-0.65.0-12.mga5.x86_64.rpm Development libraries for the Courier authentication library
courier-authlib-ldap-0.65.0-12.mga5.x86_64.rpm LDAP support for the Courier authentication library
courier-authlib-mysql-0.65.0-12.mga5.x86_64.rpm MySQL support for the Courier authentication library
courier-authlib-pgsql-0.65.0-12.mga5.x86_64.rpm MySQL support for the Courier authentication library
courier-authlib-sqlite-0.65.0-12.mga5.x86_64.rpm SQLite support for the Courier authentication library
Advertisement
Advertisement