glibc-static-devel-2.20-20.mga5.x86_64.rpm


Advertisement

Description

glibc-static-devel - Static libraries for GNU C library

Property Value
Distribution Mageia 5.1
Repository Mageia Core x86_64
Package filename glibc-static-devel-2.20-20.mga5.x86_64.rpm
Package name glibc-static-devel
Package version 2.20
Package release 20.mga5
Package architecture x86_64
Package type rpm
Category Development/C
Homepage http://www.gnu.org/software/libc/
License LGPL
Maintainer -
Download size 8.67 MB
Installed size 54.48 MB
The glibc-static-devel package contains the static libraries necessary
for developing programs which use the standard C libraries. Install
glibc-static-devel if you need to statically link your program or
library.

Alternatives

Package Version Architecture Repository
glibc-static-devel-2.20-27.mga5.i586.rpm 2.20 i586 Mageia Core Updates
glibc-static-devel-2.20-27.mga5.x86_64.rpm 2.20 x86_64 Mageia Core Updates
glibc-static-devel-2.20-26.mga5.i586.rpm 2.20 i586 Mageia Core Updates
glibc-static-devel-2.20-26.mga5.x86_64.rpm 2.20 x86_64 Mageia Core Updates
glibc-static-devel-2.20-25.mga5.i586.rpm 2.20 i586 Mageia Core Updates
glibc-static-devel-2.20-25.mga5.x86_64.rpm 2.20 x86_64 Mageia Core Updates
glibc-static-devel-2.20-24.mga5.i586.rpm 2.20 i586 Mageia Core Updates
glibc-static-devel-2.20-24.mga5.x86_64.rpm 2.20 x86_64 Mageia Core Updates
glibc-static-devel-2.20-23.mga5.i586.rpm 2.20 i586 Mageia Core Updates
glibc-static-devel-2.20-23.mga5.x86_64.rpm 2.20 x86_64 Mageia Core Updates
glibc-static-devel-2.20-22.mga5.i586.rpm 2.20 i586 Mageia Core Updates
glibc-static-devel-2.20-22.mga5.x86_64.rpm 2.20 x86_64 Mageia Core Updates
glibc-static-devel-2.20-21.mga5.i586.rpm 2.20 i586 Mageia Core Updates
glibc-static-devel-2.20-21.mga5.x86_64.rpm 2.20 x86_64 Mageia Core Updates
glibc-static-devel-2.20-20.mga5.i586.rpm 2.20 i586 Mageia Core
glibc-static-devel - - -

Requires

Name Value
glibc-devel == 6:2.20-20.mga5

Provides

Name Value
glibc-static-devel == 6:2.20-20.mga5
glibc-static-devel(x86-64) == 6:2.20-20.mga5

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package glibc-static-devel-2.20-20.mga5.x86_64.rpm
Source Package glibc-2.20-20.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install glibc-static-devel rpm package:
    # urpmi glibc-static-devel

Files

Path
/usr/lib/libBrokenLocale.a
/usr/lib/libanl.a
/usr/lib/libc.a
/usr/lib/libcrypt.a
/usr/lib/libdl.a
/usr/lib/libm.a
/usr/lib/libnsl.a
/usr/lib/libpthread.a
/usr/lib/libresolv.a
/usr/lib/librt.a
/usr/lib/libutil.a
/usr/lib64/libBrokenLocale.a
/usr/lib64/libanl.a
/usr/lib64/libc.a
/usr/lib64/libcrypt.a
/usr/lib64/libdl.a
/usr/lib64/libm.a
/usr/lib64/libnsl.a
/usr/lib64/libpthread.a
/usr/lib64/libresolv.a
/usr/lib64/librt.a
/usr/lib64/libutil.a
/usr/share/doc/glibc-static-devel/COPYING
/usr/share/doc/glibc-static-devel/COPYING.LIB

Changelog

2015-05-02 - tmb <tmb> 6:2.20-20.mga5
+ Revision: 821015
- Do not close NSS files database during iteration [BZ #18007] (CVE-2014-8121)
2015-05-01 - tmb <tmb> 6:2.20-19.mga5
+ Revision: 821001
- resolv/nss_dns/dns-host.c buffer overflow (CVE-2015-1781) [BZ#18287]
2015-04-19 - tmb <tmb> 6:2.20-18.mga5
+ Revision: 820468
- nscd needs /var/db/nscd (mga#15545)
2015-04-18 - tmb <tmb> 6:2.20-17.mga5
+ Revision: 820464
- Fix _IO_wstr_overflow integer overflow (PR/BZ #17269)
- Fix read past end of pattern in fnmatch (PR/BZ #18032)
2015-02-21 - tmb <tmb> 6:2.20-16.mga5
+ Revision: 816252
- sync with upstream glibc-2.20 maintenance branch:
* Update Russian translation
* Revert to defining __extern_inline only for gcc-4.3+ (BZ #17266)
* Update French translation
* BZ#17460: Fix buffer overrun in nscd --help
* MIPS: Avoid a dangling `vfork@GLIBC_2.0' reference
* AArch64: End frame record chain correctly
* Make __extern_always_inline usable on clang++ again
* Move findidx nested functions to top-level
* Fix memory handling in strxfrm_l [BZ #16009] (CVE pending)
* Use AVX unaligned memcpy only if AVX2 is available
2015-02-08 - tmb <tmb> 6:2.20-15.mga5
+ Revision: 814068
- wscanf allocates too little memory (CVE-2015-1472, CVE-2015-1473)
2014-12-21 - tmb <tmb> 6:2.20-14.mga5
+ Revision: 804687
- Fix stack overflow in vfprintf [BZ #16617] (CVE-2012-3406)
- Avoid infinite loop in nss_dns getnetbyname [BZ #17630] (CVE-2014-9402)
2014-11-22 - tmb <tmb> 6:2.20-12.mga5
+ Revision: 798301
- posix wordexp fails to honour WRDE_NOCMD (CVE-2014-7817)
2014-10-15 - tmb <tmb> 6:2.20-11.mga5
+ Revision: 751288
- elf/dl-load.c (open_path): Avoid writing to 'env_path_list'
when none of the search directories exist. (BZ #15378)
- Fix infinite loop in check_pf (BZ #12926)
- disable lock elision again
2014-10-10 - tmb <tmb> 6:2.20-10.mga5
+ Revision: 737970
- re-enable lock elision for now as disabling it triggesrs SIGILL traps

See Also

Package Description
glibc-utils-2.20-20.mga5.x86_64.rpm Development utilities from GNU C library
glibmm2.4-doc-2.42.0-3.mga5.noarch.rpm Glibmm documentation
glm-devel-0.9.5.4-3.mga5.x86_64.rpm C++ mathematics library for graphics programming
glm-doc-0.9.5.4-3.mga5.noarch.rpm Documentation for glm-devel
globulation2-0.9.4.4-19.mga5.x86_64.rpm Globulation2 - a state of the art Real Time Strategy (RTS) game
glom-1.28.0-2.mga5.x86_64.rpm Easy-to-use database designer and user interface
gloobus-preview-0.4.1-7.mga5.x86_64.rpm A Gnome extension to enable previews for any kind of file
glpi-0.84.8-2.1.mga5.noarch.rpm A web based park management
glpi-plugin-archires-2.1.0-4.mga5.noarch.rpm Network reporting plugin
glpi-plugin-datainjection-2.3.1-1.mga5.noarch.rpm Data import plugin
glpi-plugin-fusioninventory-0.84+3.5-5.mga5.noarch.rpm FusionInventory GLPI plugin
glpi-plugin-genericobject-2.3.2-1.mga5.noarch.rpm Add new inventory objects
glpi-plugin-manufacturersimports-1.6.0-4.mga5.noarch.rpm Financials informations from manufacturers web site plugin
glpi-plugin-racks-1.4.1-1.mga5.noarch.rpm Bay management plugin
glpi-plugin-reports-1.7.2-1.mga5.noarch.rpm Additional reports plugin
Advertisement
Advertisement