lib64gtk+3_0-3.14.8-5.mga5.x86_64.rpm


Advertisement

Description

lib64gtk+3_0 - The GIMP ToolKit (GTK+), a library for creating GUIs

Property Value
Distribution Mageia 5.1
Repository Mageia Core x86_64
Package filename lib64gtk+3_0-3.14.8-5.mga5.x86_64.rpm
Package name lib64gtk+3_0
Package version 3.14.8
Package release 5.mga5
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.gtk.org
License LGPLv2+
Maintainer -
Download size 2.18 MB
Installed size 7.85 MB
This package contains the library needed to run programs dynamically
linked with gtk+.

Alternatives

Package Version Architecture Repository
lib64gtk+3_0-3.14.8-5.1.mga5.x86_64.rpm 3.14.8 x86_64 Mageia Core Updates
lib64gtk+3_0 - - -

Requires

Name Value
adwaita-icon-theme -
glib2.0-common -
gtk+3.0 -
gtk+3.0 == 3.14.8-5.mga5
hicolor-icon-theme -
libX11.so.6()(64bit) -
libXcomposite.so.1()(64bit) -
libXcursor.so.1()(64bit) -
libXdamage.so.1()(64bit) -
libXext.so.6()(64bit) -
libXfixes.so.3()(64bit) -
libXi.so.6()(64bit) -
libXinerama.so.1()(64bit) -
libXrandr.so.2()(64bit) -
libatk-1.0.so.0()(64bit) -
libatk-bridge-2.0.so.0()(64bit) -
libatk1.0 >= 2.1.5
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libcairo-gobject.so.2()(64bit) -
libcairo.so.2()(64bit) -
libcolord.so.2()(64bit) -
libcups.so.2()(64bit) -
libfontconfig.so.1()(64bit) -
libgdk-3.so.0()(64bit) -
libgdk_pixbuf-2.0.so.0()(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libglib2.0 >= 2.39.5
libgmodule-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgtk-3.so.0()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libmesagl >= 10.2.3-1
libpango-1.0.so.0()(64bit) -
libpango1.0 >= 1.29.0
libpangocairo-1.0.so.0()(64bit) -
libpangoft2-1.0.so.0()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
librt.so.1()(64bit) -
librt.so.1(GLIBC_2.2.5)(64bit) -
libwayland-client.so.0()(64bit) -
libwayland-cursor.so.0()(64bit) -
libxkbcommon.so.0()(64bit) -

Provides

Name Value
lib64gtk+3_0 == 3.14.8-5.mga5
lib64gtk+3_0(x86-64) == 3.14.8-5.mga5
libgdk-3.so.0()(64bit) -
libgtk+3 == 3.14.8-5.mga5
libgtk+3.0 == 3.14.8-5.mga5
libgtk-3.so.0()(64bit) -
libprintbackend-cups.so()(64bit) -
libprintbackend-file.so()(64bit) -
libprintbackend-lpr.so()(64bit) -

Obsoletes

Name Value
lib64gtk+-x11-3.0_0 < 3.0.0
lib64gtk+3.0_0 < 3.0.0
lib64gtk-engines3 < 3.0.0

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64gtk+3_0-3.14.8-5.mga5.x86_64.rpm
Source Package gtk+3.0-3.14.8-5.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64gtk+3_0 rpm package:
    # urpmi lib64gtk+3_0

Files

Path
/usr/lib64/libgdk-3.so.0
/usr/lib64/libgdk-3.so.0.1400.8
/usr/lib64/libgtk-3.so.0
/usr/lib64/libgtk-3.so.0.1400.8
/usr/lib64/gtk-3.0/modules
/usr/lib64/gtk-3.0/3.0.0/immodules.cache
/usr/lib64/gtk-3.0/3.0.0/immodules/im-am-et.so
/usr/lib64/gtk-3.0/3.0.0/immodules/im-broadway.so
/usr/lib64/gtk-3.0/3.0.0/immodules/im-cedilla.so
/usr/lib64/gtk-3.0/3.0.0/immodules/im-cyrillic-translit.so
/usr/lib64/gtk-3.0/3.0.0/immodules/im-inuktitut.so
/usr/lib64/gtk-3.0/3.0.0/immodules/im-ipa.so
/usr/lib64/gtk-3.0/3.0.0/immodules/im-multipress.so
/usr/lib64/gtk-3.0/3.0.0/immodules/im-thai.so
/usr/lib64/gtk-3.0/3.0.0/immodules/im-ti-er.so
/usr/lib64/gtk-3.0/3.0.0/immodules/im-ti-et.so
/usr/lib64/gtk-3.0/3.0.0/immodules/im-viqr.so
/usr/lib64/gtk-3.0/3.0.0/immodules/im-xim.so
/usr/lib64/gtk-3.0/3.0.0/printbackends/libprintbackend-cups.so
/usr/lib64/gtk-3.0/3.0.0/printbackends/libprintbackend-file.so
/usr/lib64/gtk-3.0/3.0.0/printbackends/libprintbackend-lpr.so
/usr/lib64/gtk-3.0/bin/gtk-query-immodules-3.0
/usr/share/doc/lib64gtk+3_0/README
/var/lib/rpm/filetriggers/gtk-query-immodules-3.0-64.filter
/var/lib/rpm/filetriggers/gtk-query-immodules-3.0-64.script

Changelog

2015-05-06 - tmb <tmb> 3.14.8-5.mga5
+ Revision: 821351
- Do not return NULL AtkStateSet
- eventcontroller, widget: Don't crash if destroyed before the other
- eventcontroller: Chain up on constructed
- gdk: don't segfault on beep with offscreen window
- GtkApplication: avoid a crash
- GtkApplication: Prevent more crashes around shutdown
- Make gtk-update-icon-cache not fall over leftover temp files
- Prevent empty password request popup for kerberos
- treeview: Avoid a crash with rubberbanding
- treeview: Don't create an overly large pixel cache
- widget: Take a ref during ::unmap emission
- widget: Take a ref during ::unrealize emission
2015-03-18 - luigiwalser <luigiwalser> 3.14.8-4.mga5
+ Revision: 818857
- do not error out if libgtk+3_0 posttrans gtk-query-immodules-3.0 exits with error
- make sure libmesagl1 is updated before libgtk+3_0 so posttrans works (mga#15521)
- add symlink to old gtk-query-immodules-3.0 binary so mga4 postuns work on upgrade
2015-02-13 - tv <tv> 3.14.8-3.mga5
+ Revision: 814816
- rediff patch0 for gtk+-3.14.8
- really restore patch for misplaced tooltips in drakx (mga#11893, bgo#698730)
- restore patch for misplaced tooltips in drakx (mga#11893, bgo#698730)
2015-02-05 - ovitters <ovitters> 3.14.8-2.mga5
+ Revision: 813539
- add Adwaita requires
2015-02-01 - ovitters <ovitters> 3.14.8-1.mga5
+ Revision: 813074
- new version 3.14.8
- update description
2015-01-12 - ovitters <ovitters> 3.14.7-1.mga5
+ Revision: 810019
- new version 3.14.7
2014-12-22 - ovitters <ovitters> 3.14.6-1.mga5
+ Revision: 804803
- new version 3.14.6
2014-12-06 - wally <wally> 3.14.5-2.mga5
+ Revision: 801715
- disable default theme patch
o don't hardcode oxygen-gtk as default theme
o fixes black background in gtk3 apps if oxygen-gtk pkgs arent't installed and theme without gtk3 support is used
2014-11-11 - ovitters <ovitters> 3.14.5-1.mga5
+ Revision: 796326
- new version 3.14.5
2014-10-21 - ovitters <ovitters> 3.14.4-1.mga5
+ Revision: 792343
- new version 3.14.4
- dropped merged patch 2

See Also

Package Description
lib64gtk-gir2.0-2.24.26-3.mga5.x86_64.rpm GObject Introspection interface description for gtk+2.0
lib64gtk-gir3.0-3.14.8-5.mga5.x86_64.rpm GObject introspection interface library for gtk+3.0
lib64gtk-murrine-engine-0.98.2-6.mga5.x86_64.rpm Murrine GTK2 cairo theme
lib64gtk-qt-engine-1.1-5.r5.8.mga5.x86_64.rpm Dynamic libraries for gtk-qt-engine
lib64gtk-unico-engine-1.0.3-0.20140109bzr152.4.mga5.x86_64.rpm Unico Gtk+ theming engine
lib64gtk-vnc1.0-devel-0.5.3-6.mga5.x86_64.rpm A VNC viewer widget for GTK
lib64gtk-vnc1.0_0-0.5.3-6.mga5.x86_64.rpm A VNC viewer widget for GTK
lib64gtk-vnc2.0-devel-0.5.3-6.mga5.x86_64.rpm Headers and development library for gtk3-vnc
lib64gtk-vnc2.0_0-0.5.3-6.mga5.x86_64.rpm A VNC viewer widget for GTK3
lib64gtk2-theme-engines-2.20.2-5.mga5.x86_64.rpm Library files for gtk2-theme-engines
lib64gtkdatabox-devel-0.9.2.0-3.mga5.x86_64.rpm Development files for gtkdatabox
lib64gtkdatabox0.9.2_0-0.9.2.0-3.mga5.x86_64.rpm A Gtk+-Widget for Fast Data Display
lib64gtkextra-x11-devel-3.1.1-3.mga5.x86_64.rpm Development files for gtkextra
lib64gtkextra-x11_3.0_7-3.1.1-3.mga5.x86_64.rpm A library of gtk+ widgets
lib64gtkgl-devel-2.0.1-8.mga5.x86_64.rpm Includes and static libs
Advertisement
Advertisement