lib64qt5gui5-5.4.0-7.mga5.x86_64.rpm


Advertisement

Description

lib64qt5gui5 - Qt5 Component Library

Property Value
Distribution Mageia 5.1
Repository Mageia Core x86_64
Package filename lib64qt5gui5-5.4.0-7.mga5.x86_64.rpm
Package name lib64qt5gui5
Package version 5.4.0
Package release 7.mga5
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://www.qt-project.org
License LGPLv2 with exceptions or GPLv3 with exceptions and GFDL
Maintainer -
Download size 2.24 MB
Installed size 8.01 MB
Qt5 Component Library.
The QtGui module extends QtCore with GUI functionality.

Alternatives

Package Version Architecture Repository
lib64qt5gui5-5.4.2-1.1.mga5.x86_64.rpm 5.4.2 x86_64 Mageia Core Updates
lib64qt5gui5 - - -

Requires

Name Value
libEGL.so.1()(64bit) -
libGL.so.1()(64bit) -
libQt5Core.so.5()(64bit) -
libQt5DBus.so.5()(64bit) -
libQt5Gui.so.5()(64bit) -
libX11-xcb.so.1()(64bit) -
libX11.so.6()(64bit) -
libXi.so.6()(64bit) -
libXrender.so.1()(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.11)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libdirectfb-1.7.so.5()(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libdrm.so.2()(64bit) -
libfontconfig.so.1()(64bit) -
libfreetype.so.6()(64bit) -
libgbm.so.1()(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.4)(64bit) -
libgdk-x11-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgtk-x11-2.0.so.0()(64bit) -
libjpeg.so.8()(64bit) -
libjpeg.so.8(LIBJPEG_8.0)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpango-1.0.so.0()(64bit) -
libpng16.so.16()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libudev.so.1()(64bit) -
libudev.so.1(LIBUDEV_183)(64bit) -
libxcb-glx.so.0()(64bit) -
libxcb-icccm.so.4()(64bit) -
libxcb-image.so.0()(64bit) -
libxcb-keysyms.so.1()(64bit) -
libxcb-randr.so.0()(64bit) -
libxcb-render-util.so.0()(64bit) -
libxcb-render.so.0()(64bit) -
libxcb-shape.so.0()(64bit) -
libxcb-shm.so.0()(64bit) -
libxcb-sync.so.1()(64bit) -
libxcb-xfixes.so.0()(64bit) -
libxcb-xkb.so.1()(64bit) -
libxcb.so.1()(64bit) -
libxkbcommon-x11.so.0()(64bit) -
libxkbcommon.so.0()(64bit) -
libz.so.1()(64bit) -
qtbase5-common == 5.4.0

Provides

Name Value
lib64qt5gui5 == 5.4.0-7.mga5
lib64qt5gui5(x86-64) == 5.4.0-7.mga5
libQt5Gui.so.5()(64bit) -
libcomposeplatforminputcontextplugin.so()(64bit) -
libibusplatforminputcontextplugin.so()(64bit) -
libqdirectfb.so()(64bit) -
libqeglfs.so()(64bit) -
libqgif.so()(64bit) -
libqgtk2.so()(64bit) -
libqico.so()(64bit) -
libqjpeg.so()(64bit) -
libqkms.so()(64bit) -
libqlinuxfb.so()(64bit) -
libqminimal.so()(64bit) -
libqminimalegl.so()(64bit) -
libqoffscreen.so()(64bit) -
libqxcb.so()(64bit) -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64qt5gui5-5.4.0-7.mga5.x86_64.rpm
Source Package qtbase5-5.4.0-7.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64qt5gui5 rpm package:
    # urpmi lib64qt5gui5

Files

Path
/usr/lib64/libQt5Gui.so.5
/usr/lib64/libQt5Gui.so.5.4
/usr/lib64/libQt5Gui.so.5.4.0
/usr/lib64/qt5/plugins/imageformats/libqgif.so
/usr/lib64/qt5/plugins/imageformats/libqico.so
/usr/lib64/qt5/plugins/imageformats/libqjpeg.so
/usr/lib64/qt5/plugins/platforminputcontexts/libcomposeplatforminputcontextplugin.so
/usr/lib64/qt5/plugins/platforminputcontexts/libibusplatforminputcontextplugin.so
/usr/lib64/qt5/plugins/platforms/libqdirectfb.so
/usr/lib64/qt5/plugins/platforms/libqeglfs.so
/usr/lib64/qt5/plugins/platforms/libqkms.so
/usr/lib64/qt5/plugins/platforms/libqlinuxfb.so
/usr/lib64/qt5/plugins/platforms/libqminimal.so
/usr/lib64/qt5/plugins/platforms/libqminimalegl.so
/usr/lib64/qt5/plugins/platforms/libqoffscreen.so
/usr/lib64/qt5/plugins/platforms/libqxcb.so
/usr/lib64/qt5/plugins/platformthemes/libqgtk2.so

Changelog

2015-04-22 - luigiwalser <luigiwalser> 5.4.0-7.mga5
+ Revision: 820558
- add patches from fedora to fix CVE-2015-1858, CVE-2015-1859, and CVE-2015-1860
2015-02-28 - lmenut <lmenut> 5.4.0-6.mga5
+ Revision: 817205
- add upstream patch to fix DoS vulnerability in the BMP image handler
(CVE-2015-0295) mga#15383
2015-02-08 - doktor5000 <doktor5000> 5.4.0-5.mga5
+ Revision: 814176
- added upstream patch to fix broken drag&drop for 5.4.0 (QTBUG-43436)
2015-01-06 - cjw <cjw> 5.4.0-4.mga5
+ Revision: 808796
- sync csh profile script with sh profile script and add needed escape chars (mga #12826)
2014-12-27 - neoclust <neoclust> 5.4.0-3.mga5
+ Revision: 806365
- Add csh/tcsh profile support mga #12826
2014-12-23 - neoclust <neoclust> 5.4.0-2.mga5
+ Revision: 805003
- Fix Requires for translations Mga#13993 #14746
2014-12-11 - neoclust <neoclust> 5.4.0-1.mga5
+ Revision: 802720
- New version 5.4.0
2014-12-07 - neoclust <neoclust> 5.3.2-7.mga5
+ Revision: 802011
- New version 5.3.2
2014-11-29 - doktor5000 <doktor5000> 5.3.1-7.mga5
+ Revision: 799847
- disable SSE2 on %ix86 otherwise QT crashes on processors without SSE2
o fixes (mga#13991), (mga#14229), (mga#14418), (mga#14491)
- provide SSE2-enabled library in separate subdir as recommended by upstream
o SSE2 library located in %{_qt5_libdir}/sse2/
2014-11-25 - cjw <cjw> 5.3.1-6.mga5
+ Revision: 799031
- rebuild against postgresql9.4

See Also

Package Description
lib64qt5help-devel-5.4.0-2.mga5.x86_64.rpm Devel files needed to build apps based on QtJsonDbCompat
lib64qt5help-private-devel-5.4.0-2.mga5.x86_64.rpm Devel files needed to build apps based on QtJsonDbCompat
lib64qt5imageformats-devel-5.4.0-1.mga5.x86_64.rpm Devel files needed to build apps based on QtImageFormats
lib64qt5keychain-devel-0.4-3.mga5.x86_64.rpm Development tools for programs which will use the qt5keychain
lib64qt5keychain0-0.4-3.mga5.x86_64.rpm Platform-independent Qt API for storing passwords securely
lib64qt5location-devel-5.4.0-1.mga5.x86_64.rpm Devel files needed to build apps based on QtLocation
lib64qt5location-private-devel-5.4.0-1.mga5.x86_64.rpm Devel files needed to build apps based on QtLocation
lib64qt5location5-5.4.0-1.mga5.x86_64.rpm Qt5 Component Library
lib64qt5multimedia-devel-5.4.0-1.mga5.x86_64.rpm Devel files needed to build apps based on QtVersit
lib64qt5multimedia-private-devel-5.4.0-1.mga5.x86_64.rpm Devel files needed to build apps based on QtVersit
lib64qt5multimedia5-5.4.0-1.mga5.x86_64.rpm Qt5 Lib
lib64qt5multimediawidgets-devel-5.4.0-1.mga5.x86_64.rpm Devel files needed to build apps based on QtVersit
lib64qt5multimediawidgets-private-devel-5.4.0-1.mga5.x86_64.rpm Devel files needed to build apps based on QtVersit
lib64qt5multimediawidgets5-5.4.0-1.mga5.x86_64.rpm Qt5 Lib
lib64qt5network-devel-5.4.0-7.mga5.x86_64.rpm Devel files needed to build apps based on QtNetwork
Advertisement
Advertisement