lib64qt5printsupport-devel-5.4.0-7.mga5.x86_64.rpm


Advertisement

Description

lib64qt5printsupport-devel - Devel files needed to build apps based on QtPrintSupport

Property Value
Distribution Mageia 5.1
Repository Mageia Core x86_64
Package filename lib64qt5printsupport-devel-5.4.0-7.mga5.x86_64.rpm
Package name lib64qt5printsupport-devel
Package version 5.4.0
Package release 7.mga5
Package architecture x86_64
Package type rpm
Category Development/KDE and Qt
Homepage http://www.qt-project.org
License LGPLv2 with exceptions or GPLv3 with exceptions and GFDL
Maintainer -
Download size 26.09 KB
Installed size 43.33 KB
Devel files needed to build apps based on QtPrintSupport.

Alternatives

Package Version Architecture Repository
lib64qt5printsupport-devel-5.4.2-1.1.mga5.x86_64.rpm 5.4.2 x86_64 Mageia Core Updates
lib64qt5printsupport-devel - - -

Requires

Name Value
devel(libQt5Core(64bit)) -
devel(libQt5Gui(64bit)) -
devel(libQt5Widgets(64bit)) -
devel(libm(64bit)) -
devel(libstdc++(64bit)) -
lib64qt5printsupport5 == 5.4.0
pkgconfig -
pkgconfig(Qt5Core) -
pkgconfig(Qt5Gui) -
pkgconfig(Qt5Widgets) -
qtbase5-common == 5.4.0
qtbase5-common-devel == 5.4.0-7.mga5

Provides

Name Value
devel(libQt5PrintSupport(64bit)) -
lib64qt5printsupport-devel == 5.4.0-7.mga5
lib64qt5printsupport-devel(x86-64) == 5.4.0-7.mga5
libqt5printsupport-devel == 5.4.0
libqtprintsupport5-devel == 5.4.0
pkgconfig(Qt5PrintSupport) == 5.4.0
qt5printsupport-devel == 5.4.0
qtprintsupport5-devel == 5.4.0

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64qt5printsupport-devel-5.4.0-7.mga5.x86_64.rpm
Source Package qtbase5-5.4.0-7.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64qt5printsupport-devel rpm package:
    # urpmi lib64qt5printsupport-devel

Files

Path
/usr/lib64/libQt5PrintSupport.prl
/usr/lib64/libQt5PrintSupport.so
/usr/lib64/cmake/Qt5PrintSupport/Qt5PrintSupportConfig.cmake
/usr/lib64/cmake/Qt5PrintSupport/Qt5PrintSupportConfigVersion.cmake
/usr/lib64/cmake/Qt5PrintSupport/Qt5PrintSupport_QCupsPrinterSupportPlugin.cmake
/usr/lib64/pkgconfig/Qt5PrintSupport.pc
/usr/lib64/qt5/include/QtPrintSupport/QAbstractPrintDialog
/usr/lib64/qt5/include/QtPrintSupport/QPageSetupDialog
/usr/lib64/qt5/include/QtPrintSupport/QPrintDialog
/usr/lib64/qt5/include/QtPrintSupport/QPrintEngine
/usr/lib64/qt5/include/QtPrintSupport/QPrintPreviewDialog
/usr/lib64/qt5/include/QtPrintSupport/QPrintPreviewWidget
/usr/lib64/qt5/include/QtPrintSupport/QPrinter
/usr/lib64/qt5/include/QtPrintSupport/QPrinterInfo
/usr/lib64/qt5/include/QtPrintSupport/QtPrintSupport
/usr/lib64/qt5/include/QtPrintSupport/QtPrintSupportDepends
/usr/lib64/qt5/include/QtPrintSupport/QtPrintSupportVersion
/usr/lib64/qt5/include/QtPrintSupport/qabstractprintdialog.h
/usr/lib64/qt5/include/QtPrintSupport/qpagesetupdialog.h
/usr/lib64/qt5/include/QtPrintSupport/qprintdialog.h
/usr/lib64/qt5/include/QtPrintSupport/qprintengine.h
/usr/lib64/qt5/include/QtPrintSupport/qprinter.h
/usr/lib64/qt5/include/QtPrintSupport/qprinterinfo.h
/usr/lib64/qt5/include/QtPrintSupport/qprintpreviewdialog.h
/usr/lib64/qt5/include/QtPrintSupport/qprintpreviewwidget.h
/usr/lib64/qt5/include/QtPrintSupport/qtprintsupportglobal.h
/usr/lib64/qt5/include/QtPrintSupport/qtprintsupportversion.h

Changelog

2015-04-22 - luigiwalser <luigiwalser> 5.4.0-7.mga5
+ Revision: 820558
- add patches from fedora to fix CVE-2015-1858, CVE-2015-1859, and CVE-2015-1860
2015-02-28 - lmenut <lmenut> 5.4.0-6.mga5
+ Revision: 817205
- add upstream patch to fix DoS vulnerability in the BMP image handler
(CVE-2015-0295) mga#15383
2015-02-08 - doktor5000 <doktor5000> 5.4.0-5.mga5
+ Revision: 814176
- added upstream patch to fix broken drag&drop for 5.4.0 (QTBUG-43436)
2015-01-06 - cjw <cjw> 5.4.0-4.mga5
+ Revision: 808796
- sync csh profile script with sh profile script and add needed escape chars (mga #12826)
2014-12-27 - neoclust <neoclust> 5.4.0-3.mga5
+ Revision: 806365
- Add csh/tcsh profile support mga #12826
2014-12-23 - neoclust <neoclust> 5.4.0-2.mga5
+ Revision: 805003
- Fix Requires for translations Mga#13993 #14746
2014-12-11 - neoclust <neoclust> 5.4.0-1.mga5
+ Revision: 802720
- New version 5.4.0
2014-12-07 - neoclust <neoclust> 5.3.2-7.mga5
+ Revision: 802011
- New version 5.3.2
2014-11-29 - doktor5000 <doktor5000> 5.3.1-7.mga5
+ Revision: 799847
- disable SSE2 on %ix86 otherwise QT crashes on processors without SSE2
o fixes (mga#13991), (mga#14229), (mga#14418), (mga#14491)
- provide SSE2-enabled library in separate subdir as recommended by upstream
o SSE2 library located in %{_qt5_libdir}/sse2/
2014-11-25 - cjw <cjw> 5.3.1-6.mga5
+ Revision: 799031
- rebuild against postgresql9.4

See Also

Package Description
lib64qt5printsupport-private-devel-5.4.0-7.mga5.x86_64.rpm Devel files needed to build apps based on QtPrintSupport
lib64qt5printsupport5-5.4.0-7.mga5.x86_64.rpm Qt5 Lib
lib64qt5qml-devel-5.4.0-2.mga5.x86_64.rpm Devel files needed to build apps based on QtVersit
lib64qt5qml-private-devel-5.4.0-2.mga5.x86_64.rpm Devel files needed to build apps based on QtVersit
lib64qt5qml5-5.4.0-2.mga5.x86_64.rpm Qt5 Lib
lib64qt5quick-devel-5.4.0-2.mga5.x86_64.rpm Devel files needed to build apps based on QtVersit
lib64qt5quick-private-devel-5.4.0-2.mga5.x86_64.rpm Devel files needed to build apps based on QtVersit
lib64qt5quick5-5.4.0-2.mga5.x86_64.rpm Qt5 Lib
lib64qt5quickparticles-devel-5.4.0-2.mga5.x86_64.rpm Devel files needed to build apps based on QtVersit
lib64qt5quickparticles-private-devel-5.4.0-2.mga5.x86_64.rpm Devel files needed to build apps based on QtVersit
lib64qt5quickparticles5-5.4.0-2.mga5.x86_64.rpm Qt5 Lib
lib64qt5quicktest-devel-5.4.0-2.mga5.x86_64.rpm Devel files needed to build apps based on QtVersit
lib64qt5quicktest-private-devel-5.4.0-2.mga5.x86_64.rpm Devel files needed to build apps based on QtVersit
lib64qt5quicktest5-5.4.0-2.mga5.x86_64.rpm Qt5 Lib
lib64qt5quickwidgets-devel-5.4.0-2.mga5.x86_64.rpm Devel files needed to build apps based on QtVersit
Advertisement
Advertisement