php-ZendFramework2-Authentication-2.3.9-1.mga5.noarch.rpm


Advertisement

Description

php-ZendFramework2-Authentication - Zend Framework 2: Authentication Component

Property Value
Distribution Mageia 5.1
Repository Mageia Core x86_64
Package filename php-ZendFramework2-Authentication-2.3.9-1.mga5.noarch.rpm
Package name php-ZendFramework2-Authentication
Package version 2.3.9
Package release 1.mga5
Package architecture noarch
Package type rpm
Category Development/PHP
Homepage http://framework.zend.com/
License BSD
Maintainer -
Download size 32.55 KB
Installed size 111.45 KB
The Zend\Authentication component provides an API for authentication and
includes concrete authentication adapters for common use case scenarios.
Zend\Authentication is concerned only with authentication and not with
authorization. Authentication is loosely defined as determining whether
an entity actually is what it purports to be (i.e., identification),
based on some set of credentials. Authorization, the process of deciding
whether to allow an entity access to, or to perform operations upon, other
entities is outside the scope of Zend\Authentication. For more information
about authorization and access control with Zend Framework, please see the
Zend\Permissions\Acl or Zend\Permissions\Rbac component.

Alternatives

Package Version Architecture Repository
php-ZendFramework2-Authentication-2.4.11-1.mga5.noarch.rpm 2.4.11 noarch Mageia Core Updates
php-ZendFramework2-Authentication-2.4.11-1.mga5.noarch.rpm 2.4.11 noarch Mageia Core Updates
php-ZendFramework2-Authentication-2.4.9-1.mga5.noarch.rpm 2.4.9 noarch Mageia Core Updates
php-ZendFramework2-Authentication-2.4.9-1.mga5.noarch.rpm 2.4.9 noarch Mageia Core Updates
php-ZendFramework2-Authentication-2.4.8-1.mga5.noarch.rpm 2.4.8 noarch Mageia Core Updates
php-ZendFramework2-Authentication-2.4.8-1.mga5.noarch.rpm 2.4.8 noarch Mageia Core Updates
php-ZendFramework2-Authentication-2.4.7-1.mga5.noarch.rpm 2.4.7 noarch Mageia Core Updates
php-ZendFramework2-Authentication-2.4.7-1.mga5.noarch.rpm 2.4.7 noarch Mageia Core Updates
php-ZendFramework2-Authentication-2.3.9-1.mga5.noarch.rpm 2.3.9 noarch Mageia Core
php-ZendFramework2-Authentication - - -

Requires

Name Value
php-ZendFramework2 == 2.3.9-1.mga5
php-ctype -
php-hash -
php-pcre -

Provides

Name Value
php-ZendFramework2-Authentication == 2.3.9-1.mga5

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package php-ZendFramework2-Authentication-2.3.9-1.mga5.noarch.rpm
Source Package php-ZendFramework2-2.3.9-1.mga5.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install php-ZendFramework2-Authentication rpm package:
    # urpmi php-ZendFramework2-Authentication

Files

Path
/usr/share/doc/php-ZendFramework2-Authentication/CONTRIBUTING.md
/usr/share/doc/php-ZendFramework2-Authentication/README.md
/usr/share/doc/php-ZendFramework2-Authentication/composer.json
/usr/share/php/Zend/Authentication/AuthenticationService.php
/usr/share/php/Zend/Authentication/AuthenticationServiceInterface.php
/usr/share/php/Zend/Authentication/Result.php
/usr/share/php/Zend/Authentication/Adapter/AbstractAdapter.php
/usr/share/php/Zend/Authentication/Adapter/AdapterInterface.php
/usr/share/php/Zend/Authentication/Adapter/DbTable.php
/usr/share/php/Zend/Authentication/Adapter/Digest.php
/usr/share/php/Zend/Authentication/Adapter/Http.php
/usr/share/php/Zend/Authentication/Adapter/Ldap.php
/usr/share/php/Zend/Authentication/Adapter/ValidatableAdapterInterface.php
/usr/share/php/Zend/Authentication/Adapter/DbTable/AbstractAdapter.php
/usr/share/php/Zend/Authentication/Adapter/DbTable/CallbackCheckAdapter.php
/usr/share/php/Zend/Authentication/Adapter/DbTable/CredentialTreatmentAdapter.php
/usr/share/php/Zend/Authentication/Adapter/DbTable/Exception/ExceptionInterface.php
/usr/share/php/Zend/Authentication/Adapter/DbTable/Exception/InvalidArgumentException.php
/usr/share/php/Zend/Authentication/Adapter/DbTable/Exception/RuntimeException.php
/usr/share/php/Zend/Authentication/Adapter/Exception/ExceptionInterface.php
/usr/share/php/Zend/Authentication/Adapter/Exception/InvalidArgumentException.php
/usr/share/php/Zend/Authentication/Adapter/Exception/RuntimeException.php
/usr/share/php/Zend/Authentication/Adapter/Exception/UnexpectedValueException.php
/usr/share/php/Zend/Authentication/Adapter/Http/ApacheResolver.php
/usr/share/php/Zend/Authentication/Adapter/Http/FileResolver.php
/usr/share/php/Zend/Authentication/Adapter/Http/ResolverInterface.php
/usr/share/php/Zend/Authentication/Adapter/Http/Exception/ExceptionInterface.php
/usr/share/php/Zend/Authentication/Adapter/Http/Exception/InvalidArgumentException.php
/usr/share/php/Zend/Authentication/Adapter/Http/Exception/RuntimeException.php
/usr/share/php/Zend/Authentication/Exception/ExceptionInterface.php
/usr/share/php/Zend/Authentication/Exception/InvalidArgumentException.php
/usr/share/php/Zend/Authentication/Exception/RuntimeException.php
/usr/share/php/Zend/Authentication/Exception/UnexpectedValueException.php
/usr/share/php/Zend/Authentication/Storage/Chain.php
/usr/share/php/Zend/Authentication/Storage/NonPersistent.php
/usr/share/php/Zend/Authentication/Storage/Session.php
/usr/share/php/Zend/Authentication/Storage/StorageInterface.php
/usr/share/php/Zend/Authentication/Validator/Authentication.php

Changelog

2015-05-21 - luigiwalser <luigiwalser> 2.3.9-1.mga5
+ Revision: 822472
- 2.3.9 (fixes CVE-2015-3154)
2015-03-20 - guillomovitch <guillomovitch> 2.3.7-1.mga5
+ Revision: 819057
- new version 2.3.7
2015-03-03 - oden <oden> 2.3.5-1.mga5
+ Revision: 817389
- 2.3.5 (ZF2015-02)
2015-01-31 - guillomovitch <guillomovitch> 2.3.4-1.mga5
+ Revision: 812853
- new version 2.3.4
2014-10-21 - guillomovitch <guillomovitch> 2.3.3-3.mga5
+ Revision: 792348
- fix dependencies
2014-10-15 - umeabot <umeabot> 2.3.3-2.mga5
+ Revision: 739704
- Second Mageia 5 Mass Rebuild
2014-10-07 - guillomovitch <guillomovitch> 2.3.3-1.mga5
+ Revision: 737403
- imported package php-ZendFramework2

See Also

Package Description
php-ZendFramework2-Barcode-2.3.9-1.mga5.noarch.rpm Zend Framework 2: Barcode Component
php-ZendFramework2-Cache-2.3.9-1.mga5.noarch.rpm Zend Framework 2: Cache Component
php-ZendFramework2-Captcha-2.3.9-1.mga5.noarch.rpm Zend Framework 2: CAPTCHA Component
php-ZendFramework2-Code-2.3.9-1.mga5.noarch.rpm Zend Framework 2: Code Component
php-ZendFramework2-Config-2.3.9-1.mga5.noarch.rpm Zend Framework 2: Config Component
php-ZendFramework2-Console-2.3.9-1.mga5.noarch.rpm Zend Framework 2: Console Component
php-ZendFramework2-Crypt-2.3.9-1.mga5.noarch.rpm Zend Framework 2: Crypt Component
php-ZendFramework2-Db-2.3.9-1.mga5.noarch.rpm Zend Framework 2: DB Component
php-ZendFramework2-Debug-2.3.9-1.mga5.noarch.rpm Zend Framework 2: Debug Component
php-ZendFramework2-Di-2.3.9-1.mga5.noarch.rpm Zend Framework 2: DI Component
php-ZendFramework2-Dom-2.3.9-1.mga5.noarch.rpm Zend Framework 2: DOM Component
php-ZendFramework2-Escaper-2.3.9-1.mga5.noarch.rpm Zend Framework 2: Escaper Component
php-ZendFramework2-EventManager-2.3.9-1.mga5.noarch.rpm Zend Framework 2: EventManager Component
php-ZendFramework2-Feed-2.3.9-1.mga5.noarch.rpm Zend Framework 2: Feed Component
php-ZendFramework2-File-2.3.9-1.mga5.noarch.rpm Zend Framework 2: File Component
Advertisement
Advertisement