emacs-24.3-10.1.mga5.i586.rpm


Advertisement

Description

emacs - GNU Emacs text editor with X11 support

Property Value
Distribution Mageia 5.1
Repository Mageia Core Updates i586
Package filename emacs-24.3-10.1.mga5.i586.rpm
Package name emacs
Package version 24.3
Package release 10.1.mga5
Package architecture i586
Package type rpm
Category Editors
Homepage http://www.gnu.org/software/emacs/
License GPLv3+
Maintainer -
Download size 2.37 MB
Installed size 8.27 MB
Emacs is a powerful, customizable, self-documenting, modeless text
editor. Emacs contains special code editing features, a scripting
language (elisp), and the capability to read mail, news, and more
without leaving the editor.
This package provides an emacs binary with support for X Windows.

Alternatives

Package Version Architecture Repository
emacs-24.3-10.1.mga5.x86_64.rpm 24.3 x86_64 Mageia Core Updates
emacs-24.3-10.mga5.i586.rpm 24.3 i586 Mageia Core
emacs-24.3-10.mga5.x86_64.rpm 24.3 x86_64 Mageia Core
emacs - - -

Requires

Name Value
emacs-common == 24.3
libMagickCore-6.Q16.so.2 -
libMagickWand-6.Q16.so.2 -
libX11.so.6 -
libXft.so.2 -
libXpm.so.4 -
libXrender.so.1 -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.11) -
libc.so.6(GLIBC_2.15) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.2.1) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.6) -
libcairo.so.2 -
libdbus-1.so.3 -
libfontconfig.so.1 -
libfreetype.so.6 -
libgdk-3.so.0 -
libgdk_pixbuf-2.0.so.0 -
libgif.so.4 -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgnutls.so.28 -
libgnutls.so.28(GNUTLS_1_4) -
libgobject-2.0.so.0 -
libgpm.so.2 -
libgtk-3.so.0 -
libjpeg.so.8 -
libjpeg.so.8(LIBJPEG_8.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm17n-core.so.0 -
libm17n-flt.so.0 -
libotf.so.0 -
libpango-1.0.so.0 -
libpng16.so.16 -
libpng16.so.16(PNG16_0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.2) -
librsvg-2.so.2 -
librt.so.1 -
librt.so.1(GLIBC_2.2) -
libtiff.so.5 -
libtiff.so.5(LIBTIFF_4.0) -
libtinfo.so.5 -
libxml2.so.2 -
libxml2.so.2(LIBXML2_2.4.30) -
libxml2.so.2(LIBXML2_2.6.0) -
update-alternatives -

Provides

Name Value
application() -
application(emacs.desktop) -
emacs == 24.3-10.1.mga5
emacs(x86-32) == 24.3-10.1.mga5
emacs-X11 < 22.0.50
emacs-bin -
emacs-gtk -
mimehandler(application/x-shellscript) -
mimehandler(text/english) -
mimehandler(text/plain) -
mimehandler(text/x-c) -
mimehandler(text/x-c++) -
mimehandler(text/x-c++hdr) -
mimehandler(text/x-c++src) -
mimehandler(text/x-chdr) -
mimehandler(text/x-csrc) -
mimehandler(text/x-java) -
mimehandler(text/x-makefile) -
mimehandler(text/x-moc) -
mimehandler(text/x-pascal) -
mimehandler(text/x-tcl) -
mimehandler(text/x-tex) -

Conflicts

Name Value
emacs-snapshot < 24.3-10.1.mga5

Obsoletes

Name Value
emacs-X11 < 22.0.50
emacs-gtk <= 22.3

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package emacs-24.3-10.1.mga5.i586.rpm
Source Package emacs-24.3-10.1.mga5.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install emacs rpm package:
    # urpmi emacs

Files

Path
/usr/bin/emacs-24.3
/usr/share/applications/emacs.desktop
/usr/share/doc/emacs/COPYING
/usr/share/icons/hicolor/128x128/apps/emacs.png
/usr/share/icons/hicolor/16x16/apps/emacs.png
/usr/share/icons/hicolor/24x24/apps/emacs.png
/usr/share/icons/hicolor/32x32/apps/emacs.png
/usr/share/icons/hicolor/48x48/apps/emacs.png
/usr/share/icons/hicolor/scalable/apps/emacs.svg
/usr/share/icons/hicolor/scalable/mimetypes/emacs-document.svg

Changelog

2017-12-28 - luigiwalser <luigiwalser> 24.3-10.1.mga5
+ Revision: 1186819
- add patch from debian to fix CVE-2017-14482

See Also

Package Description
emacs-common-24.3-10.1.mga5.i586.rpm Common files for GNU Emacs
emacs-doc-24.3-10.1.mga5.noarch.rpm GNU Emacs documentation
emacs-el-24.3-10.1.mga5.noarch.rpm GNU Emacs Lisp source files
emacs-leim-24.3-10.1.mga5.noarch.rpm GNU Emacs Lisp code for international input methods
emacs-nox-24.3-10.1.mga5.i586.rpm GNU Emacs text editor without support for X11
emacs-puppet-3.6.2-3.1.mga5.noarch.rpm Syntax highlighting for puppet manifests in emacs
emacs-puppet-3.6.2-3.3.mga5.noarch.rpm Syntax highlighting for puppet manifests in emacs
encfs-1.7.5-1.mga5.i586.rpm Encrypted pass-through filesystem for Linux
eog-3.14.3-1.1.mga5.i586.rpm The Eye of GNOME image viewer
eog-3.14.3-1.2.mga5.i586.rpm The Eye of GNOME image viewer
eog-devel-3.14.3-1.1.mga5.i586.rpm C headers needed to build EOG plugins
eog-devel-3.14.3-1.2.mga5.i586.rpm C headers needed to build EOG plugins
eom-1.8.1-2.1.mga5.i586.rpm Eye of MATE image viewer
eom-devel-1.8.1-2.1.mga5.i586.rpm C headers needed to build EOM plugins
ettercap-0.8.2-1.1.mga5.i586.rpm Ncurses/Gtk2 based sniffer/interceptor utility
Advertisement
Advertisement