libqt5gui5-5.4.2-1.1.mga5.i586.rpm


Advertisement

Description

libqt5gui5 - Qt5 Component Library

Property Value
Distribution Mageia 5.1
Repository Mageia Core Updates i586
Package name libqt5gui5
Package version 5.4.2
Package release 1.1.mga5
Package architecture i586
Package type rpm
Installed size 14.17 MB
Download size 4.03 MB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Qt5 Component Library.
The QtGui module extends QtCore with GUI functionality.

Alternatives

Package Version Architecture Repository
libqt5gui5-5.4.0-7.mga5.i586.rpm 5.4.0 i586 Mageia Core
libqt5gui5 - - -

Requires

Name Value
libEGL.so.1 -
libGL.so.1 -
libQt5Core.so.5 -
libQt5DBus.so.5 -
libQt5Gui.so.5 -
libX11-xcb.so.1 -
libX11.so.6 -
libXi.so.6 -
libXrender.so.1 -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.11) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libdirectfb-1.7.so.5 -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libdrm.so.2 -
libfontconfig.so.1 -
libfreetype.so.6 -
libgbm.so.1 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.4) -
libgcc_s.so.1(GLIBC_2.0) -
libgdk-x11-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libgtk-x11-2.0.so.0 -
libjpeg.so.8 -
libjpeg.so.8(LIBJPEG_8.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libpango-1.0.so.0 -
libpng16.so.16 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.2) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
libudev.so.1 -
libudev.so.1(LIBUDEV_183) -
libxcb-glx.so.0 -
libxcb-icccm.so.4 -
libxcb-image.so.0 -
libxcb-keysyms.so.1 -
libxcb-randr.so.0 -
libxcb-render-util.so.0 -
libxcb-render.so.0 -
libxcb-shape.so.0 -
libxcb-shm.so.0 -
libxcb-sync.so.1 -
libxcb-xfixes.so.0 -
libxcb-xkb.so.1 -
libxcb.so.1 -
libxkbcommon-x11.so.0 -
libxkbcommon.so.0 -
libz.so.1 -
qtbase5-common == 5.4.2

Provides

Name Value
libQt5Gui.so.5 -
libcomposeplatforminputcontextplugin.so -
libibusplatforminputcontextplugin.so -
libqdirectfb.so -
libqeglfs.so -
libqgif.so -
libqgtk2.so -
libqico.so -
libqjpeg.so -
libqkms.so -
libqlinuxfb.so -
libqminimal.so -
libqminimalegl.so -
libqoffscreen.so -
libqt5gui5 == 5.4.2-1.1.mga5
libqt5gui5(x86-32) == 5.4.2-1.1.mga5
libqxcb.so -

Download

Type URL
Binary Package libqt5gui5-5.4.2-1.1.mga5.i586.rpm
Source Package qtbase5-5.4.2-1.1.mga5.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libqt5gui5 rpm package:
    # urpmi libqt5gui5

Files

Path
/usr/lib/libQt5Gui.so.5
/usr/lib/libQt5Gui.so.5.4
/usr/lib/libQt5Gui.so.5.4.2
/usr/lib/qt5/plugins/imageformats/libqgif.so
/usr/lib/qt5/plugins/imageformats/libqico.so
/usr/lib/qt5/plugins/imageformats/libqjpeg.so
/usr/lib/qt5/plugins/platforminputcontexts/libcomposeplatforminputcontextplugin.so
/usr/lib/qt5/plugins/platforminputcontexts/libibusplatforminputcontextplugin.so
/usr/lib/qt5/plugins/platforms/libqdirectfb.so
/usr/lib/qt5/plugins/platforms/libqeglfs.so
/usr/lib/qt5/plugins/platforms/libqkms.so
/usr/lib/qt5/plugins/platforms/libqlinuxfb.so
/usr/lib/qt5/plugins/platforms/libqminimal.so
/usr/lib/qt5/plugins/platforms/libqminimalegl.so
/usr/lib/qt5/plugins/platforms/libqoffscreen.so
/usr/lib/qt5/plugins/platforms/libqxcb.so
/usr/lib/qt5/plugins/platformthemes/libqgtk2.so
/usr/lib/sse2/libQt5Gui.so.5
/usr/lib/sse2/libQt5Gui.so.5.4
/usr/lib/sse2/libQt5Gui.so.5.4.2

Changelog

2015-12-02 - filipesaraiva <filipesaraiva> 5.4.2-1.1.mga5
+ Revision: 907652
- Add subrel;
- Update to Qt 5.4.2;
- Fix URL to new address qt.io;
- Remove applied patches in upstream;
2015-04-22 - luigiwalser <luigiwalser> 5.4.0-7.mga5
+ Revision: 820558
- add patches from fedora to fix CVE-2015-1858, CVE-2015-1859, and CVE-2015-1860
2015-02-28 - lmenut <lmenut> 5.4.0-6.mga5
+ Revision: 817205
- add upstream patch to fix DoS vulnerability in the BMP image handler
(CVE-2015-0295) mga#15383
2015-02-08 - doktor5000 <doktor5000> 5.4.0-5.mga5
+ Revision: 814176
- added upstream patch to fix broken drag&drop for 5.4.0 (QTBUG-43436)
2015-01-06 - cjw <cjw> 5.4.0-4.mga5
+ Revision: 808796
- sync csh profile script with sh profile script and add needed escape chars (mga #12826)
2014-12-27 - neoclust <neoclust> 5.4.0-3.mga5
+ Revision: 806365
- Add csh/tcsh profile support mga #12826
2014-12-23 - neoclust <neoclust> 5.4.0-2.mga5
+ Revision: 805003
- Fix Requires for translations Mga#13993 #14746
2014-12-11 - neoclust <neoclust> 5.4.0-1.mga5
+ Revision: 802720
- New version 5.4.0
2014-12-07 - neoclust <neoclust> 5.3.2-7.mga5
+ Revision: 802011
- New version 5.3.2
2014-11-29 - doktor5000 <doktor5000> 5.3.1-7.mga5
+ Revision: 799847
- disable SSE2 on %ix86 otherwise QT crashes on processors without SSE2
o fixes (mga#13991), (mga#14229), (mga#14418), (mga#14491)
- provide SSE2-enabled library in separate subdir as recommended by upstream
o SSE2 library located in %{_qt5_libdir}/sse2/

See Also

Package Description
libqt5help-devel-5.4.2-1.mga5.i586.rpm Devel files needed to build apps based on QtJsonDbCompat
libqt5help-private-devel-5.4.2-1.mga5.i586.rpm Devel files needed to build apps based on QtJsonDbCompat
libqt5imageformats-devel-5.4.2-1.mga5.i586.rpm Devel files needed to build apps based on QtImageFormats
libqt5location-devel-5.4.2-1.mga5.i586.rpm Devel files needed to build apps based on QtLocation
libqt5location-private-devel-5.4.2-1.mga5.i586.rpm Devel files needed to build apps based on QtLocation
libqt5location5-5.4.2-1.mga5.i586.rpm Qt5 Component Library
libqt5multimedia-devel-5.4.2-1.mga5.i586.rpm Devel files needed to build apps based on QtVersit
libqt5multimedia-private-devel-5.4.2-1.mga5.i586.rpm Devel files needed to build apps based on QtVersit
libqt5multimedia5-5.4.2-1.mga5.i586.rpm Qt5 Lib
libqt5multimediawidgets-devel-5.4.2-1.mga5.i586.rpm Devel files needed to build apps based on QtVersit
libqt5multimediawidgets-private-devel-5.4.2-1.mga5.i586.rpm Devel files needed to build apps based on QtVersit
libqt5multimediawidgets5-5.4.2-1.mga5.i586.rpm Qt5 Lib
libqt5network-devel-5.4.2-1.1.mga5.i586.rpm Devel files needed to build apps based on QtNetwork
libqt5network-private-devel-5.4.2-1.1.mga5.i586.rpm Devel files needed to build apps based on QtNetwork
libqt5network5-5.4.2-1.1.mga5.i586.rpm Qt5 Component Library
Advertisement
Advertisement