lib64nm-glib-vpn-devel-1.0.12-1.1.mga5.x86_64.rpm


Advertisement

Description

lib64nm-glib-vpn-devel - Development files for nm-glib-vpn

Property Value
Distribution Mageia 5.1
Repository Mageia Core Updates x86_64
Package filename lib64nm-glib-vpn-devel-1.0.12-1.1.mga5.x86_64.rpm
Package name lib64nm-glib-vpn-devel
Package version 1.0.12
Package release 1.1.mga5
Package architecture x86_64
Package type rpm
Category Development/C
Homepage https://wiki.gnome.org/Projects/NetworkManager
License GPLv2+
Maintainer -
Download size 14.89 KB
Installed size 22.00 KB
Development files for nm-glib-vpn.

Alternatives

Package Version Architecture Repository
lib64nm-glib-vpn-devel-1.0.2-2.mga5.x86_64.rpm 1.0.2 x86_64 Mageia Core
lib64nm-glib-vpn-devel - - -

Requires

Name Value
devel(libdbus-glib-1(64bit)) -
devel(libglib-2.0(64bit)) -
devel(libgobject-2.0(64bit)) -
devel(libnm-util(64bit)) -
lib64nm-glib-vpn1 == 1.0.12-1.1.mga5
pkgconfig -
pkgconfig(NetworkManager) >= 1.0.12
pkgconfig(dbus-glib-1) -
pkgconfig(glib-2.0) -

Provides

Name Value
devel(libnm-glib-vpn(64bit)) -
lib64nm-glib-vpn-devel == 1.0.12-1.1.mga5
lib64nm-glib-vpn-devel(x86-64) == 1.0.12-1.1.mga5
libnm-glib-vpn-devel == 1.0.12-1.1.mga5
pkgconfig(libnm-glib-vpn) == 1.0.12

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64nm-glib-vpn-devel-1.0.12-1.1.mga5.x86_64.rpm
Source Package networkmanager-1.0.12-1.1.mga5.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64nm-glib-vpn-devel rpm package:
    # urpmi lib64nm-glib-vpn-devel

Files

Path
/usr/include/libnm-glib/nm-vpn-connection.h
/usr/include/libnm-glib/nm-vpn-enum-types.h
/usr/include/libnm-glib/nm-vpn-plugin-ui-interface.h
/usr/include/libnm-glib/nm-vpn-plugin-utils.h
/usr/include/libnm-glib/nm-vpn-plugin.h
/usr/lib64/libnm-glib-vpn.so
/usr/lib64/pkgconfig/libnm-glib-vpn.pc

Changelog

2016-05-05 - daviddavid <daviddavid> 1.0.12-1.1.mga5
+ Revision: 1009643
- add an upstream patch to fix some wireless regresses
* wifi: hack for wext devices reporting IW_MODE_AUTO configuration mode
- new version: 1.0.12 fixes CVE-2016-0764 (mga#18125)
2015-05-11 - tmb <tmb> 1.0.2-2.mga5
+ Revision: 821736
- submit to release
2015-05-06 - shlomif <shlomif> 1.0.2-1.mga5
+ Revision: 821350
- New version 1.0.2 with fixes to MGA#15862 .
2015-02-19 - ovitters <ovitters> 1.0.0-4.mga5
+ Revision: 815854
- enable libteam support
- update description as it can now be used on servers as well
2015-02-06 - ovitters <ovitters> 1.0.0-3.mga5
+ Revision: 813707
- add tui (text user interface) and recommend it
- enable concheck
- also recommend networkmanager-openswan
- improve text in the urpmi upgrade message
2015-02-06 - ovitters <ovitters> 1.0.0-2.mga5
+ Revision: 813644
- recommend the networkmanager VPN packages l2tp,openconnect,openvpn,pptp,vpnc
2015-01-29 - colin <colin> 1.0.0-1.mga5
+ Revision: 812687
- New version: 1.0.0
- Rediffed patches (MAC address discovery patch was broken for a year)
- Be more explicit with configure args (we may want to enable tui)
- Add new sub-packages for new libraries
2014-10-15 - umeabot <umeabot> 0.9.10.0-7.mga5
+ Revision: 750830
- Second Mageia 5 Mass Rebuild
2014-09-26 - wally <wally> 0.9.10.0-6.mga5
+ Revision: 724948
- rebuild with new rpm-mageia-setup to generate requires for .typelib files
2014-09-16 - umeabot <umeabot> 0.9.10.0-5.mga5
+ Revision: 682866
- Mageia 5 Mass Rebuild
+ tv <tv>
- use %global for req/prov exclude
- autoconvert to new prov/req excludes

See Also

Package Description
lib64nm-glib-vpn1-1.0.12-1.1.mga5.x86_64.rpm Shared library for nm-glib-vpn
lib64nm-glib4-1.0.12-1.1.mga5.x86_64.rpm Shared library for nm_glib
lib64nm-util-devel-1.0.12-1.1.mga5.x86_64.rpm Development files for nm_util
lib64nm-util2-1.0.12-1.1.mga5.x86_64.rpm Shared library for nm_util
lib64nm0-1.0.12-1.1.mga5.x86_64.rpm Shared library for nm
lib64nmclient-gir1.0-1.0.12-1.1.mga5.x86_64.rpm GObject Introspection interface library for nm_glib
lib64noteshared4-4.14.10-1.3.mga5.x86_64.rpm Library providing grantlee theme editor support
lib64nspr-devel-4.10.10-1.mga5.x86_64.rpm Development libraries for the Netscape Portable Runtime
lib64nspr-devel-4.10.9-1.mga5.x86_64.rpm Development libraries for the Netscape Portable Runtime
lib64nspr-devel-4.11-1.mga5.x86_64.rpm Development libraries for the Netscape Portable Runtime
lib64nspr-devel-4.12-1.mga5.x86_64.rpm Development libraries for the Netscape Portable Runtime
lib64nspr-devel-4.13.1-1.mga5.x86_64.rpm Development libraries for the Netscape Portable Runtime
lib64nspr-devel-4.14-1.mga5.x86_64.rpm Development libraries for the Netscape Portable Runtime
lib64nspr-devel-4.15-1.mga5.x86_64.rpm Development libraries for the Netscape Portable Runtime
lib64nspr-devel-4.16-1.mga5.x86_64.rpm Development libraries for the Netscape Portable Runtime
Advertisement
Advertisement