ruby-devel-2.0.0.p648-1.5.mga5.x86_64.rpm


Advertisement

Description

ruby-devel - Development file for the powerful language Ruby

Property Value
Distribution Mageia 5.1
Repository Mageia Core Updates x86_64
Package name ruby-devel
Package version 2.0.0.p648
Package release 1.5.mga5
Package architecture x86_64
Package type rpm
Installed size 16.98 MB
Download size 2.81 MB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Ruby is the interpreted scripting language for quick and
easy object-oriented programming.  It has many features to
process text files and to do system management tasks (as in
Perl). It is simple, straight-forward, and extensible.
This package contains the Ruby's devel files.

Alternatives

Package Version Architecture Repository
ruby-devel-2.0.0.p648-1.6.mga5.x86_64.rpm 2.0.0.p648 x86_64 Mageia Core Updates
ruby-devel-2.0.0.p648-1.6.mga5.i586.rpm 2.0.0.p648 i586 Mageia Core Updates
ruby-devel-2.0.0.p648-1.5.mga5.i586.rpm 2.0.0.p648 i586 Mageia Core Updates
ruby-devel-2.0.0.p648-1.4.mga5.x86_64.rpm 2.0.0.p648 x86_64 Mageia Core Updates
ruby-devel-2.0.0.p648-1.4.mga5.i586.rpm 2.0.0.p648 i586 Mageia Core Updates
ruby-devel-2.0.0.p648-1.1.mga5.i586.rpm 2.0.0.p648 i586 Mageia Core Updates
ruby-devel-2.0.0.p648-1.1.mga5.x86_64.rpm 2.0.0.p648 x86_64 Mageia Core Updates
ruby-devel-2.0.0.p648-1.mga5.i586.rpm 2.0.0.p648 i586 Mageia Core Updates
ruby-devel-2.0.0.p648-1.mga5.x86_64.rpm 2.0.0.p648 x86_64 Mageia Core Updates
ruby-devel-2.0.0.p645-1.mga5.i586.rpm 2.0.0.p645 i586 Mageia Core
ruby-devel-2.0.0.p645-1.mga5.x86_64.rpm 2.0.0.p645 x86_64 Mageia Core
ruby-devel - - -

Requires

Name Value
devel(libcrypt(64bit)) -
devel(libdl(64bit)) -
devel(libm(64bit)) -
lib64ruby2.0 == 2.0.0.p648
pkgconfig -
ruby == 2.0.0.p648

Provides

Name Value
devel(libruby(64bit)) -
pkgconfig(ruby) == 2.0.0
ruby-devel == 2.0.0.p648-1.5.mga5
ruby-devel(x86-64) == 2.0.0.p648-1.5.mga5

Download

Type URL
Binary Package ruby-devel-2.0.0.p648-1.5.mga5.x86_64.rpm
Source Package ruby-2.0.0.p648-1.5.mga5.src.rpm

Install Howto

  1. Enable Mageia Core Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install ruby-devel rpm package:
    # urpmi ruby-devel

Files

Path
/usr/include/ruby.h
/usr/include/ruby/debug.h
/usr/include/ruby/defines.h
/usr/include/ruby/digest.h
/usr/include/ruby/dl.h
/usr/include/ruby/encoding.h
/usr/include/ruby/intern.h
/usr/include/ruby/io.h
/usr/include/ruby/missing.h
/usr/include/ruby/oniguruma.h
/usr/include/ruby/re.h
/usr/include/ruby/regex.h
/usr/include/ruby/ruby.h
/usr/include/ruby/st.h
/usr/include/ruby/subst.h
/usr/include/ruby/thread.h
/usr/include/ruby/util.h
/usr/include/ruby/version.h
/usr/include/ruby/vm.h
/usr/include/ruby/backward/classext.h
/usr/include/ruby/backward/rubyio.h
/usr/include/ruby/backward/rubysig.h
/usr/include/ruby/backward/st.h
/usr/include/ruby/backward/util.h
/usr/include/x86_64-linux/
/usr/include/x86_64-linux/ruby/config.h
/usr/lib64/libruby-static.a
/usr/lib64/libruby.so
/usr/lib64/pkgconfig/ruby.pc

Changelog

See ruby-2.0.0.p648-1.5.mga5.x86_64.rpm changelog.

See Also

Package Description
ruby-doc-2.0.0.p648-1.1.mga5.noarch.rpm Documentation for the powerful language Ruby
ruby-doc-2.0.0.p648-1.4.mga5.noarch.rpm Documentation for the powerful language Ruby
ruby-doc-2.0.0.p648-1.5.mga5.noarch.rpm Documentation for the powerful language Ruby
ruby-doc-2.0.0.p648-1.6.mga5.noarch.rpm Documentation for the powerful language Ruby
ruby-doc-2.0.0.p648-1.mga5.noarch.rpm Documentation for the powerful language Ruby
ruby-eventmachine-1.0.3-3.1.mga5.x86_64.rpm Ruby/EventMachine library
ruby-eventmachine-doc-1.0.3-3.1.mga5.noarch.rpm Documentation for ruby-eventmachine
ruby-graphviz-2.38.0-10.1.mga5.x86_64.rpm Graphviz bindings for ruby
ruby-irb-2.0.0.p648-1.1.mga5.noarch.rpm The Interactive Ruby
ruby-irb-2.0.0.p648-1.4.mga5.noarch.rpm The Interactive Ruby
ruby-irb-2.0.0.p648-1.5.mga5.noarch.rpm The Interactive Ruby
ruby-irb-2.0.0.p648-1.6.mga5.noarch.rpm The Interactive Ruby
ruby-irb-2.0.0.p648-1.mga5.noarch.rpm The Interactive Ruby
ruby-json-1.8.1-3.1.mga5.x86_64.rpm JSON Implementation for Ruby
ruby-json-doc-1.8.1-3.1.mga5.noarch.rpm Documentation for ruby-json
Advertisement
Advertisement