nvidia-current-cuda-opencl-375.66-1.mga5.nonfree.x86_64.rpm


Advertisement

Description

nvidia-current-cuda-opencl - CUDA and OpenCL libraries for NVIDIA proprietary driver

Distribution: Mageia 5.1
Repository: Mageia Nonfree Updates x86_64
Package name: nvidia-current-cuda-opencl
Package version: 375.66
Package release: 1.mga5.nonfree
Package architecture: x86_64
Package type: rpm
Installed size: 129.26 MB
Download size: 29.32 MB
Official Mirror: distrib-coffee.ipsl.jussieu.fr
Cuda and OpenCL libraries for NVIDIA proprietary driver. This package is not required for normal use, it provides libraries to use NVIDIA cards for High Performance Computing (HPC).

Alternatives

Provides

  • nvidia-current-cuda == 375.66-1.mga5.nonfree
  • nvidia-current-cuda-opencl == 375.66-1.mga5.nonfree
  • nvidia-current-cuda-opencl(x86-64) == 375.66-1.mga5.nonfree

Conflicts

  • nvidia < 1:195.36.15-4
  • x11-driver-video-nvidia-current <= 295.59-1

    Install Howto

    1. Enable Mageia Nonfree Updates repository on "Install and Remove Software"
    2. Update packages list:
      # urpmi.update -a
    3. Install nvidia-current-cuda-opencl rpm package:
      # urpmi nvidia-current-cuda-opencl

    Files

    • /usr/lib/nvidia-current/libOpenCL.so.1
    • /usr/lib/nvidia-current/libOpenCL.so.1.0
    • /usr/lib/nvidia-current/libOpenCL.so.1.0.0
    • /usr/lib/nvidia-current/libcuda.so.1
    • /usr/lib/nvidia-current/libcuda.so.375.66
    • /usr/lib/nvidia-current/libnvcuvid.so.1
    • /usr/lib/nvidia-current/libnvcuvid.so.375.66
    • /usr/lib/nvidia-current/libnvidia-compiler.so.375.66
    • /usr/lib/nvidia-current/libnvidia-encode.so.1
    • /usr/lib/nvidia-current/libnvidia-encode.so.375.66
    • /usr/lib/nvidia-current/libnvidia-opencl.so.1
    • /usr/lib/nvidia-current/libnvidia-opencl.so.375.66
    • /usr/lib64/nvidia-current/libOpenCL.so.1
    • /usr/lib64/nvidia-current/libOpenCL.so.1.0
    • /usr/lib64/nvidia-current/libOpenCL.so.1.0.0
    • /usr/lib64/nvidia-current/libcuda.so.1
    • /usr/lib64/nvidia-current/libcuda.so.375.66
    • /usr/lib64/nvidia-current/libnvcuvid.so.1
    • /usr/lib64/nvidia-current/libnvcuvid.so.375.66
    • /usr/lib64/nvidia-current/libnvidia-compiler.so.375.66
    • /usr/lib64/nvidia-current/libnvidia-encode.so.1
    • /usr/lib64/nvidia-current/libnvidia-encode.so.375.66
    • /usr/lib64/nvidia-current/libnvidia-opencl.so.1
    • /usr/lib64/nvidia-current/libnvidia-opencl.so.375.66

    Changelog

    2017-07-05 - tmb <tmb> 375.66-1.mga5 + Revision: 1109051 - update to 375.66 - sync with cauldron 375.39-6 - update to 375.26 - remove usage of kernel internal-only phys_to_dma() usage (mga#17604) - update to 352.79 - update to 352.63 - update to 346.96 (CVE-2015-5950) - update to 346.82 (new hw support) - revert 352 branch update, needs more upgraded libs - update to 352.21 (new long lived branch, new hw support)

    2015-05-22 - tmb <tmb> 346.72-1.mga5.nonfree + Revision: 822600 - 346.72 (maintenance/bugfix release)

    2015-04-12 - tmb <tmb> 346.59-1.mga5.nonfree + Revision: 820081 - update to 346.59 -longterm

    2015-02-26 - tmb <tmb> 346.47-1.mga5.nonfree + Revision: 817094 - update to 346.47 (maintenance release)

    2015-02-04 - tmb <tmb> 346.35-5.mga5.nonfree + Revision: 813329 - fix drm trace in logs (dropped by mistake in 346.35 update)

    2015-01-26 - tmb <tmb> 346.35-4.mga5.nonfree + Revision: 812400 - fix broken dkms.conf

    2015-01-26 - tmb <tmb> 346.35-3.mga5.nonfree + Revision: 812394 - uvm module is available only on x86_64

    2015-01-26 - anssi <anssi> 346.35-2.mga5.nonfree + Revision: 812377 - fix libnvidia-gtk*.so* name not matching their SONAME, causing nvidia-settings to fail to load

    2015-01-26 - anssi <anssi> 346.35-1.mga5.nonfree + Revision: 812247 - remove extra unneeded __provides_exclude_from added in auto-conversion - add backward-compatibility definitions for dependency exclusions - alternativeszificate /usr/share/nvidia as there are now unversioned files in there - use the self-built versions of libnvidia-gtk*.so - adapt simple mode pcitable generation for new version and new ldetect-lst - update cards definition as support was dropped for some cards + tmb <tmb> - handle OPENCL_* and XORG_OUTPUTCLASS_CONFIG in manifest - build gtk+3 UI too - BR: vdpau-devel >= 0.9 - update to 346.35 (new Long Lived branch)

    2014-12-19 - tmb <tmb> 340.65-3.mga5.nonfree + Revision: 804238 - really fix drm trace with kernel 3.18 (mga#14769, mga#14832)

    Advertisement
    Advertisement