lib64php_common7-7.2.20-1.mga6.x86_64.rpm


Advertisement

Description

lib64php_common7 - Shared library for PHP

Property Value
Distribution Mageia 6.1
Repository Mageia Core Backports x86_64
Package filename lib64php_common7-7.2.20-1.mga6.x86_64.rpm
Package name lib64php_common7
Package version 7.2.20
Package release 1.mga6
Package architecture x86_64
Package type rpm
Category Development/PHP
Homepage http://www.php.net
License PHP License
Maintainer -
Download size 1.34 MB
Installed size 5.35 MB
This package provides the common files to run with different implementations of
PHP. You need this package if you install the php standalone package or a
webserver with php support (ie: apache-mod_php).

Alternatives

Package Version Architecture Repository
lib64php_common7-7.2.21-1.mga6.x86_64.rpm 7.2.21 x86_64 Mageia Core Backports
lib64php_common7-7.2.18-1.mga6.x86_64.rpm 7.2.18 x86_64 Mageia Core Backports
lib64php_common7-7.2.14-1.mga6.x86_64.rpm 7.2.14 x86_64 Mageia Core Backports
lib64php_common7-7.2.13-2.mga6.x86_64.rpm 7.2.13 x86_64 Mageia Core Backports
lib64php_common7-7.2.11-3.mga6.x86_64.rpm 7.2.11 x86_64 Mageia Core Backports
lib64php_common7 - - -

Requires

Name Value
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.11)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libc.so.6(GLIBC_2.8)(64bit) -
libcrypt.so.1()(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
liblzma.so.5()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libnsl.so.1()(64bit) -
libpcre.so.1()(64bit) -
libresolv.so.2()(64bit) -
libresolv.so.2(GLIBC_2.2.5)(64bit) -
librt.so.1()(64bit) -
libstdc++.so.6()(64bit) -
libxml2.so.2()(64bit) -
libxml2.so.2(LIBXML2_2.4.30)(64bit) -
libxml2.so.2(LIBXML2_2.5.2)(64bit) -
libxml2.so.2(LIBXML2_2.6.0)(64bit) -
libxml2.so.2(LIBXML2_2.6.11)(64bit) -
libxml2.so.2(LIBXML2_2.9.0)(64bit) -
libz.so.1()(64bit) -
php >= 3:7.2.20
php-ctype >= 3:7.2.20
php-filter >= 3:7.2.20
php-ftp >= 3:7.2.20
php-gettext >= 3:7.2.20
php-hash >= 3:7.2.20
php-ini >= 7.2.20
php-json >= 3:7.2.20
php-openssl >= 3:7.2.20
php-pcre >= 3:7.2.20
php-posix >= 3:7.2.20
php-session >= 3:7.2.20
php-sysvsem >= 3:7.2.20
php-sysvshm >= 3:7.2.20
php-tokenizer >= 3:7.2.20
php-xml >= 3:7.2.20
php-xmlreader >= 3:7.2.20
php-xmlwriter >= 3:7.2.20
php-zlib >= 3:7.2.20

Provides

Name Value
lib64php_common7 == 3:7.2.20-1.mga6
lib64php_common7(x86-64) == 3:7.2.20-1.mga6
libphp7_common.so.7()(64bit) -
php-pcre == 3:7.2.20
php-simplexml == 3:7.2.20

Conflicts

Name Value
lib64php5_common5 < 3:7.2.20
lib64php_common7 < 3:7.2.20

Obsoletes

Name Value
php-ZendFramework -
php-amf -
php-apacheaccessor -
php-auth_nds -
php-awl -
php-bbcode -
php-bloomy -
php-braille -
php-cairo -
php-cairo_wrapper -
php-cyrus -
php-dav -
php-dbx -
php-docblock -
php-doublemetaphone -
php-ecasound -
php-esmtp -
php-fam -
php-gearman < 1.1.3
php-gnutls -
php-haru -
php-hidef -
php-htscanner -
php-id3 -
php-inclued -
php-layersmenu -
php-libevent -
php-magickwand -
php-mcal < 0.6-51
php-mcal -
php-mdbtools -
php-ming -
php-mongo -
php-mssql -
php-netools -
php-newt -
php-oggvorbis -
php-optimizer -
php-pam -
php-pear-Horde -
php-pear-PHP_Parser -
php-pear-PHP_Parser_DocblockParser -
php-pluf -
php-sasl -
php-suhosin -
php-swish -
php-sybase_ct -
php-symfony-YAML -
php-syslog-ng -
php-tclink -
php-timezonedb -
php-txforward -
php-uploadprogress -
php-wbxml -

Download

Type URL
Mirror distrib-coffee.ipsl.jussieu.fr
Binary Package lib64php_common7-7.2.20-1.mga6.x86_64.rpm
Source Package php-7.2.20-1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core Backports repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64php_common7 rpm package:
    # urpmi lib64php_common7

Files

Path
/usr/lib64/libphp7_common.so.7
/usr/lib64/libphp7_common.so.7.0.0

Changelog

2019-07-04 - mokraemer <mokraemer> 3:7.2.20-1.mga6
+ Revision: 1418544
- new version 7.2.20
- new release 7.2.18
- update to php 7.2.17
- fix old lib name
- new version 7.2.16, with bugfixes
- new version 7.2.14
- Fix build noarch
- new version 7.2.13
- fix packaging error
- Fix added info on central package
- added a few hints for update
- move to correct destination
- added php-7.2.11 for backport
- import php7 for backport
+ zezinho <zezinho>
- try to fix oldlibname
2018-10-20 - wally <wally> 3:7.2.11-2.mga7
+ Revision: 1322964
- fix php-sqlite obsoletes
2018-10-12 - mokraemer <mokraemer> 3:7.2.11-1.mga7
+ Revision: 1319841
- new version 7.2.11
2018-09-13 - mokraemer <mokraemer> 3:7.2.10-1.mga7
+ Revision: 1258856
- new version 7.2.10
2018-08-25 - mokraemer <mokraemer> 3:7.2.9-2.mga7
+ Revision: 1254140
+ rebuild (emptylog)
2018-08-16 - mokraemer <mokraemer> 3:7.2.9-1.mga7
+ Revision: 1252055
- new release 7.2.9
2018-08-03 - mokraemer <mokraemer> 3:7.2.8-2.mga7
+ Revision: 1247154
- Bug mga#23385
2018-07-19 - mokraemer <mokraemer> 3:7.2.8-1.mga7
+ Revision: 1244310
- new version 7.2.8
2018-06-21 - mokraemer <mokraemer> 3:7.2.7-1.mga7
+ Revision: 1238679
- new version 7.2.7
2018-06-17 - luigiwalser <luigiwalser> 3:7.2.6-2.mga7
+ Revision: 1237489
- rebuild for gdbm

See Also

Package Description
lib64sane-hpaio1-3.19.1-1.mga6.x86_64.rpm SANE driver for scanners in HP's multi-function devices (from HPLIP)
lib64toxcore-devel-0.2.4-1.mga6.x86_64.rpm Development files for the Toxcore libraries
lib64toxcore2-0.2.4-1.mga6.x86_64.rpm The Toxcore library
mame-0.188-1.mga6.x86_64.rpm Multiple Arcade Machine Emulator
mame-data-0.188-1.mga6.noarch.rpm Data files used by MAME
mame-data-software-lists-0.188-1.mga6.noarch.rpm Software lists used by MAME
mame-doc-0.188-1.mga6.noarch.rpm Documentation for MAME
mame-tools-0.188-1.mga6.x86_64.rpm Additional tools for MAME
mgba-0.6.0-1.mga6.x86_64.rpm Fast and accurate Game Boy Advance emulator
mgba-qt-0.6.0-1.mga6.x86_64.rpm Qt 5 frontend for the mGBA emulator
nextcloud-14.0.10-1.mga6.noarch.rpm Open personal cloud
nextcloud-14.0.14-1.mga6.noarch.rpm Open personal cloud
nextcloud-14.0.4-4.mga6.noarch.rpm Open personal cloud
nextcloud-mysql-14.0.10-1.mga6.noarch.rpm MySQL database support for NextCloud
nextcloud-mysql-14.0.14-1.mga6.noarch.rpm MySQL database support for NextCloud
Advertisement
Advertisement