groovy-2.4.5-11.mga6.noarch.rpm


Advertisement

Description

groovy - Dynamic language for the Java Platform

Property Value
Distribution Mageia 6.0
Repository Mageia Core i586
Package name groovy
Package version 2.4.5
Package release 11.mga6
Package architecture noarch
Package type rpm
Installed size 165.16 KB
Download size 124.20 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Groovy is an agile and dynamic language for the Java Virtual Machine,
built upon Java with features inspired by languages like Python, Ruby and
Smalltalk.  It seamlessly integrates with all existing Java objects and
libraries and compiles straight to Java bytecode so you can use it anywhere
you can use Java.

Alternatives

Package Version Architecture Repository
groovy-2.4.5-11.mga6.noarch.rpm 2.4.5 noarch Mageia Core
groovy - - -

Requires

Name Value
config(groovy) == 2.4.5-11.mga6
groovy-ant == 2.4.5-11.mga6
groovy-bsf == 2.4.5-11.mga6
groovy-console == 2.4.5-11.mga6
groovy-docgenerator == 2.4.5-11.mga6
groovy-groovydoc == 2.4.5-11.mga6
groovy-groovysh == 2.4.5-11.mga6
groovy-jmx == 2.4.5-11.mga6
groovy-json == 2.4.5-11.mga6
groovy-jsr223 == 2.4.5-11.mga6
groovy-lib == 2.4.5-11.mga6
groovy-nio == 2.4.5-11.mga6
groovy-servlet == 2.4.5-11.mga6
groovy-sql == 2.4.5-11.mga6
groovy-swing == 2.4.5-11.mga6
groovy-templates == 2.4.5-11.mga6
groovy-test == 2.4.5-11.mga6
groovy-testng == 2.4.5-11.mga6
groovy-xml == 2.4.5-11.mga6
xpp3-minimal -

Provides

Name Value
appdata() -
appdata(groovy.appdata.xml) -
application() -
application(groovy.desktop) -
config(groovy) == 2.4.5-11.mga6
groovy == 2.4.5-11.mga6

Download

Type URL
Binary Package groovy-2.4.5-11.mga6.noarch.rpm
Source Package groovy-2.4.5-11.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install groovy rpm package:
    # urpmi groovy

Files

Path
/etc/groovy-starter.conf
/usr/bin/grape
/usr/bin/groovy
/usr/bin/groovyConsole
/usr/bin/groovyc
/usr/bin/groovydoc
/usr/bin/groovysh
/usr/bin/java2groovy
/usr/share/appdata/groovy.appdata.xml
/usr/share/applications/groovy.desktop
/usr/share/groovy/DISCLAIMER
/usr/share/groovy/LICENSE
/usr/share/groovy/NOTICE
/usr/share/groovy/bin/grape
/usr/share/groovy/bin/groovy
/usr/share/groovy/bin/groovyConsole
/usr/share/groovy/bin/groovyc
/usr/share/groovy/bin/groovydoc
/usr/share/groovy/bin/groovysh
/usr/share/groovy/bin/java2groovy
/usr/share/groovy/bin/startGroovy
/usr/share/groovy/conf/groovy-starter.conf
/usr/share/groovy/embeddable/groovy-all-2.4.5-indy.jar
/usr/share/groovy/embeddable/groovy-all-2.4.5.jar
/usr/share/groovy/grooid/groovy-2.4.5-grooid.jar
/usr/share/groovy/grooid/groovy-test-2.4.5-grooid.jar
/usr/share/groovy/indy/groovy-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-ant-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-bsf-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-console-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-docgenerator-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-groovydoc-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-groovysh-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-jmx-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-json-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-jsr223-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-nio-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-servlet-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-sql-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-swing-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-templates-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-test-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-testng-2.4.5-indy.jar
/usr/share/groovy/indy/groovy-xml-2.4.5-indy.jar
/usr/share/groovy/lib/ant-antlr.jar
/usr/share/groovy/lib/ant-junit.jar
/usr/share/groovy/lib/ant-launcher.jar
/usr/share/groovy/lib/ant.jar
/usr/share/groovy/lib/bsf.jar
/usr/share/groovy/lib/commons-cli.jar
/usr/share/groovy/lib/commons-logging.jar
/usr/share/groovy/lib/extra166y.jar
/usr/share/groovy/lib/gpars.jar
/usr/share/groovy/lib/groovy-2.4.5.jar
/usr/share/groovy/lib/groovy-ant-2.4.5.jar
/usr/share/groovy/lib/groovy-bsf-2.4.5.jar
/usr/share/groovy/lib/groovy-console-2.4.5.jar
/usr/share/groovy/lib/groovy-docgenerator-2.4.5.jar
/usr/share/groovy/lib/groovy-groovydoc-2.4.5.jar
/usr/share/groovy/lib/groovy-groovysh-2.4.5.jar
/usr/share/groovy/lib/groovy-jmx-2.4.5.jar
/usr/share/groovy/lib/groovy-json-2.4.5.jar
/usr/share/groovy/lib/groovy-jsr223-2.4.5.jar
/usr/share/groovy/lib/groovy-nio-2.4.5.jar
/usr/share/groovy/lib/groovy-servlet-2.4.5.jar
/usr/share/groovy/lib/groovy-sql-2.4.5.jar
/usr/share/groovy/lib/groovy-swing-2.4.5.jar
/usr/share/groovy/lib/groovy-templates-2.4.5.jar
/usr/share/groovy/lib/groovy-test-2.4.5.jar
/usr/share/groovy/lib/groovy-testng-2.4.5.jar
/usr/share/groovy/lib/groovy-xml-2.4.5.jar
/usr/share/groovy/lib/groovy.icns
/usr/share/groovy/lib/hamcrest-core.jar
/usr/share/groovy/lib/ivy.jar
/usr/share/groovy/lib/jansi.jar
/usr/share/groovy/lib/jcommander.jar
/usr/share/groovy/lib/jline.jar
/usr/share/groovy/lib/jsp-api.jar
/usr/share/groovy/lib/junit.jar
/usr/share/groovy/lib/multiverse-core.jar
/usr/share/groovy/lib/qdox.jar
/usr/share/groovy/lib/servlet-api.jar
/usr/share/groovy/lib/testng.jar
/usr/share/groovy/lib/xpp3-minimal.jar
/usr/share/groovy/lib/xstream.jar
/usr/share/groovy/licenses/antlr2-license.txt
/usr/share/groovy/licenses/asm-license.txt
/usr/share/groovy/licenses/hamcrest-license.txt
/usr/share/groovy/licenses/jline2-license.txt
/usr/share/groovy/licenses/jsr166y-license.txt
/usr/share/groovy/licenses/jsr223-license.txt
/usr/share/groovy/licenses/junit-license.txt
/usr/share/groovy/licenses/xstream-license.txt
/usr/share/pixmaps/groovy.png

Changelog

2017-05-19 - neoclust <neoclust> 2.4.5-11.mga6
+ Revision: 1103179
- Rebuild against new gradle
- Sync with fedora
2017-01-16 - daviddavid <daviddavid> 2.4.5-8.mga6
+ Revision: 1082011
- Backport fix for CVE-2016-6814 (mga{20121)
2016-03-02 - neoclust <neoclust> 2.4.5-7.mga6
+ Revision: 983296
- Add missing symlink to extra166y (Resolve: rhbz#1301952)
- Fix xpp3 symlink (Resolves: rhbz#1299674, thanks to Richard Chan)
- Second rebuild of the java stack
2016-02-23 - neoclust <neoclust> 2.4.5-2.mga6
+ Revision: 976251
- First rebuild of the java stack
- sync package groovy with fedora
+ umeabot <umeabot>
- Mageia 6 Mass Rebuild
2015-07-27 - luigiwalser <luigiwalser> 1.8.9-6.mga6
+ Revision: 858309
- add upstream patch to fix CVE-2015-3253
2015-05-15 - neoclust <neoclust> 1.8.9-5.mga5
+ Revision: 822125
- Fix upgrade from mga4
2015-01-08 - pterjan <pterjan> 1.8.9-4.mga5
+ Revision: 809334
- Rebuild to fix antlr dependency
2015-01-04 - alexl <alexl> 1.8.9-3.mga5
+ Revision: 808386
- Update desktop file (sync with Fedora Rawhide)
2014-12-27 - pterjan <pterjan> 1.8.9-2.mga5
+ Revision: 806416
- Clean rebuild
- Sync with Fedora 21 (update to 1.8.9)
2014-11-24 - anssi <anssi> 1.8.7-9.mga5
+ Revision: 798736
- fix wrong rpm require on jline, replacing with jline1 instead

See Also

Package Description
groovy-ant-2.4.5-11.mga6.noarch.rpm ant module for groovy
groovy-bsf-2.4.5-11.mga6.noarch.rpm bsf module for groovy
groovy-console-2.4.5-11.mga6.noarch.rpm console module for groovy
groovy-docgenerator-2.4.5-11.mga6.noarch.rpm docgenerator module for groovy
groovy-groovydoc-2.4.5-11.mga6.noarch.rpm groovydoc module for groovy
groovy-groovysh-2.4.5-11.mga6.noarch.rpm groovysh module for groovy
groovy-jmx-2.4.5-11.mga6.noarch.rpm jmx module for groovy
groovy-json-2.4.5-11.mga6.noarch.rpm json module for groovy
groovy-jsr223-2.4.5-11.mga6.noarch.rpm jsr223 module for groovy
groovy-lib-2.4.5-11.mga6.noarch.rpm Groovy JAR artifact
groovy-nio-2.4.5-11.mga6.noarch.rpm nio module for groovy
groovy-sandbox-1.8-4.mga6.noarch.rpm Groovy sandbox for executing untrusted Groovy scripts safely
groovy-sandbox-javadoc-1.8-4.mga6.noarch.rpm Javadoc for groovy-sandbox
groovy-servlet-2.4.5-11.mga6.noarch.rpm servlet module for groovy
groovy-sql-2.4.5-11.mga6.noarch.rpm sql module for groovy
Advertisement
Advertisement