libappstream-glib-devel-0.6.13-1.mga6.i586.rpm


Advertisement

Description

libappstream-glib-devel - Development files for appstream-glib

Property Value
Distribution Mageia 6.0
Repository Mageia Core i586
Package name libappstream-glib-devel
Package version 0.6.13
Package release 1.mga6
Package architecture i586
Package type rpm
Installed size 1.91 MB
Download size 143.27 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
The appstream-glib-devel package contains libraries and header files for
developing applications that use appstream-glib.

Alternatives

Package Version Architecture Repository
libappstream-glib-devel-0.7.6-1.mga6.i586.rpm 0.7.6 i586 Mageia Core Updates
libappstream-glib-devel - - -

Requires

Name Value
appstream-util -
devel(libappstream-glib) -
devel(libarchive) -
devel(libgcab-1.0) -
devel(libgdk_pixbuf-2.0) -
devel(libgio-2.0) -
devel(libglib-2.0) -
devel(libgmodule-2.0) -
devel(libgobject-2.0) -
devel(librpm) -
devel(librpmio) -
devel(libsoup-2.4) -
devel(libstemmer) -
devel(libuuid) -
devel(libyaml-0) -
libappstream-builder-gir1.0 == 0.6.13-1.mga6
libappstream-builder8 == 0.6.13-1.mga6
libappstream-glib-gir1.0 == 0.6.13-1.mga6
libappstream-glib8 == 0.6.13-1.mga6
pkgconfig -
pkgconfig(gdk-pixbuf-2.0) -
pkgconfig(glib-2.0) -
pkgconfig(gobject-2.0) -
pkgconfig(libarchive) -
pkgconfig(libgcab-1.0) -
pkgconfig(uuid) -

Provides

Name Value
appstream-glib-devel == 0.6.13-1.mga6
devel(libappstream-builder) -
devel(libappstream-glib) -
libappstream-glib-devel == 0.6.13-1.mga6
libappstream-glib-devel(x86-32) == 0.6.13-1.mga6
pkgconfig(appstream-builder) == 0.6.13
pkgconfig(appstream-glib) == 0.6.13

Conflicts

Name Value
appdata-tools < 0.1.9

Obsoletes

Name Value
libappstream-glib1.0-devel < 0.1.1-2

Download

Type URL
Binary Package libappstream-glib-devel-0.6.13-1.mga6.i586.rpm
Source Package appstream-glib-0.6.13-1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on "Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install libappstream-glib-devel rpm package:
    # urpmi libappstream-glib-devel

Files

Path
/usr/include/libappstream-builder/appstream-builder.h
/usr/include/libappstream-builder/asb-app.h
/usr/include/libappstream-glib/appstream-glib.h
/usr/include/libappstream-glib/as-app-builder.h
/usr/include/libappstream-glib/as-app.h
/usr/include/libappstream-glib/as-bundle.h
/usr/include/libappstream-glib/as-checksum.h
/usr/include/libappstream-glib/as-content-rating.h
/usr/include/libappstream-glib/as-enums.h
/usr/include/libappstream-glib/as-format.h
/usr/include/libappstream-glib/as-icon.h
/usr/include/libappstream-glib/as-image.h
/usr/include/libappstream-glib/as-inf.h
/usr/include/libappstream-glib/as-launchable.h
/usr/include/libappstream-glib/as-markup.h
/usr/include/libappstream-glib/as-node.h
/usr/include/libappstream-glib/as-problem.h
/usr/include/libappstream-glib/as-profile.h
/usr/include/libappstream-glib/as-provide.h
/usr/include/libappstream-glib/as-release.h
/usr/include/libappstream-glib/as-require.h
/usr/include/libappstream-glib/as-review.h
/usr/include/libappstream-glib/as-screenshot.h
/usr/include/libappstream-glib/as-store.h
/usr/include/libappstream-glib/as-suggest.h
/usr/include/libappstream-glib/as-tag.h
/usr/include/libappstream-glib/as-translation.h
/usr/include/libappstream-glib/as-utils.h
/usr/include/libappstream-glib/as-version.h
/usr/lib/libappstream-builder.so
/usr/lib/libappstream-glib.so
/usr/lib/pkgconfig/appstream-builder.pc
/usr/lib/pkgconfig/appstream-glib.pc
/usr/share/aclocal/appdata-xml.m4
/usr/share/aclocal/appstream-xml.m4
/usr/share/gettext/its/appdata.its
/usr/share/gettext/its/appdata.loc
/usr/share/gir-1.0/AppStreamBuilder-1.0.gir
/usr/share/gir-1.0/AppStreamGlib-1.0.gir
/usr/share/gtk-doc/html/appstream-glib/AsApp.html
/usr/share/gtk-doc/html/appstream-glib/AsBundle.html
/usr/share/gtk-doc/html/appstream-glib/AsChecksum.html
/usr/share/gtk-doc/html/appstream-glib/AsContentRating.html
/usr/share/gtk-doc/html/appstream-glib/AsFormat.html
/usr/share/gtk-doc/html/appstream-glib/AsIcon.html
/usr/share/gtk-doc/html/appstream-glib/AsImage.html
/usr/share/gtk-doc/html/appstream-glib/AsLaunchable.html
/usr/share/gtk-doc/html/appstream-glib/AsProblem.html
/usr/share/gtk-doc/html/appstream-glib/AsProvide.html
/usr/share/gtk-doc/html/appstream-glib/AsRelease.html
/usr/share/gtk-doc/html/appstream-glib/AsRequire.html
/usr/share/gtk-doc/html/appstream-glib/AsScreenshot.html
/usr/share/gtk-doc/html/appstream-glib/AsStore.html
/usr/share/gtk-doc/html/appstream-glib/AsTranslation.html
/usr/share/gtk-doc/html/appstream-glib/annotation-glossary.html
/usr/share/gtk-doc/html/appstream-glib/appstream-glib-as-enums.html
/usr/share/gtk-doc/html/appstream-glib/appstream-glib-as-markup.html
/usr/share/gtk-doc/html/appstream-glib/appstream-glib-as-node.html
/usr/share/gtk-doc/html/appstream-glib/appstream-glib-as-tag.html
/usr/share/gtk-doc/html/appstream-glib/appstream-glib-as-utils.html
/usr/share/gtk-doc/html/appstream-glib/appstream-glib-as-version.html
/usr/share/gtk-doc/html/appstream-glib/appstream-glib.devhelp2
/usr/share/gtk-doc/html/appstream-glib/home.png
/usr/share/gtk-doc/html/appstream-glib/index.html
/usr/share/gtk-doc/html/appstream-glib/left-insensitive.png
/usr/share/gtk-doc/html/appstream-glib/left.png
/usr/share/gtk-doc/html/appstream-glib/libappstream-glib.html
/usr/share/gtk-doc/html/appstream-glib/right-insensitive.png
/usr/share/gtk-doc/html/appstream-glib/right.png
/usr/share/gtk-doc/html/appstream-glib/style.css
/usr/share/gtk-doc/html/appstream-glib/up-insensitive.png
/usr/share/gtk-doc/html/appstream-glib/up.png
/usr/share/installed-tests/appstream-glib/appdata-validate.test
/usr/share/installed-tests/appstream-glib/destdir-check.test

Changelog

2017-05-13 - luigiwalser <luigiwalser> 0.6.13-1.mga6
+ Revision: 1100928
- 0.6.13
2017-04-14 - luigiwalser <luigiwalser> 0.6.12-1.mga6
+ Revision: 1096523
- 0.6.12
2017-03-29 - luigiwalser <luigiwalser> 0.6.11-1.mga6
+ Revision: 1095161
- 0.6.11
2017-03-23 - tv <tv> 0.6.10-2.mga6
+ Revision: 1094605
- BR appstream-util in devel pkg thus fixing missing typelib() deps in some pkgs
2017-03-09 - luigiwalser <luigiwalser> 0.6.10-1.mga6
+ Revision: 1090518
- 0.6.10
2017-02-17 - ngompa <ngompa> 0.6.8-1.mga6
+ Revision: 1086569
- Update to 0.6.8
2017-01-14 - luigiwalser <luigiwalser> 0.6.7-1.mga6
+ Revision: 1081683
- 0.6.7
2016-12-23 - luigiwalser <luigiwalser> 0.6.6-1.mga6
+ Revision: 1076650
- 0.6.6
2016-11-11 - ngompa <ngompa> 0.6.5-1.mga6
+ Revision: 1066365
- Upgrade to 0.6.5
2016-10-11 - ngompa <ngompa> 0.6.3-1.mga6
+ Revision: 1060118
- Upgrade to 0.6.3

See Also

Package Description
libappstream-glib-gir1.0-0.6.13-1.mga6.i586.rpm GObject Introspection interface description for appstream-glib
libappstream-glib8-0.6.13-1.mga6.i586.rpm Library for reading and writing AppStream metadata
libappstream4-0.10.6-1.mga6.i586.rpm Library for appstream
libappstreamqt-devel-0.10.6-1.mga6.i586.rpm Development files for appstream Qt5 bindings
libappstreamqt2-0.10.6-1.mga6.i586.rpm Qt5 bindings for appstream
libapr-devel-1.5.2-2.mga6.i586.rpm APR library development kit
libapr-util-devel-1.5.4-7.mga6.i586.rpm APR utility library development kit
libapr-util1_0-1.5.4-7.mga6.i586.rpm Apache Portable Runtime Utility library
libapr1_0-1.5.2-2.mga6.i586.rpm Apache Portable Runtime library
libapreq-devel-2.130.0-21.mga6.i586.rpm Development library and header files for the Apache Request Library
libapreq2_3-2.130.0-21.mga6.i586.rpm Apache Request Library
libapt-pkg-devel-0.5.15lorg3.94-26.mga6.i586.rpm Development files for apt
libapt-pkg4-0.5.15lorg3.94-26.mga6.i586.rpm Libraries for apt
libaqbanking-devel-5.5.1-2.mga6.i586.rpm Aqbanking development kit
libaqbanking34-5.5.1-2.mga6.i586.rpm A library for online banking functions and financial data import/export
Advertisement
Advertisement