libhawkey-devel-0.6.4-1.mga6.i586.rpm


Advertisement

Description

libhawkey-devel - A Library providing simplified C and Python API to libsolv

Distribution: Mageia 6.0
Repository: Mageia Core i586
Package name: libhawkey-devel
Package version: 0.6.4
Package release: 1.mga6
Package architecture: i586
Package type: rpm
Installed size: 39.06 KB
Download size: 17.21 KB
Official Mirror: distrib-coffee.ipsl.jussieu.fr
Development files for hawkey.

Alternatives

Provides

  • devel(libhawkey)
  • hawkey-devel == 0.6.4-1.mga6
  • libhawkey-devel == 0.6.4-1.mga6
  • libhawkey-devel(x86-32) == 0.6.4-1.mga6
  • pkgconfig(hawkey) == 0.6.4

Obsoletes

  • libhawkey-devel < 0.6.3-7

    Download

    Install Howto

    1. Enable Mageia Core repository on "Install and Remove Software"
    2. Update packages list:
      # urpmi.update -a
    3. Install libhawkey-devel rpm package:
      # urpmi libhawkey-devel

    Files

    • /usr/include/hawkey/advisory.h
    • /usr/include/hawkey/advisorypkg.h
    • /usr/include/hawkey/advisoryref.h
    • /usr/include/hawkey/errno.h
    • /usr/include/hawkey/goal.h
    • /usr/include/hawkey/nevra.h
    • /usr/include/hawkey/package.h
    • /usr/include/hawkey/packagelist.h
    • /usr/include/hawkey/packageset.h
    • /usr/include/hawkey/query.h
    • /usr/include/hawkey/reldep.h
    • /usr/include/hawkey/repo.h
    • /usr/include/hawkey/sack.h
    • /usr/include/hawkey/selector.h
    • /usr/include/hawkey/stringarray.h
    • /usr/include/hawkey/subject.h
    • /usr/include/hawkey/types.h
    • /usr/include/hawkey/util.h
    • /usr/include/hawkey/version.h
    • /usr/lib/libhawkey.so
    • /usr/lib/pkgconfig/hawkey.pc

    Changelog

    2017-03-23 - ngompa <ngompa> 0.6.4-1.mga6 + Revision: 1094580 - Update to 0.6.4 - Drop all merged patches

    2017-02-08 - ngompa <ngompa> 0.6.3-8.mga6 + Revision: 1085119 - Add support for preferring Provides (mga#18343, rhbz#1332830, rhbz#1096506)

    2016-11-27 - ngompa <ngompa> 0.6.3-7.mga6 + Revision: 1070469 - Permanently disable docs, add self-Obsoletes for removed files in devel subpackage

    2016-11-26 - ngompa <ngompa> 0.6.3-6.mga6 + Revision: 1070209 - Disable building Python bindings and docs for libdnf coexistence

    2016-09-03 - ngompa <ngompa> 0.6.3-5.mga6 + Revision: 1049962 - Add patch to let CMake handle default build type (rhbz#1332067)

    2016-08-26 - ngompa <ngompa> 0.6.3-4.mga6 + Revision: 1049005 - add patch to detect armv7hnl properly (rhbz#1368238)

    2016-05-24 - ngompa <ngompa> 0.6.3-3.mga6 + Revision: 1018192 - Add another patch to fix building on libsolv-0.6.21+ - Add patch to fix build with libsolv-0.6.21

    2016-05-14 - ngompa <ngompa> 0.6.3-2.mga6 + Revision: 1015183 - Add patch to enable URPM-style solution reordering

    2016-03-26 - ngompa <ngompa> 0.6.3-1.mga6 + Revision: 995662 - Update to 0.6.3 + umeabot <umeabot> - Mageia 6 Mass Rebuild

    2015-12-09 - neoclust <neoclust> 0.6.2-4.mga6 + Revision: 908993 - Do not install valgrind as long as openmpi do not build on ARM

    Advertisement
    Advertisement