libpcreposix-devel-8.40-2.mga6.i586.rpm


Advertisement

Description

libpcreposix-devel - Headers for pcreposix development

Property Value
Distribution Mageia 6.0
Repository Mageia Core i586
Package name libpcreposix-devel
Package version 8.40
Package release 2.mga6
Package architecture i586
Package type rpm
Installed size 9.52 KB
Download size 15.57 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Install this package if you want do compile applications using the pcre
library.
The header file for the POSIX-style functions is called pcreposix.h. The
official POSIX name is regex.h, but I didn't want to risk possible problems
with existing files of that name by distributing it that way. To use it with an
existing program that uses the POSIX API, it will have to be renamed or pointed
at by a link.

Alternatives

Package Version Architecture Repository
libpcreposix-devel-8.41-1.mga6.i586.rpm 8.41 i586 Mageia Core Updates
libpcreposix-devel - - -

Requires

Name Value
devel(libpcre) -
libpcre-devel == 8.40-2.mga6
libpcreposix1 == 8.40-2.mga6
pkgconfig -
pkgconfig(libpcre) -

Provides

Name Value
devel(libpcreposix) -
libpcreposix-devel == 8.40-2.mga6
libpcreposix-devel(x86-32) == 8.40-2.mga6
pcreposix-devel == 8.40-2.mga6
pkgconfig(libpcreposix) == 8.40

Conflicts

Name Value
pcre-devel < 8.32-4

Download

Type URL
Binary Package libpcreposix-devel-8.40-2.mga6.i586.rpm
Source Package pcre-8.40-2.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on "Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install libpcreposix-devel rpm package:
    # urpmi libpcreposix-devel

Files

Path
/usr/include/pcreposix.h
/usr/lib/libpcreposix.so
/usr/lib/pkgconfig/libpcreposix.pc
/usr/share/man/man3/pcreposix.3.xz

Changelog

See pcre-8.40-2.mga6.i586.rpm changelog.

See Also

Package Description
libpcreposix0-8.40-2.mga6.i586.rpm Perl-compatible regular expression library
libpcreposix1-8.40-2.mga6.i586.rpm Perl-compatible regular expression library
libpcsclite-devel-1.8.20-1.mga6.i586.rpm Muscle PCSC Framework for Linux development files
libpcsclite1-1.8.20-1.mga6.i586.rpm Muscle PCSC Framework for Linux libraries
libpcscspy0-1.8.20-1.mga6.i586.rpm PCSC Smart Card Library
libpe_rules2-1.1.16-1.mga6.i586.rpm Library used by the Pacemaker cluster resource manager and its clients
libpe_status4-1.1.16-1.mga6.i586.rpm Library used by the Pacemaker cluster resource manager and its clients
libpeas-data-1.20.0-2.mga6.i586.rpm Library for plugin handling - data files
libpeas-gir1.0-1.20.0-2.mga6.i586.rpm GObject Introspection interface description for libpeas
libpeas-gtk-gir1.0-1.20.0-2.mga6.i586.rpm GObject Introspection interface description for libpeas-gtk
libpeas-gtk1.0_0-1.20.0-2.mga6.i586.rpm Library plugin handling UI part
libpeas1.0-devel-1.20.0-2.mga6.i586.rpm Development files for libpeas
libpeas1.0_0-1.20.0-2.mga6.i586.rpm Library plugin handling
libpengine4-1.1.16-1.mga6.i586.rpm Library used by the Pacemaker cluster resource manager and its clients
libpfstools-devel-2.0.6-3.mga6.i586.rpm Files for development with PFS tools
Advertisement
Advertisement