libprotobuf9-2.6.1-3.mga6.i586.rpm


Advertisement

Description

libprotobuf9 - Runtime library for protobuf

Property Value
Distribution Mageia 6.1
Repository Mageia Core i586
Package name libprotobuf9
Package version 2.6.1
Package release 3.mga6
Package architecture i586
Package type rpm
Installed size 1.17 MB
Download size 362.42 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
Protocol Buffers are a way of encoding structured data in an efficient
yet extensible format. Google uses Protocol Buffers for almost all of
its internal RPC protocols and file formats.
Protocol buffers are a flexible, efficient, automated mechanism for
serializing structured data - think XML, but smaller, faster, and
simpler. You define how you want your data to be structured once, then
you can use special generated source code to easily write and read
your structured data to and from a variety of data streams and using a
variety of languages. You can even update your data structure without
breaking deployed programs that are compiled against the "old" format.
This package contains the shared protobuf library.

Alternatives

Package Version Architecture Repository
libprotobuf9 - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.10) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libz.so.1 -

Provides

Name Value
libprotobuf.so.9 -
libprotobuf9 == 2.6.1-3.mga6
libprotobuf9(x86-32) == 2.6.1-3.mga6

Obsoletes

Name Value
libprotobuf6 < 2.6.1-3.mga6

Download

Type URL
Binary Package libprotobuf9-2.6.1-3.mga6.i586.rpm
Source Package protobuf-2.6.1-3.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libprotobuf9 rpm package:
    # urpmi libprotobuf9

Files

Path
/usr/lib/libprotobuf.so.9
/usr/lib/libprotobuf.so.9.0.1
/usr/share/doc/libprotobuf9/CHANGES.txt
/usr/share/doc/libprotobuf9/CONTRIBUTORS.txt
/usr/share/doc/libprotobuf9/README.md
/usr/share/licenses/libprotobuf9/LICENSE

Changelog

2016-02-16 - umeabot <umeabot> 2.6.1-3.mga6
+ Revision: 962148
- Mageia 6 Mass Rebuild
2015-11-10 - pterjan <pterjan> 2.6.1-2.mga6
+ Revision: 900408
- Disable java subpackage on arm
2015-08-26 - daviddavid <daviddavid> 2.6.1-1.mga6
+ Revision: 869867
- new version: 2.6.1
- update URL and Source URL
- drop java-fixes patch, use pom macros instead
- update java BuildRequires
- build with xmvn
- update doc files lists
- switch to %license macro
2015-08-26 - daviddavid <daviddavid> 2.6.0-7.mga6
+ Revision: 869580
- rebuild for new gcc 5.2.1
2015-01-19 - daviddavid <daviddavid> 2.6.0-6.mga5
+ Revision: 811482
- build with xmvn
- use .mfiles generated during build
- update Requires for -java subpackage
- fix Group
2014-10-15 - umeabot <umeabot> 2.6.0-5.mga5
+ Revision: 740898
- Second Mageia 5 Mass Rebuild
- Mageia 5 Mass Rebuild
+ tv <tv>
- rebuild for missing pythoneggs deps
- s/uggests:/Recommends:/
2014-09-01 - luigiwalser <luigiwalser> 2.6.0-2.mga5
+ Revision: 670298
- library major is now 9
- 2.6.0
- rediff patch 2
+ pterjan <pterjan>
- Rebuild for new Python
- Do not BuildRequires maven-local when java build is disabled
2013-12-31 - dmorgan <dmorgan> 2.5.0-1.mga4
+ Revision: 563486
- New version ( needed by infinispan and hibernate4)
2013-10-22 - umeabot <umeabot> 2.4.1-7.mga4
+ Revision: 544923
- Mageia 4 Mass Rebuild
2013-10-15 - pterjan <pterjan> 2.4.1-6.mga4
+ Revision: 500483
- Rebuild to add different pythonegg provides for python 2 and 3

See Also

Package Description
libprotoc9-2.6.1-3.mga6.i586.rpm Protocol Buffers compiler shared library
libproxy-devel-0.4.14-1.mga6.i586.rpm Development files for libproxy
libproxy-gnome-0.4.14-1.mga6.i586.rpm Plugin for libproxy and gnome
libproxy-gxsettings-0.4.14-1.mga6.i586.rpm Helper utility for libproxy gnome support
libproxy-kde-0.4.14-1.mga6.i586.rpm Plugin for libproxy and kde
libproxy-networkmanager-0.4.14-1.mga6.i586.rpm Plugin for libproxy and NetworkManager
libproxy-pacrunner-0.4.14-1.mga6.i586.rpm Plugin for libproxy and PacRunner
libproxy-perl-0.4.14-1.mga6.i586.rpm Perl bindings for libproxy
libproxy-utils-0.4.14-1.mga6.i586.rpm Binary to test libproxy
libproxy-webkit-0.4.14-1.mga6.i586.rpm Plugin for libproxy and webkit
libproxy1-0.4.14-1.mga6.i586.rpm A library handling all the details of proxy configuration
libproxychains3-3.1-4.mga6.i586.rpm Provides proxy support to any application
libpsiconv-devel-0.9.8-26.mga6.i586.rpm PSION 5(MX) file format data conversion library
libpsiconv6-0.9.8-26.mga6.i586.rpm PSION 5(MX) file format data conversion library
libpslib-devel-0.4.5-10.mga6.i586.rpm Static library and header files for the PSlib library
Advertisement
Advertisement