libsfml2.4-2.4.2-1.mga6.i586.rpm


Advertisement

Description

libsfml2.4 - Dynamic libraries from sfml

Property Value
Distribution Mageia 6.0
Repository Mageia Core i586
Package name libsfml2.4
Package version 2.4.2
Package release 1.mga6
Package architecture i586
Package type rpm
Installed size 654.54 KB
Download size 243.99 KB
Official Mirror distrib-coffee.ipsl.jussieu.fr
SFML is a portable and easy to use multimedia API written in C++.
You can see it as a modern, object-oriented alternative to SDL.
SFML is composed of several packages to perfectly suit your needs.
You can use SFML as a minimal windowing system to interface with OpenGL,
or as a fully-featured multimedia library for building games or
interactive programs.

Alternatives

Package Version Architecture Repository
libsfml2.4 - - -

Requires

Name Value
libFLAC.so.8 -
libGL.so.1 -
libX11.so.6 -
libXrandr.so.2 -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.15) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libfreetype.so.6 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libjpeg.so.8 -
libjpeg.so.8(LIBJPEG_8.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libogg.so.0 -
libopenal.so.1 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
librt.so.1 -
librt.so.1(GLIBC_2.2) -
libsfml-system.so.2.4 -
libsfml-window.so.2.4 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libudev.so.1 -
libudev.so.1(LIBUDEV_183) -
libvorbis.so.0 -
libvorbisenc.so.2 -
libvorbisfile.so.3 -

Provides

Name Value
libsfml-audio.so.2.4 -
libsfml-graphics.so.2.4 -
libsfml-network.so.2.4 -
libsfml-system.so.2.4 -
libsfml-window.so.2.4 -
libsfml2.4 == 2.4.2-1.mga6
libsfml2.4(x86-32) == 2.4.2-1.mga6
sfml == 2.4.2-1.mga6

Download

Type URL
Binary Package libsfml2.4-2.4.2-1.mga6.i586.rpm
Source Package sfml-2.4.2-1.mga6.src.rpm

Install Howto

  1. Enable Mageia Core repository on "Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install libsfml2.4 rpm package:
    # urpmi libsfml2.4

Files

Path
/usr/lib/libsfml-audio.so.2.4
/usr/lib/libsfml-audio.so.2.4.2
/usr/lib/libsfml-graphics.so.2.4
/usr/lib/libsfml-graphics.so.2.4.2
/usr/lib/libsfml-network.so.2.4
/usr/lib/libsfml-network.so.2.4.2
/usr/lib/libsfml-system.so.2.4
/usr/lib/libsfml-system.so.2.4.2
/usr/lib/libsfml-window.so.2.4
/usr/lib/libsfml-window.so.2.4.2

Changelog

2017-02-12 - akien <akien> 2.4.2-1.mga6
+ Revision: 1085913
- Version 2.4.2
2016-11-13 - akien <akien> 2.4.1-1.mga6
+ Revision: 1067054
- Version 2.4.1, major 2.4
2016-01-12 - akien <akien> 2.3.2-1.mga6
+ Revision: 922163
- Version 2.3.2
2015-08-22 - akien <akien> 2.3-3.mga6
+ Revision: 868121
- Rebuild for gcc 5.2.1
2015-06-25 - fwang <fwang> 2.3-2.mga6
+ Revision: 842813
+ rebuild (emptylog)
2015-06-24 - akien <akien> 2.3-1.mga6
+ Revision: 842155
- Version 2.3
o sndfile is dropped, and ogg, flac and vorbis are used instead
o GLU is dropped (since 2.1)
o GLEW is replaced by glLoadGen loader
2015-02-08 - akien <akien> 2.2-1.mga5
+ Revision: 814212
- Version 2.2
- Do not build and package the documentation
2015-01-31 - akien <akien> 2.1-9.mga5
+ Revision: 812928
- Obsolete sfml2 SRPM
- Drop hack to make SFML2 parallel installable with SFML1.6, the latter was dropped
- Obsolete all previous SFML1.6 devel packages
- Rename to "sfml", the previous sfml 1.6 package has been obsoleted
2014-10-15 - umeabot <umeabot> 2.1-8.mga5
+ Revision: 739140
- Second Mageia 5 Mass Rebuild
2014-09-16 - umeabot <umeabot> 2.1-7.mga5
+ Revision: 689125
- Mageia 5 Mass Rebuild

See Also

Package Description
libsgutils-devel-1.42-1.mga6.i586.rpm Development library and header files for the sgutils library
libsgutils2-1.42-1.mga6.i586.rpm Shared library for sg3_utils
libshadowsocks-devel-2.4.3-5.mga6.i586.rpm Development headers for shadowsocks-libev
libshadowsocks1-2.4.3-5.mga6.i586.rpm A lightweight and secure socks5 proxy
libshairplay-devel-0.9.0-0.git20160101.1.mga6.i586.rpm Headers for libshairplay development
libshairplay0-0.9.0-0.git20160101.1.mga6.i586.rpm Shared library of shairplay
libshairport-devel-1.2.1-0.git20120111.7.mga6.i586.rpm Headers for libshairport development
libshairport1-1.2.1-0.git20120111.7.mga6.i586.rpm Shared library of libshairport
libshiboken1-1.2.2-10.mga6.i586.rpm Shiboken Generator core lib
libshorturlpluginprivate5-16.12.3-1.mga6.i586.rpm Runtime library for kdepim-addons
libshout-devel-2.4.1-1.mga6.i586.rpm Headers for developing programs that will use libshout
libshout-idjc-devel-2.4.1-1.mga6.i586.rpm Development files for libshout with extensions for IDJC
libshout-idjc3-2.4.1-1.mga6.i586.rpm Libshout with extensions for IDJC
libshout3-2.4.1-1.mga6.i586.rpm Main library for libshout
libshp-devel-1.3.0-10.mga6.i586.rpm API in "C" for Shapefile handling
Advertisement
Advertisement